Troubleshooting Help

Hello,

I am new to Allstar so please be gentle.

I have setup my Allstar node with a raspberry pi 3, Alinco D135 and the RIM-Alinco interface. The node is recognized online through Allstarlink. I have Echolink up and running without a problem.

The issue is this: my DTMF codes dont work when I key the radio with my HT. When I have someone connect to my node, he says its all static. When I run the simpleusb-tune menu, I go to the visual graph with rx. When I key my HT, the graph disappears, sound comes through the radio and then when I release the PTT the graph reappears again.

Any help would be appreciated. I think I have this about 99% setup correctly?

Thanks!

Ryan, KF8IV

When I key my HT, the graph disappears, sound comes through the radio and then when I release the PTT the graph reappears
again.
I’m not sure I understand this. When you key your radio, and you have the volume on the DR-135 turned up, do you hear normal
audio coming from the radio’s speaker? If you get garbled audio from the 135’s speaker, something is wrong with the 135 or
your HT.

I’m not sure what you mean by the “graph disappears.” do you mean the video disappears, or that the indication on the bar
graph disappears?

Could you have the node programmed for full-duplex in the AllStar config files and thus the DR-135 is going into transmit
mode in response to an incoming signal?

Scott

Scott Zimmerman
Amateur Radio Call N3XCC
474 Barnett Road
Boswell, PA 15531

···

On 3/21/2020 1:23 PM, Ryan Hartnett via AllStarLink Discussion Groups wrote:

[KF8IV] KF8IV https://community.allstarlink.org/u/kf8iv
March 21

Hello,

I am new to Allstar so please be gentle.

I have setup my Allstar node with a raspberry pi 3, Alinco D135 and the RIM-Alinco interface. The node is recognized online
through Allstarlink. I have Echolink up and running without a problem.

The issue is this: my DTMF codes dont work when I key the radio with my HT. When I have someone connect to my node, he says
its all static. When I run the simpleusb-tune menu, I go to the visual graph with rx. When I key my HT, the graph disappears,
sound comes through the radio and then when I release the PTT the graph reappears again.

Any help would be appreciated. I think I have this about 99% setup correctly?

Thanks!

Ryan, KF8IV


Visit Topic https://community.allstarlink.org/t/troubleshooting-help/16688/1 or reply to this email to respond.

You are receiving this because you enabled mailing list mode.

To unsubscribe from these emails, click here
https://community.allstarlink.org/email/unsubscribe/9f9e31d6212dd5d46cd381cffab2e2bd7101b013d7685e81ab95a38ab1973f18.

Hello,

Yes, sorry. The ASCII graph disappears when I PTT.

I hear audio coming from the radios speaker when I key it.

I do not have it set to duplex. Its set to partial simplex I think it was #1.

Ryan,

Sounds like a simple configuration settings issue.

I would follow the directions provided by the folks that you bought the RIM-Alinco from.

If they did not provide directions I would contact them directly.

I am sure that they have a basic configuration setting instructions for their RIM-Alinco to get you up and running easily.

73

Marshall - ke6pcv

···

From: Ryan Hartnett via AllStarLink Discussion Groups [mailto:noreply@community.allstarlink.org]
Sent: Saturday, March 21, 2020 10:24 AM
To: ke6pcv@cal-net.org
Subject: [AllStarLink Discussion Groups] [App_rpt-users] Troubleshooting Help

KF8IV
March 21

Hello,

I am new to Allstar so please be gentle.

I have setup my Allstar node with a raspberry pi 3, Alinco D135 and the RIM-Alinco interface. The node is recognized online through Allstarlink. I have Echolink up and running without a problem.

The issue is this: my DTMF codes dont work when I key the radio with my HT. When I have someone connect to my node, he says its all static. When I run the simpleusb-tune menu, I go to the visual graph with rx. When I key my HT, the graph disappears, sound comes through the radio and then when I release the PTT the graph reappears again.

Any help would be appreciated. I think I have this about 99% setup correctly?

Thanks!

Ryan, KF8IV


Visit Topic or reply to this email to respond.

You are receiving this because you enabled mailing list mode.

To unsubscribe from these emails, click here.

I gave them a call and left message.

Fingers crossed!

Ryan

You probably need to turn off the full duplex setting in rpt.conf and make it a simplex.

Edit your rpt.conf and change

duplex=3

to

duplex =1

reboot the node and see if that helps.

The duplex key/value pairs sets the duplex mode for desired radio operation. Duplex mode 2 is the default if none specified.

Duplex Mode

Description

0

Half duplex with no telemetry tones or hang time. Special Case: Full duplex if linktolink is set to yes. This mode is preferred when interfacing with an external multiport repeater controller. Comment out idrecording and idtalkover to suppress IDs.

1

Half duplex with telemetry tones and hang time. Does not repeat audio. This mode is preferred when interfacing a simplex node.

2

Full Duplex with telemetry tones and hang time. This mode is preferred when interfacing a repeater.

3

Full Duplex with telemetry tones and hang time, but no repeated audio. See details

4

Full Duplex with telemetry tones and hang time. Repeated audio only when the autopatch is down.

Sample:

duplex = 0 ; 0 = Half duplex with no telemetry tones or hang time.

73

Marshall - ke6pcv

···

From: Ryan Hartnett via AllStarLink Discussion Groups [mailto:noreply@community.allstarlink.org]
Sent: Saturday, March 21, 2020 10:46 AM
To: ke6pcv@cal-net.org
Subject: [AllStarLink Discussion Groups] [App_rpt-users] Troubleshooting Help

KF8IV
March 21

Hello,

Yes, sorry. The ASCII graph disappears when I PTT.

I hear audio coming from the radios speaker when I key it.

I do not have it set to duplex. Its set to partial simplex I think it was #1.


Visit Topic or reply to this email to respond.


In Reply To

N3xcc
March 21

When I key my HT, the graph disappears, sound comes through the radio and then when I release the PTT the graph reappears again. I’m not sure I understand this. When you key your radio, and you have the volume on the DR-135 turned up, do you hear normal audio coming from the radio’s speaker? If …

Previous Replies

N3xcc
March 21

When I key my HT, the graph disappears, sound comes through the radio and then when I release the PTT the graph reappears
again.
I’m not sure I understand this. When you key your radio, and you have the volume on the DR-135 turned up, do you hear normal
audio coming from the radio’s speaker? If you get garbled audio from the 135’s speaker, something is wrong with the 135 or
your HT.

I’m not sure what you mean by the “graph disappears.” do you mean the video disappears, or that the indication on the bar
graph disappears?

Could you have the node programmed for full-duplex in the AllStar config files and thus the DR-135 is going into transmit
mode in response to an incoming signal?

Scott

Scott Zimmerman
Amateur Radio Call N3XCC
474 Barnett Road
Boswell, PA 15531

··· (click for more details)

KF8IV
March 21

Hello,

I am new to Allstar so please be gentle.

I have setup my Allstar node with a raspberry pi 3, Alinco D135 and the RIM-Alinco interface. The node is recognized online through Allstarlink. I have Echolink up and running without a problem.

The issue is this: my DTMF codes dont work when I key the radio with my HT. When I have someone connect to my node, he says its all static. When I run the simpleusb-tune menu, I go to the visual graph with rx. When I key my HT, the graph disappears, sound comes through the radio and then when I release the PTT the graph reappears again.

Any help would be appreciated. I think I have this about 99% setup correctly?

Thanks!

Ryan, KF8IV


Visit Topic or reply to this email to respond.

You are receiving this because you enabled mailing list mode.

To unsubscribe from these emails, click here.

That’s sounds like you have the receive audio connected to discriminator audio out of the Alinco. Is there another pin that has squelched audio? If so try that as it would be your best option. If there is no other pin you can use for audio output, try using simple-tune-menu to set de-emphasis to on. That may correct the audio characteristics to help the DTMF issue. Also it will probably make your audio sound less tinny to connected nodes.

Another thing that will often help DTMF decoding is to turn on the CTCSS Rx filter.

Ryan,

I do not think you have a choice with the RIM-Alinco, the unit comes pre-wired to discriminator audio pin only.

Looking at the site, here are the suggested settings using the RIM-Alinco and SimpleUSB.

Starting Values for audio levels:

TX = 400

RX = 460

carrierfrom = usb
ctcssfrom = no
txmixa = voice
txmixb = no
deemphasis = yes
plfilter = Yes
rxboost = 0
txboost = 0

Marshall - ke6pcv

···

From: Tim Sawyer via AllStarLink Discussion Groups [mailto:noreply@community.allstarlink.org]
Sent: Saturday, March 21, 2020 12:34 PM
To: ke6pcv@cal-net.org
Subject: [AllStarLink Discussion Groups] [App_rpt-users] Troubleshooting Help

wd6awp ASL Admin
March 21

That’s sounds like you have the receive audio connected to discriminator audio out of the Alinco. Is there another pin that has squelched audio? If so try that as it would be your best option. If there is no other pin you can use for audio output, try using simple-tune-menu to set de-emphasis to on. That may correct the audio characteristics to help the DTMF issue. Also it will probably make your audio sound less tinny to connected nodes.

Another thing that will often help DTMF decoding is to turn on the CTCSS Rx filter.


Visit Topic or reply to this email to respond.


Previous Replies

KE6PCV ASL Admin
March 21

You probably need to turn off the full duplex setting in rpt.conf and make it a simplex.

Edit your rpt.conf and change

duplex=3

to

duplex =1

reboot the node and see if that helps.

The duplex key/value pairs sets the duplex mode for desired radio operation. Duplex mode 2 is the default if none specified.

Duplex Mode

Description

0

Half duplex with no telemetry tones or hang time. Special Case: Full duplex if linktolink is set to yes. This mode is preferred when interfacing with an external multiport repeater controller. Comment out idrecording and idtalkover to suppress IDs.

1

Half duplex with telemetry tones and hang time. Does not repeat audio. This mode is preferred when interfacing a simplex node.

2

Full Duplex with telemetry tones and hang time. This mode is preferred when interfacing a repeater.

3

Full Duplex with telemetry tones and hang time, but no repeated audio. See details

4

Full Duplex with telemetry tones and hang time. Repeated audio only when the autopatch is down.

Sample:

duplex = 0 ; 0 = Half duplex with no telemetry tones or hang time.

73

Marshall - ke6pcv

··· (click for more details)

KF8IV
March 21

I gave them a call and left message.

Fingers crossed!

Ryan

KE6PCV ASL Admin
March 21

Ryan,

Sounds like a simple configuration settings issue.

I would follow the directions provided by the folks that you bought the RIM-Alinco from.

If they did not provide directions I would contact them directly.

I am sure that they have a basic configuration setting instructions for their RIM-Alinco to get you up and running easily.

73

Marshall - ke6pcv

··· (click for more details)

KF8IV
March 21

Hello,

Yes, sorry. The ASCII graph disappears when I PTT.

I hear audio coming from the radios speaker when I key it.

I do not have it set to duplex. Its set to partial simplex I think it was #1.

N3xcc
March 21

When I key my HT, the graph disappears, sound comes through the radio and then when I release the PTT the graph reappears
again.
I’m not sure I understand this. When you key your radio, and you have the volume on the DR-135 turned up, do you hear normal
audio coming from the radio’s speaker? If you get garbled audio from the 135’s speaker, something is wrong with the 135 or
your HT.

I’m not sure what you mean by the “graph disappears.” do you mean the video disappears, or that the indication on the bar
graph disappears?

Could you have the node programmed for full-duplex in the AllStar config files and thus the DR-135 is going into transmit
mode in response to an incoming signal?

Scott

Scott Zimmerman
Amateur Radio Call N3XCC
474 Barnett Road
Boswell, PA 15531

··· (click for more details)


Visit Topic or reply to this email to respond.

You are receiving this because you enabled mailing list mode.

To unsubscribe from these emails, click here.