Alternate IAX port

This does not appear to have been discussed for quite a while. I have read everything that a search of the thread title shows and performed all of the recommended solutions, and I still cannot connect from WAN or LAN.

The situation is this. I am running two Asterisk servers on the same LAN, but not the same machine. I setup two servers at allstarlink.org with ports of 4569 and 4568, and have linked the two nodes to the corresponding servers.

512190 is port 4569
512192 is port 4568

After setting up the physical nodes and setting the proper port forwarding (I do networking for a living), 512190 (4569) can be reached from WAN; 512192 (4568) cannot be reached from WAN. Both nodes are capable of connecting out to WAN.

An Allstar DNS search returns all of the proper information for 512192:

512192 W4EAE Cayce SC DNS DNS radio@172.75.169.33:4568/512192,172.75.169.33

Before going any further, I wanted to make sure than 512192 was reachable by LAN. It is not. 512190 cannot connect to 512192, but 512192 can connect to 512190.

This tells me that the problem is local to the 512192 (4568) installation.

Here are the pertinent parts of my *.conf files:

iax.conf of 512192:
bindport = 4568

rpt.conf of 512192:
[nodes]
512192 = radio@127.0.0.1/512192,NONE ; This must be changed to your node number
515190 = radio@192.168.1.160:4569/512190,NONE

rpt.conf of 512190:
512190 = radio@127.0.0.1/512190,NONE
512192 = radio@192.168.1.215:4568/512192,NONE

What am I missing?

Ryan,

I encountered this issue once. It must have been a hiccup in the
routing. My solution was to enter the actual node IP in place of the
12.0.0.1’s and reload rpt.conf. Made no sense but it worked after that.
Why it didn’t work the first time using the 12.0.0.1 is beyond me.

With other nodes I tied together the problem never occurred?

Larry - N7FM

···

On 3/13/20 7:10 AM, Ryan Matthew Headley via AllStarLink Discussion Groups wrote:

[Ryan_Matthew_Headley] Ryan_Matthew_Headley
https://community.allstarlink.org/u/ryan_matthew_headley
March 13

This does not appear to have been discussed for quite a while. I have
read everything that a search of the thread title shows and performed
all of the recommended solutions, and I still cannot connect from WAN
/or/ LAN.

The situation is this. I am running two Asterisk servers on the same
LAN, but not the same machine. I setup two servers at allstarlink.org
http://allstarlink.org with ports of 4569 and 4568, and have linked
the two nodes to the corresponding servers.

512190 is port 4569
512192 is port 4568

After setting up the physical nodes and setting the proper port
forwarding (I do networking for a living), 512190 (4569) can be reached
from WAN; 512192 (4568) cannot be reached from WAN. Both nodes are
capable of connecting out to WAN.

An Allstar DNS search returns all of the proper information for 512192:

512192 W4EAE Cayce SC DNS DNS radio@172.75.169.33:4568/512192,172.75.169.33

Before going any further, I wanted to make sure than 512192 was
reachable by LAN. It is not. 512190 cannot connect to 512192, but 512192
can connect to 512190.

This tells me that the problem is local to the 512192 (4568) installation.

Here are the pertinent parts of my *.conf files:

iax.conf of 512192:
bindport = 4568

rpt.conf of 512192:
[nodes]
512192 = radio@127.0.0.1 mailto:radio@127.0.0.1/512192,NONE ; This
must be changed to your node number
515190 = radio@192.168.1.160:4569/512190,NONE

rpt.conf of 512190:
512190 = radio@127.0.0.1 mailto:radio@127.0.0.1/512190,NONE
512192 = radio@192.168.1.215:4568/512192,NONE

What am I missing?


Visit Topic
https://community.allstarlink.org/t/alternate-iax-port/16560/1 or
reply to this email to respond.

You are receiving this because you enabled mailing list mode.

To unsubscribe from these emails, click here
https://community.allstarlink.org/email/unsubscribe/f8ef4703045de3673df8a7abcfeca027c488ab3cd0ccb069528fe555fa87ffdf.

Take a look at this document and be sure to put the bindport= setting right at the top of the [general] stanza.

These instructions are helpful, but unfortunately do not solve the problem.

···

Ryan Matthew Headley
1705 Granby Road
Cayce, SC 29033 USA

mobile - +1803-386-1799

Hi Ryan,
I have the same problem. 'iax2 show registry ’ command in CLI shows it is registered but cannot get it to connect.

I have tried several fresh installs, setting everything accord to ALL the information listed in this thread and others that I have found, using any port other than 4569 for the X86 image does not work for incoming connections–even on LAN. The software simply will not listen at any other port number. I checked iptables and the it does not appear to be inhibiting anything.

The only workaround I have been able to find that works is port translation from the router. This requires two separate machines–one for each node. Both are listening on 4569, but the router sends incoming from 4569 to 4569 on once machine and 4568 to 4569 on the other.

Ryan,

Two things to verify…

Are you certain that your local Nodes IAX port matches what is set up on
the Allstarlink Portal (server tab). Plus that UDP port is that Port
number port-forwarded in your router to the proper LAN IP address of you
Allstar Node?

If you are attempting to connect 2 servers together on the same LAN the
IAX ports should be different. Each others routing information should
exist in the opposite NODES Section in rpt.conf file.

Larry - N7FM

···

On 3/19/20 8:45 AM, Ryan Matthew Headley via AllStarLink Discussion Groups wrote:

[Ryan_Matthew_Headley] Ryan_Matthew_Headley
https://community.allstarlink.org/u/ryan_matthew_headley
March 19

I have tried several fresh installs, setting everything accord to ALL
the information listed in this thread and others that I have found,
using any port other than 4569 for the X86 image does not work for
incoming connections–even on LAN. The software simply will not listen at
any other port number. I checked iptables and the it does not appear to
be inhibiting anything.

The only workaround I have been able to find that works is port
translation from the router. This requires two separate machines–one for
each node. Both are listening on 4569, but the router sends incoming
from 4569 to 4569 on once machine and 4568 to 4569 on the other.


Visit Topic
https://community.allstarlink.org/t/alternate-iax-port/16560/6 or
reply to this email to respond.


    Previous Replies

[G8HAV] G8HAV https://community.allstarlink.org/u/g8hav
March 18

Hi Ryan,
I have the same problem. 'iax2 show registry ’ command in CLI shows it
is registered but cannot get it to connect.

[Ryan_Matthew_Headley] Ryan_Matthew_Headley
https://community.allstarlink.org/u/ryan_matthew_headley
March 16

These instructions are helpful, but unfortunately do not solve the problem.

··· (click for more details)
https://community.allstarlink.org/t/alternate-iax-port/16560/4
[wd6awp] wd6awp https://community.allstarlink.org/u/wd6awp ASL Admin
March 13

Take a look at this document and be sure to put the bindport= setting
right at the top of the [general] stanza.

wiki.allstarlink.org
https://wiki.allstarlink.org/w/images/0/0c/ASL_two_servers_one_netwrok.pdf

https://wiki.allstarlink.org/w/images/0/0c/ASL_two_servers_one_netwrok.pdf

  ASL_two_servers_one_netwrok.pdf
  <https://wiki.allstarlink.org/w/images/0/0c/ASL_two_servers_one_netwrok.pdf>

56.62 KB

[larry] larry https://community.allstarlink.org/u/larry
March 13

Ryan,

I encountered this issue once. It must have been a hiccup in the
routing. My solution was to enter the actual node IP in place of the
12.0.0.1’s and reload rpt.conf. Made no sense but it worked after that.
Why it didn’t work the first time using the 12.0.0.1 is beyond me.

With other nodes I tied together the problem never occurred?

Larry - N7FM

··· (click for more details)
https://community.allstarlink.org/t/alternate-iax-port/16560/2
[Ryan_Matthew_Headley] Ryan_Matthew_Headley
https://community.allstarlink.org/u/ryan_matthew_headley
March 13

This does not appear to have been discussed for quite a while. I have
read everything that a search of the thread title shows and performed
all of the recommended solutions, and I still cannot connect from WAN
/or/ LAN.

The situation is this. I am running two Asterisk servers on the same
LAN, but not the same machine. I setup two servers at allstarlink.org
http://allstarlink.org with ports of 4569 and 4568, and have linked
the two nodes to the corresponding servers.

512190 is port 4569
512192 is port 4568

After setting up the physical nodes and setting the proper port
forwarding (I do networking for a living), 512190 (4569) can be reached
from WAN; 512192 (4568) cannot be reached from WAN. Both nodes are
capable of connecting out to WAN.

An Allstar DNS search returns all of the proper information for 512192:

512192 W4EAE Cayce SC DNS DNS radio@172.75.169.33:4568/512192,172.75.169.33

Before going any further, I wanted to make sure than 512192 was
reachable by LAN. It is not. 512190 cannot connect to 512192, but 512192
can connect to 512190.

This tells me that the problem is local to the 512192 (4568) installation.

Here are the pertinent parts of my *.conf files:

iax.conf of 512192:
bindport = 4568

rpt.conf of 512192:
[nodes]
512192 = radio@127.0.0.1 mailto:radio@127.0.0.1/512192,NONE ; This
must be changed to your node number
515190 = radio@192.168.1.160:4569/512190,NONE

rpt.conf of 512190:
512190 = radio@127.0.0.1 mailto:radio@127.0.0.1/512190,NONE
512192 = radio@192.168.1.215:4568/512192,NONE

What am I missing?


Visit Topic
https://community.allstarlink.org/t/alternate-iax-port/16560/6 or
reply to this email to respond.

You are receiving this because you enabled mailing list mode.

To unsubscribe from these emails, click here
https://community.allstarlink.org/email/unsubscribe/786a17ac4ab6b548389ce6897b14ffd34926f94242af726b3bffc6db7ae75045.

I can confirm that everything you have suggested is properly configured.

Ryan,

What does your bindaddr = contain? believe 0.0.0.0 allows all.

I have tried the bind address connected out, as the actual LAN IP, and as 0.0.0.0 to no avail.

···

On Fri, 20 Mar 2020, 13:02 Larry via AllStarLink Discussion Groups, noreply@community.allstarlink.org wrote:


larry

    March 20

Ryan,

What does your bindaddr = contain? believe 0.0.0.0 allows all.


Visit Topic or reply to this email to respond.

To unsubscribe from these emails, click here.

Boy you do have a mystery Ryan.

The only other workaround I could try would be as I mentioned earlier is
to do away with the the 12.0.0.1 routing withing Allstar and switch the
Nodes section to the actual IP address and port number assigned to each
[nodes] listing.

rpt.conf of 512192:
512192 = radio@192.168.1.215:4568/512192,NONE
515190 = radio@192.168.1.160:4569/512190,NONE

rpt.conf of 512190:
512190 = radio@192.168.1.160:4569/512190,NONE
512192 = radio@192.168.1.215:4568/512192,NONE

I know that you aren’t supposed to have to do this but when I had your
issue it was what worked for me. Probably something in my PFsense router
that had a hic-cup.

The only other thing I can see that is different in your set up from
most older nodes is the fact that it is using NNx 6 digit numbers. Since
I have never used NNx numbers on any of my systems I may be all wet.
However… the Hamvoip Group made a comment for some users using their
version of Allstar… Don’t have a clue if there is something else that
need to be added/dealt with when using the your version of Allstar…

(Paste from Hamvoip about NNx type number usage)

Here is an example of the importance of updating. If you are using 6 digit
nodes numbers and you cannot connect to a particular node or they cannot
connect to you it is probably because that node has not updated in a long
time and is rejecting your node number. Until we made the update change to
6 digit node number capability last year the code would not accept more
than a 5 digit node number. So if you have not updated and someone
complains they cannot connect to you ask if they are using a 6 digit node
number. If so and you want to connect with them you must update. Also
because of this it is probably not a good idea to run a hub on a 6 digit
node number until everyone or at least most everyone is on-board.

73 Doug

WA3DSP

···

Whether that is something that also needs to be dealt with using the ASL
version perhaps one of the ASL guru will jump in and enlighten all of us,

Larry - N7FM

On 3/20/20 11:20 AM, Ryan Matthew Headley via AllStarLink Discussion Groups wrote:

[Ryan_Matthew_Headley] Ryan_Matthew_Headley
https://community.allstarlink.org/u/ryan_matthew_headley
March 20

I have tried the bind address connected out, as the actual LAN IP, and
as 0.0.0.0 to no avail.

··· (click for more details)
https://community.allstarlink.org/t/alternate-iax-port/16560/10

Visit Topic
https://community.allstarlink.org/t/alternate-iax-port/16560/10 or
reply to this email to respond.


    In Reply To

[larry] larry https://community.allstarlink.org/u/larry
March 20

Ryan, What does your bindaddr = contain? believe 0.0.0.0 allows all.

    Previous Replies

[larry] larry https://community.allstarlink.org/u/larry
March 20

Ryan,

What does your bindaddr = contain? believe 0.0.0.0 allows all.

[Ryan_Matthew_Headley] Ryan_Matthew_Headley
https://community.allstarlink.org/u/ryan_matthew_headley
March 19

I can confirm that everything you have suggested is properly configured.

[larry] larry https://community.allstarlink.org/u/larry
March 19

Ryan,

Two things to verify…

Are you certain that your local Nodes IAX port matches what is set up on
the Allstarlink Portal (server tab). Plus that UDP port is that Port
number port-forwarded in your router to the proper LAN IP address of you
Allstar Node?

If you are attempting to connect 2 servers together on the same LAN the
IAX ports should be different. Each others routing information should
exist in the opposite NODES Section in rpt.conf file.

Larry - N7FM

··· (click for more details)
https://community.allstarlink.org/t/alternate-iax-port/16560/7
[Ryan_Matthew_Headley] Ryan_Matthew_Headley
https://community.allstarlink.org/u/ryan_matthew_headley
March 19

I have tried several fresh installs, setting everything accord to ALL
the information listed in this thread and others that I have found,
using any port other than 4569 for the X86 image does not work for
incoming connections–even on LAN. The software simply will not listen at
any other port number. I checked iptables and the it does not appear to
be inhibiting anything.

The only workaround I have been able to find that works is port
translation from the router. This requires two separate machines–one for
each node. Both are listening on 4569, but the router sends incoming
from 4569 to 4569 on once machine and 4568 to 4569 on the other.

[G8HAV] G8HAV https://community.allstarlink.org/u/g8hav
March 18

Hi Ryan,
I have the same problem. 'iax2 show registry ’ command in CLI shows it
is registered but cannot get it to connect.


Visit Topic
https://community.allstarlink.org/t/alternate-iax-port/16560/10 or
reply to this email to respond.

You are receiving this because you enabled mailing list mode.

To unsubscribe from these emails, click here
https://community.allstarlink.org/email/unsubscribe/5464b8e87b07fb358f1cb802521a77714a0b70d7cd45fe8f7c13d3983ae45566.