What is the correct syntax in the schedule in rpt.conf?

What is the correct syntax to use to run macros in the schedule portion of rpt.conf? It looks like minutes then hours. Is this right?

There are 5 entries. An asterisk is a placeholder.
m h dom mon dow [ Minute - hour - day of month - month - day of week ]
[ * * * 7 * = every day in July ]
[ 10 7 * * * = 10 minutes after 7am every day ]
[ * 17 * * 7 = at 5pm on Sunday ]
[ /5 * * * * = every 5 minutes ]
[ * 5,14 * * * = at 5am and 2pm ]

I appreciate your response. It seems pretty vague in the comments.
I’m wanting all linked repeaters to give the time at 12 o’clock noon every day. So in the macro stanza, I have:
1 = *122903# ;Disconnect from hub
2 = *322903#
;Connect to hub
3 = *722. ; Global time command

In my schedule stanza I would edit it to be:
;dtmf_function = m h dom mon dow ; ala cron, star is implied
3 = 00 12 * * *

Is that correct?


I’m still not able to make this work. Is there a command to enable/disable the schedule?

After making the changes to the configuration file, you need to restart the asterisk service in order for those changes to take effect.

I’ve done that. Did you see my previous reply where I copied what I have in my rpt.conf file? Is it correct?

I’m wanting all linked repeaters to give the time at 12 o’clock noon every day. So in the macro stanza, I have:
1 = *122903# ;Disconnect from hub
2 = *322903#
;Connect to hub
3 = *722. ; Global time command

In my schedule stanza I would edit it to be:
;dtmf_function = m h dom mon dow ; ala cron, star is implied
3 = 00 12 * * *

Yep, that is how to do it.

Except it doesn’t work. *722 should be a global command to give the time on all linked repeaters, right?

I’ve never used the scheduler function. I favor using crontab and commands instead
In your rpt.conf file have you a define that prefixes the macro function with saya “5” or some digit.
If so perhaps you need to list the scheduled macro to run as a full dtmf action (star(digit) 3) or at least the prefix+3 as the macro to run.

Larry - N7FM

Larry, thank you for the response. Yes, I have that set for *5. If I enter *53 from a DTMF pad, the repeaters respond with the global time.
I have tried putting *53 in the schedule stanza, but I did not get a response.
I’ll keep plugging away at this, but it’s a little frustrating.

de N0ATC

Chuck there is someplace to enable and disable the scheduler I have seen it but don’t recall which Doc.
Until someone (in the KNOW) along and posts the actual commands you are looking for …
An alternative is to use the crontab function.
As user root → crontab -e and create something along this line
00 12 * * * /usr/sbin/asterisk -rx “rpt fun 22903 *53”

Should dial your *53 macro for you automatically each day at noon (which you say works to sends the time globally)

Larry - N7FM

The notes in rpt.conf are rather confusing.

“dtmf_function = m h dom mon dow ; ala cron, star is implied”

“ala cron” means “just like they do it in crontab”
“star is implied” makes little sense.

“m h dom mon dow” means

Star means EVERY. For example, a star in the month column means each and every month, this thing will happen.


01 14 * * * means a 1 minute past 2PM local, any date, any month, any day it falls on

01 14 * * 7 means at 1 minute past 2PM any date, any month, AS LONG AS IT IS SUNDAY.

A net that runs every Sunday at 7:00 PM would be
00 19 * * 7

A net that runs every Sunday at 7PM only in the Summer months June through September would be
00 19 * 6-9 7
at zero minutes past 7PM (I don’t care the date) (but only in June July Aug Sep) (only Sunday please)

Hope this helps.

-Pres W2PW

Larry & Preston, again, thank you for your responses and help. I understand it much better now.
I’m not sure what I did differently, but it’s working now!
Now, if I can figure out how to play sound files by macro, I can announce the schedule of our Nets.
Thanks again to everyone who replied!


Create a command to play the sound file.

xxx=localplay,/etc/asterisk/msg/wxfc ; play wx fcst local only

Put the command to call (xxx) in your macro, then schedule it.

Mike, thanks! All of you who responded to me in this thread were very helpful. Your answer to the audio file command is greatly appreciated!

de N0ATC

Mike, is it possible to call the audio files from a different mounted drive?

It would make it a lot easier to change messages on the fly, so to speak.

I would think so, while I have never done that.
Location is as the system would see it, so, if it is mounted by the system, I see no reason why it would not see it.
However, I would suggest keeping a local sub/directory of your custom sound files, and I would understand instances where that is not possible or desirable.
Try to stay organized with them. This stuff tends to grow on you.

Well, after spending part of the day trying to get my Pi to recognize a USB drive, I finally got my .wav files copied to /etc/asterisk/msg.
I edited rpt.conf and made cop
980 = localplay,/etc/asterisk/msg/msg1.wav
When I enter *980 on a DTMF pad, the wav file doesn’t play. I’m not sure why, it plays on a Pi 4 that I have here.
I need to take a break from it while I still have some hair left.

de N0ATC