URI to Yaesu - Vertex VXR-7000 issues , please help

I have a DMK URI that I am trying to interface to a Yaesu VXR-7000 . I followed this previous thread here , URI Hook up for Yeasu VXR-7000 (Angeo and Kevin) and followed Kuggie’s suggestion on how to wire the DB25 from the rear of the repeater to the URI. However, the link that provides the instructions on ASL configurations is dead. I have searched the net looking for more info, but they keep pointing to that same link. I know I am only supposed to have “remote” turned on in the front, and that doesnt do anything. When I try to press repeat on the front, the repeater does repeat, but has a horrible hum on the receive radios. When I unplug the Cable from the back of the repeater, the hum goes away and acts like a standard desk top repeater. I am using the latest distro that is on the ASL site now as this is a new server and node I have created for our club. When I try Radio Tune menu, it tells me that USB Radio must be enabled in modules (which it is) and selected in Rpt.conf (which it is) then fails to run. Please help. Thanks

I’ve restored the example configuration files on the Masters Communications server.

http://www.masterscommunications.com/temp/2302/

Kevin W3KKC

Sounds like usbradio isn’t fully turned on in modules. Did you turn off simpleusb, as I think you can only have one or the other enabled at a time (not sure about this)?

Also - how old is the URI interface? Is it a URIxB? If so, all bets are off for any of this to work at all.

Kevin W3KKC

It doesnt say URIxB on it anywhere. And the P/N on it is 9095. But its still a no go. And the USBradio is the only module set to load. Simple is marked noload. I am using a pi if that makes a difference

Of course when I enable Simple and no load USB and change it on RPT , that at least lets the tuner work, but when I switch it back to USB and put simple on noload , and change it on RPT, it tells me USBradio must be enabled when I try and run the tuner. I’m at a loss

noload => chan_simpleusb.so ; CM1xx USB Cards with Radio Interface Channel Driver (No DSP)
noload => chan_sip.so ; Session Initiation Protocol (SIP)
noload => chan_tlb.so ; TheLinkBox Channel Driver
load => chan_usbradio.so ; CM1xx USB Cards with Radio Interface Channel Driver (DSP)
noload => chan_usrp.so ; GNU Radio interface USRP Channel Driver
noload => chan_voter.so

make sure you also have /etc/asterisk/usbradio_tune_usb_YOURNODENUMBER.conf file configured properly. Yes you may leave both chan_simpleusb.so and chan_usbradio.so enabled in modules.conf and simply select which one with rxchannel= in the /etc/asterisk/rpt.conf file.

···

Nathan Hardman

nhardman1428@gmail.com

N8THN@ARRL.NET

My first concern would be the hum. Something is wrong with the wiring between the URI and the 7000. There should not be any hum no mater the AllStar settings. Check your wiring, make any needed corrections and maybe all your problems will disappear.

I used Koogies Wiring diagram from the other thread :
There’s a DB25 male connector that plugs into the Vertex VXR-7000. And, there’s a DB25 male on the other end that plugs into the URI.

On the repeater end I have the following:
Pin 1 = shield = GND
Pin 6 = white = DISC OUT
Pin 12 = orange = EXT PTT
Pin 13 = black = GND
Pin 24 = red = TXD LOW

On the URI end I have the following:
Pin 1 = orange = PTT
Pin 13 = shield = GND
Pin 19 = black = GND
Pin 21 = white = MIC_AC
Pin 23 = red = RIGHT_OUT

When I put it back through the Cat250 controller, it works fine, no hum.

/etc/asterisk/usbradio_tune_usb_503290.conf file is empty. It is there , but nothing in it.

My rpt.conf settings :

				; Enable the selected channel driver in modules.conf !!!

; rxchannel = dahdi/pseudo ; No radio (hub)
; rxchannel = SimpleUSB/usb_503290 ; SimpleUSB
; rxchannel = Pi/1 ; Raspberry Pi PiTA
rxchannel = Radio/usb_503290 ; USBRadio (DSP)
; rxchannel = Dahdi/1 ; PCI Quad card
; rxchannel = Beagle/1 ; BeagleBoard
; rxchannel = USRP/127.0.0.1:34001:32001; GNU Radio interface USRP

You will need to run radio_tune_menu

···

Nathan Hardman

nhardman1428@gmail.com

N8THN@ARRL.NET

I stated in the original message, radio_tune_menu closes after it tells me that USB Radio must be enabled in modules (which it is) and selected in Rpt.conf (which it is) .

I have even formatted the memory card, re installed ASL 1.01 current version and ran it again. Still wont open radio tune for USB even though its enabled in modules. When I try to copy the file usbradiotune _xxxx from another repeater I have and change the node # it tells me it cant convert sound to 16 bit or something like that

URIxB cannot be interfaced to a VXR-7000?

The context of the original question in 2019 was using a URI (not xB) with a Vertex VXR-7000 and the usbradio channel driver. Because of a multitude of reasons, I don’t recommend any interface that has a CM119B to be used with usbradio. If you’re using simpleusb - then it’s fine. The URI and URIx both used the CM119A, which is significantly different when used with app_rpt. If you’d like to know why - I’ll fill in the blanks.

Sure, I’d love to know.
Also, I have a URIxB and the VXR-7000, I did the COR plus CTCSS signal mod on my VXR-7000 and wired repeater Acc 10 to URI 8 COR_DET and I still don’t get any RED when I key in. Am I confused and is this “COR” mod only for when receiving? Because using TXD LOW Acc 24 on repeater up to URI 22 LEFT_OUT and using REMOTE switch on VXR-7000 works great and it’s loud vs using TX AF IN (repeater Acc pin 3)
My issue is my repeater is not turning the RED led on when I either key in or I receive transmission on my repeater’s RX frequency.