Telemetry Announcements with duplex=0

I have a simoco node radio interfacing with a KL450 repeater. I have set duplex=0 to remove telemetry but still get the link/unlink announcements. I can manage when I want these announcements by disabling/enabling telemetry.

But this also prevents me from calling saytime… i.e. duplex=0 prevents saytime. I can’t go to duplex=1 or higher because I get looping. So being stuck with duplex=0, I still wish to force a saytime call from crontab.

How do I force a ‘saytime’ announcement with suplex=0?

Alan

As I famously said… no telemetry means no telemetry…(LOL)
This topic was just discussed.
Command “rpt playback” doesn’t send to all connected nodes - App_rpt-users - AllStarLink Discussion Groups

However, if that does not bring you to where you want, come back and ask more.
But do tell us what version of software you are using if you do.
ASL/hamvoip/beta etc

I also should ask that if we could get rid of your ping-pong, could you use duplex=1 ?

Status 12 plays the time locally. Assuming you only want the time announcement on your repeater this might work. Try the command below. Replace 1234 with your node number. The xxx is just junk rpt cmd needs.

asterisk -rvvv
rpt cmd 1234 status 12 xxx

Do you hear the time announcement and/or see it printed on the screen?

yes - I’d love to get rid of the ping ping and return to dupex=1… but I am yet to get the repeater manager to install a different controller to eliminate/drop the Tx tone when identing… so things will change shortly anyway… still I’d like to learn more

if no telemetry means no telemetry, why do I still get connection announcements until I disable telemetry?
Alan

Connected to Asterisk 1.4.23-pre.hamvoip-V1.6.2-01-app_rpt-0.327-02/04/2020 currently running on AllStarNode (pid = 353)

Is this the version you want?

Alan

1 Like

I still get silence - no time announcement. I get this but no Tx occurs:
AllStarNodeCLI> rpt cmd 512810 status 12 xxx
– <DAHDI/pseudo-202651003> Playing ‘rpt/goodmorning’ (language ‘en’)
– <DAHDI/pseudo-202651003> Playing ‘rpt/thetimeis’ (language ‘en’)
– <DAHDI/pseudo-202651003> Playing ‘digits/10’ (language ‘en’)
– <DAHDI/pseudo-202651003> Playing ‘digits/50’ (language ‘en’)
– <DAHDI/pseudo-202651003> Playing ‘digits/4’ (language ‘en’)
– <DAHDI/pseudo-202651003> Playing ‘digits/a-m’ (language ‘en’)
– Hungup ‘DAHDI/pseudo-202651003’
AllStarNode
CLI>

I guess “no telemetry means no telemetry” is really, really true. But I thought it was worth try.

So you are stuck with duplex=1 if you want time announcements. Next suggestion is to try these settings to see if you can get rid of the looping:

duplex=1
nounkeyct=1        ; Set to a 1 to eliminate courtesy tones and associated delays.
telemdefault = 0   ;No Linking messages
hangtime = 0       ;No hang time
;idrecording = myvoiceid      ;No IDs
;idtalkover = |iW1AW      ;No talkover ID

Thanks Tim,
but it’s duplex=0 that I’m stuck with not 1 (1 causes looping)
I’m setting nounkeyct=1 and trying that.
Can you tell me the difference between having idrecording and idtalkover commented out and actually set to nothing? Is there a difference at all?
Alan

Sorry, I communicated poorly. I’m suggesting you must use duplex=1 in order to have the time announcement. However, with the settings from the previous post you may be able to remove the courtesy tones and looping.

Blank idrecording and idtalkover should (maybe) prevent any ID transmission. See these WiKi links for an explanation of their usage:
https://wiki.allstarlink.org/wiki/Rpt.conf#idrecording.3D
https://wiki.allstarlink.org/wiki/Rpt.conf#idtalkover.3D

Edit: Maybe commenting idrecording and idtalkover would be better. Try that first.

OK - thanks Tim, I now have duplex=1 and I have announcement on demand which is what I wanted. Seems the
nounkeyct=1
setting stopped the looping
Alan

Great! Glad nounkeyct=1 and duplex=1 solved the problem. These other settings are recommended as well, particularly hangtime=0. The repeater users will thank you :slight_smile:

telemdefault = 0   ;No Linking messages
hangtime = 0       ;No hang time
;idrecording = myvoiceid      ;No IDs
;idtalkover = |iW1AW      ;No talkover ID

Thanks - roger that, they were already done
Alan