SimpleUSB-tune-menu: error running option 4


I have been trying to install ALS to run a node on a VirtualBox. I have an RA-25 connected to the PC and an FT8900 for my radio. But when I got to the SimpleUSB-tune-menu config step, an error is reported saying “There was an error running option 4”.

I initially thought that the VirtualBox is causing the problem. So I took an old laptop out that I configured to do a dual-boot (Win8 and Debian 9) and did the install there. I had exactly the same error.

Could any one please point me to where I should be looking to resolve the issue, other than getting a Raspberry Pi? Any help is much appreciated.

Boyet 4F3BZ

Be sure that you have enabled SimpleUSB in modules.conf Also, that sounds line you are using the ASL menus. Try exiting the menu and run it on the Linux CLI with simple-tune-menu.


I forgot to mention that I was following the Beginner’s Guide to configure my node using asl-menu. I am also not too familiar with Linux :(.

I do have SimpleUSB enabled in the modules.conf (load =>;)

I also exited the menu and ran simpleusb-tune-menu on the CLI but I got a “Error parsing device parameters” message.

I just noted this when ASL is loading:

everything else loads ok. what am i missing?

Are you restarting ASL and running simple-tune-menu as root?

yes i did restart ASL and logged in as root.


Ok, that’s good. So that being the case, there is some problem with the settings in rpt.conf and/or simpleusb.conf. Rpt.conf has to point to a stanza of the same name in simpleusb.conf.

rpt.conf - Use your node number in place of 1234.

rxchannel = SimpleUSB/usb_1234          ; SimpleUSB




this is the current settings in rpt.conf


for simplusb.conf


i did not make any changes as it seems okay

Hmmm, are you sure asterisk is running? Run asterisk -rvvv. Do you get the *CLI prompt?

If it’s running do module show like sim. You should see

If not do asterisk -fnvvv and analyze the failure. Let us know what you see.

Ran asterisk -rvvv, and this is what I got


I don’t think asterisk is running?

I have been using the ASL menu to setup my node. I am now in option 4, this is where the error occurred. Should asterisk be running by this time?


Let’s exit the menu and do asterisk -fnvvv so we can see why Asterisk is not running.

this is what I got. sorry the screen went too fast

Ahha! Dahdi is the problem. That’s the most difficult problem to fix. My recommendation is to get a Raspberry Pi. But maybe one of the other folks on here is willing to help you with DAHDI on VirtualBox or dual boot.

Was DAHDI not installed? or was installed but not configured properly? which part of the ASL menu deals with DAHDI?

DAHDI is a critical part of Asterisk drivers. There is no menu anything for dahdi. It’s must be compiled for the kernel in use.

This Topic discusses the issue:

If you did manage to compile dahdi and get Asterisk running it’s questionable that VirtualBox would talk to the USB port reliably if at all. You’d have a better chance with Dual boot.

Thanks for the info. I was hoping that following the beginner’s guide and running the installer was all that was needed to get the node up and running.

If DAHDI is a critical part of Asterisk drivers, is it correct to say that it is part of the installer package found in the Downloads page? If it is, what may have caused DAHDI to be not installed on my PC? I have downloaded and ran the installer several times, still no luck.

I see this every time the ALS loads. Could this be the reason why DAHDI is missing?

Seems like a good clew to me.