Setting up Alinco DR-135 radio

I have a new Allstarlink node running on a PC. I have iaxrpt working for a radioless node. I just tried to add an Alinco DR-135 radio. I am using a Repeater Builder Rim-Alinco RIM card for my radio interface. When connected it has a solid green light and a blinking orange or red light. My problem is I hear nothing through the radio when I run the simpleusb-tune menu and select option F to Flash toggling between PTT and Tone output.

When I execute susb tune I get the following:
estesvalley*CLI> susb tune
Active radio interface is [usb_56376]
Device String is 2-1.2:1.0
Rx Level currently set to 500
Tx Output A Level currently set to 500
Tx Output B Level currently set to 500
Usage: susb tune
rx [newsetting]
txa [newsetting]
txb [newsetting]
save (settings to tuning file)
load (tuning settings from EEPROM)

   All [newsetting]'s are values 0-999

I am using simpleusb.confs. I have made no changes in settings except the following in simpleusb.conf: ctcssfrom= no. The parameter carrierfrom=usbinvert was already set to this value.

On the DR-135 radio I have T SQ displayed on the screen above the frequency. The tone is set to 100 Hz. The radio is not in data mode.

This is my first node so I am a newbie. Please help

Node: 56376

I looked at another messages in the community, Troubleshooting Help - App_rpt-users - AllStarLink Discussion Groups

I also went back to the web site and found the same set of simpleusb.conf settings printed on the RIM-Alinco schematic. I entered them in simpleusb.conf and set the audio levels as suggested.

Starting Values for audio levels:

TX = 400
RX = 460

simpleusb.conf settings

carrierfrom = usb
ctcssfrom = no
txmixa = voice
txmixb = no
deemphasis = yes
plfilter = Yes
rxboost = 0
txboost = 0

After rebooting, still no audio from the Alinco Dr-135 radio.

duplex = 1 in rpt.conf

Try turning off the tone squelch in the Alinco while you play and adjust

Turned off CTCSS and regular squelch. No change. Nothing heard when I flash from the Run simpleusb-tune-menu. I can hear noise on the radio, that’s all. I unplugged and replugged the cable and RIM-Alinco card. The susb tune still shows:

estesvalley*CLI> susb tune
Active radio interface is [usb_56376]
Device String is 2-1.2:1.0
Rx Level currently set to 460
Tx Output A Level currently set to 400
Tx Output B Level currently set to 500
Usage: susb tune
rx [newsetting]
txa [newsetting]
txb [newsetting]
save (settings to tuning file)
load (tuning settings from EEPROM)

   All [newsetting]'s are values 0-999

Now when I do the flash to toggle PTT and Tone output I get several of these messages:

 -- Remote UNIX connection
-- Remote UNIX connection disconnected
-- Remote UNIX connection
-- Remote UNIX connection
-- Remote UNIX connection disconnected
-- Remote UNIX connection disconnected

I reset the radio to factory defaults to clear any problems that might have been in the settings with no effect. I am starting to think the Alinco radio is defective. In its previous life the radio was used with an external TNC to connect to a PC to provide Winlink. So, the data port worked at that time. I do not have it set in data mode for ASL per previous recommendations.

I’d like to swap out the radio, RIM-Alinco card, and data cable one-at-a-time to isolate the problem, if it is hardware. However, I don’t have any extra equipment. I suppose I could check pinout voltages from the RIM-Alinco and the radio’s data ports using a friend’s meter

I recently bought a Pi 3b+. I’m thinking of rebuilding my node on that computer to see if that makes any difference.

I have lost track of exactly where you are in your process.
Where are you monitoring the Alinco? You do realize if this is a simplex Node you will hear nothing on the Alinco while it transmits. You need to monitor its output either with another radio or by utilizing the Output B Level which can (change from NO) to a voice and feed it to headset or external speaker.

Larry - N7FM

I have my node registered and working with the program iaxrpt. I was thinking that with a radio it would operate much the same way. I could key in a node and the speaker would announce that we are connected. When I connect with iaxrpt I see messages like the following on the Asterisk CLI console.
– Accepting AUTHENTICATED call from
> requested format = gsm,
> requested prefs = (),
> actual format = gsm,
> host prefs = (ulaw|adpcm|gsm),
> priority = mine
– Executing [56376@radio-gui:1] Rpt(“IAX2/iaxrpt-2369”, “56376|X”) in new stack
== Spawn extension (radio-gui, 56376, 1) exited KEEPALIVE on ‘IAX2/iaxrpt-2369’
– Call accepted by (format ulaw)
– Format for call is ulaw
– Hungup ‘DAHDI/pseudo-1167147587’
– <DAHDI/pseudo-2017397764> Playing ‘rpt/node’ (language ‘en’)
– <DAHDI/pseudo-2017397764> Playing ‘digits/4’ (language ‘en’)
– <DAHDI/pseudo-2017397764> Playing ‘digits/0’ (language ‘en’)
– <DAHDI/pseudo-2017397764> Playing ‘digits/8’ (language ‘en’)
– <DAHDI/pseudo-2017397764> Playing ‘digits/9’ (language ‘en’)
– <DAHDI/pseudo-2017397764> Playing ‘digits/4’ (language ‘en’)
– <DAHDI/pseudo-2017397764> Playing ‘rpt/connected’ (language ‘en’)
– <DAHDI/pseudo-2017397764> Playing ‘digits/2’ (language ‘en’)
– <DAHDI/pseudo-2017397764> Playing ‘rpt/node’ (language ‘en’)
– <DAHDI/pseudo-2017397764> Playing ‘digits/5’ (language ‘en’)
– <DAHDI/pseudo-2017397764> Playing ‘digits/6’ (language ‘en’)
– <DAHDI/pseudo-2017397764> Playing ‘digits/3’ (language ‘en’)
– <DAHDI/pseudo-2017397764> Playing ‘digits/7’ (language ‘en’)
– <DAHDI/pseudo-2017397764> Playing ‘digits/6’ (language ‘en’)
– Hungup ‘DAHDI/pseudo-2017397764’
– Hungup ‘DAHDI/pseudo-1556233091’
– Hungup ‘DAHDI/pseudo-440465356’
– Hungup ‘DAHDI/pseudo-2082957684’

When I enter a connection string from the radio’s keypad, I see nothing on the Asterisk console. It’s as if the radio doesn’t exist as far as Asterisk is concerned. I can understand that the voice response from Asterisk would come out on a different channel, but when the radio is connected and attempting to work with Asterisk there should be some indication that it is communicating with Asterisk, or so it seems.

The Alinco DR-135 is advertised as being plug-and-play with Asterisk when using the RIM-Alinco interface from If that’s true I must be doing something very wrong in my setup or I have a hardware failure of some kind.

If the recommended setting says to turn on receive de-emphasis, that means it is getting audio from the 9600 data connection. For that to work, you need to set the radio to data mode (you should see a little square wave pattern on the right side of the display).


In response to KE2N, I get no response when I put the Alinco radio into data mode. I was able to get this to work by 1) Removing the internal EJ-41U packet TNC card and 2) setting the PTT Mode to LOW in simpleusb_tune_usb. Using an HT radio, I can enter commands such as *81 or *70 and get an audio response. The problem I am having now is that there is a low background hum accompanying every voice message from ASL. It sounds to me like the hum you sometimes get from a ground loop. The Alinco radio is connected to my Samlex power supply whereas the Pi computer is connected to a wall outlet with power adapter to supply the correct voltage. Neither are grounded. The radio is connected via coax to an outdoor mounted X-50 antenna. If I can get rid of the hum, I will have a fully functioning simplex node.

I’ve been able to move the HT radio around and almost eliminate the background hum. I think that problem is solved. Now I’m trying to connect to nodes listed on the ALS keyed node list and not getting any connections. When I use iaxrpt as a radioless node on a Windows PC I can make node connections, though not every time I try to connect.

I have the Pi based ASL system working now and connecting to nodes using the DR-135 radio and an HT. I’m still working on the linux PC ASL system to get the DR-135 radio to work. It only puts out noise for ASL voice response messages. The ASL simpleusb-tune-usb script for the PC does not have an option to set the PTT Mode LOW or HIGH. I think it should be set to LOW, which is how it’s set on my Pi. Does anyone know how to set the PTT Mode on a PC ASL system?

Look in the simpleusb.conf file. That’s where the interface control gets configured. the tune menu deals with audio settings.

Larry - N7FM

TX audio issues seem to be a issue with this brand of radio and/or the Rim-Alinco board… not sure which yet. May not even be with either and might just be an ASL issue.

I’m running the Beta version of ASL (since it seemed to be the only one of the ASL’s to properly work with this Rim-Alinco board), the Rim-Alinco interface, and it’s attached to a Alinco DR-438. Testing done with a Vertex FTL-7011 mobile radio. Receive audio from internet, through Rim-Alinco, and transmitted out over the air to the test radio is great — no complaints. But, the other way is poor to say the least. Going from test radio to DR-438, the audio is as required (all set properly and tested with a IFR service monitor). From DR-438 through the Rim-Alinco and out over the internet (as received on the other end with IAXRPT) the audio is barely heard. I’ve set the TX level starting at 400 and increased it in increments at a time to 999 and it makes no difference in TX audio.

Simpleusb.conf settings are:
txboost=0 (even when set to 1 there’s still no difference)
TX=400 (starting and incremented to 999 with no difference)
RX=450 (excellent setting)

Simpleusb_tune_usb_nodenum.conf settings (file is completely empty)…

So question is: There are two files I understand that control the operations of this Rim-Alinco board. One is “simpleusb.conf” and the other is “simpleusb_tune_usb_(node number).conf”. I’m not sure I understand what the purpose of the second file is since it has nothing (no code no setting) within it.

So first question is, what settings for this Rim-Alinco board go into the “simpleusb.conf” file and what settings belong in the “simpleusb_tune_usb_nodenumber.conf”?

Second question is, when running the simple usb tune from the ASL menu, where are those settings stored within ASL?

I know there a solution, I jsut need help getting to it.

William, KI5PHN

Did you find a solution? I’m having some of the same issues and am wondering if it is caused by the board or radio.

Scott, N7FGP

Running the simpleusb tune function from the menu is what populates the simpleusb_tune_usb(nodenumber).conf file when the setting are saved.
The data inside that file will look similar to this. Note the comments that follow are only reminders for myself.
The tune numbers will change depending on your USB device and your radio.

; name=usb28162
; devicenum=1
rxmixerset=600 ;outgoing Audio level sent TO the Internet for any linked nodes
txmixaset=600 ;incoming Audio FROM the Internet - becomes mic audio adjust for radio transmitter
txmixbset=600 ;speaker/headset jack for monitoring the incoming Audio (above) which is being passed to the local radio’s transmitter.
Once that file is created you can adjust the audio settings up and down by editing the =600 directly. Saves re-running the tune menu all the time.
What other features the RIM- Alinco have on board I’m not familiar with.
Hope that helps

Alinco DR-135 and their other cheap single band radios (235, 435) should not be used for nodes – or for anything for that matter. They are known to have Tx PLL stability issues that transmit all over the band +/- MHz while the VCO stabilizes for the first ~50mS of every transmission. See W2AEW’s video documenting this issue:

My tests on a DR-735T show it does not have this issue. As usual you get what you pay for. The 735 is also a much nicer radio supporting dual band dual receive and cross-band full-duplex.