Private node, outbound calls and chan_tlb

Hi, I’m trying to setup a private link (not accessible from the general AllStar network) between an instance of ASL and thelinkbox.

I created a private node as usual, linked via USRP to the intended destination (an instance of USRP2M17). I added it to the [nodes] stanza in rpt.conf as well as extensions.conf, as per usual. I also created a second instance of chan_tlb, associated with this node and defined a private node (1002) to the intended destination.

Results so far:
The private node (1990) can be reached from the main ASL node (27154) no problems, and the USRP link between 1990 and USRP2M17 has been confirmed to be working. The problem is node 1990 can’t initiate a connection via either AllStar or chan_tlb (RTP) to known destinations. I get an error “unable to start dialtone” in the log when I attempt to connect from 1990 to either 27154 (AllStar) or 1002.(RTP/chan_tlb).

In summary, connecting from 27154 to 1990 works
1990 to 27154 doesn’t work
1990 to 1002 (desired connection) doesn’t work either.

Any ideas on how to resolve this issue?

Are the connections known to asterisk ? …
Do you have the private nodes connection in the dialplan (extensions.conf) ?

I also created a second instance of chan_tlb, WHY? There’s already an instance of chan_tlb there, just use it and make sure you enable it in modules.conf.

I think they’re known. In rpt.conf, I have:

; Note, if you are using automatic update for allstar link nodes,
; no allstar link nodes should be defined here. Only place a definition
; for your local nodes, and private (off of allstar link) nodes here.

27154 = radio@,NONE ; This must be changed to your node number
; and iax port number if not the default
1990 = radio@,NONE
;1998 = radio@,NONE
;1997 = radio@,NONE

I can connect from 27154 to 1990, but not the other way around.

Here’s my tlb.conf.

call=AS27154 ; Call of the app_rpt station
port=44966 ; Start of UDP port range (this port, port + 1)
astnode=27154 ; app_rpt node associated with this instance (for incoming connections)
context=radio-secure ; Asterisk context for incoming connections
codec=ULAW ; Default CODEC to be used

call=AS1990 ; Call of the app_rpt station
port=44968 ; Start of UDP port range (this port, port + 1)
astnode=1990 ; app_rpt node associated with this instance (for incoming connections)
context=radio-secure ; Asterisk context for incoming connections
codec=ULAW ; Default CODEC to be used

1001 = REF9550,,44966,ULAW ; This one is for VK3RIR at ip default CODEC
1002 = REF9556,,44968,ULAW ; Link to HAM conference, ULAW CODEC

And extensions.conf is the one I understand the least. I have the usual changes to enable routing to private nodes, but don’t know if I need anything else to be able to dial out from private nodes.


static = yes ; These two lines prevent the command-line interface
writeprotect = yes ; from overwriting the config file. Leave them here.

HOMENPA = 999 ; change this to your Area Code
NODE = 27154 ; change this to your node number
NODE1 = 1990 ; First private node (link to HAM)
NODE2 = 1998 ; Second private node (link to P25)
NODE3 = 1997 ; Third private node (link to DMR and YSF)
NODE4 = 1995 ; Fourth private node (link to PTTLink)


exten => i,1,Hangup

exten => ${NODE},1,rpt,${NODE}
exten => ${NODE1},1,rpt,${NODE1}
exten => ${NODE2},1,rpt,${NODE2}
exten => ${NODE3},1,rpt,${NODE3}
exten => ${NODE4},1,rpt,${NODE4}

Well, I can say first I do not use this but, just trying to move through it logically and I don’t see any issues.

One thing we have not verified is this from the wiki:

On TheLinkBox side, you must specify the following in the main configuration file (generally tlb.conf):

RTP_Port = 44966

And you must have an entry if your ACL file (generally tlb.acl) for each app_rpt node as follows:

allow WB6NIL - -R

I have since confirmed that the issue was somewhere in the AllStar call routing side of things. I reconfigured using a NNX node number, and it works. Using NNX has led to a different problem (I’ll do another post for that). I went with NNX, because I decided a public node number might be an advantage.

I’ve done a number of links using chan_tlb before, and have used thelinkbox in numerous weird and wonderful configurations, though this is the first one using chan_tlb configurations on the one AllStar server. That was done, to associate each instance with a different AllStar node and use different UDP ports for the RTP traffic.

You can keep the NNX and not reg it to keep it private if you wish.
(keeping the long node number)
When I originally was going through your set-up,
I was thinking that it was looking at the node db and your private node was not there and would not connect. So yes NNX or public nodes would solve that.

Yeah, NNX has solved the original problem, but now I have a call routing issue (see separate post).