Call routing issues after converting to NNX

I had 2 AllStar node numbers - 2199 and 27154. In order to accommodate another project, I switched 2199 to NNX and created 21990 and 21991. I reconfigured 2199 to become 21990, as per the instructions in the Wiki, and I added 21991 to the server that 27154 runs on. All 3 nodes are registering on the AllStar network.

The nodes are working, for the most part, but there is a routing issue. If I attempt to call 21990, I get an error that there is no extension 2199 in the radio-secure context (which is correct, there isn’t such an extension now). Something is still causing calls to be routed to node 2199. Similarly, if I attempt to call 21991 from 21990, the call is routed back to 21990’s server with the same error.

This has been the case for around 14 hours so far.

Double check the [nodes] stanza on the server(s) where the new NNX nodes are.

The other thing to check would be extensions.conf. I’d do it like so…

HOMENPA = 999 ; change this to your Area Code
NODE = 27154

exten => ${NODE},1,rpt,${NODE}
exten => 21991,1,rpt,21991

Or you could do it with variables as shown in this topic…

My guess is that is where the routing issue is.

Here’s my [nodes] stanza on 21990

; Note, if you are using automatic update for allstar link nodes,
; no allstar link nodes should be defined here. Only place a definition
; for your local nodes, and private (off of allstar link) nodes here.

21990 = radio@,NONE ; This must be changed to your node number
; and iax port number if not the default
1999 = radio@,NONE
1046 = radio@,NONE

And the relevant part of extensions.conf.

HOMENPA = 999 ; change this to your Area Code
NODE = 21990
NODE1 = 1999 ; change this to your node number
NODE2 = 1046
NODE3 = 1997


exten => i,1,Hangup

exten => ${NODE},1,rpt,${NODE}
exten => ${NODE1},1,rpt,${NODE1}
exten => ${NODE2},1,rpt,${NODE2}
exten => ${NODE3},1,rpt,${NODE3}

But what I can’t work out is what’s causing calls to be routed to 2199, rather than 21990. Not only calls originating from 21990, but calls from another node to 21990 (e.g. 27154) are routed to the correct host, but rejected, because 2199 doesn’t exist (which suggests extensions.conf is correct). Try connecting to 21990 yourself.

Have you changed the node# in rpt.conf

Asterisk will always take the first command it sees as valid.
So, somewhere there is still a definition for 2199 never seeing the 0 and it has to be rpt.conf

Mike is right about touchtone decoding. They are decoded at each keypress and as soon as there is a match it will be executed. That’s why there can’t be a 2199 and a 21990.

My question is what is it that indicates to you that a connection is being made to 2199?

There should not be a 2199 anywhere in your node. Try grep’ing for it.

cd /etc/asterisk
grep 2199 *

I tried to connect to 2199 from 2530. It just ignores me as expected. Connecting to 21990 appears to work normally from what I see on this end.

Thanks, problem solved. Had to reboot both servers involved. stopping and restarting Asterisk was insufficient to get everything working properly. Rebooting the machines fixed everything. I can now connect from 21990 to 21991.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.