Need better instuctions for dahdi_dummy install

Some of us do not have extensive Linux knowledge…I’m willing to learn.
Somehow this procedure assumes some knowledge I’ve yet to obtain.
I’ve tried the install as posted, but keep getting errors. Here is where I get stopped:
Procedure followed:
Login: repeater
Passsword: allstarlink
SSH port: 22
User repeater has sudo privileges (sudo -s)
There may have been updates to the operating system and AllStarLink since this image was built.
Run the following commands after the first time you boot.
sudo apt-mark hold raspberrypi-kernel-headers raspberrypi-kernel
sudo apt-get update
sudo apt-get upgrade -y sudo reboot
at the # prompt run “asl-menu” to setup your node.
reboot
I have a working system at this point
apt-mark hold raspberrypi-kernel-headers raspberrypi-kernel
apt-get install gcc raspberrypi-kernel-headers make vim git
vim /usr/src/asl-dahdi-linux-2.11.1/linux/drivers/dahdi/Kbuild [ remove the # from the dummy file ]
– Here I used the NANO editor instead –
cd /usr/src/asl-dahdi-linux-2.11.1
make
— ERRORS HERE –

  • You do not appear to have the sources for the 4.9.80-v7+ kernel installed
  • Makefile:71: recipe for target ’ modules ’ failed
  • make[1]: *** [modules] Error 1
  • make[1]: Leaving directory ’ /usr/src/asl-dahdi-linux-2.11.1/Linux ’
  • make[1]: recipe for target ’ all ’ failed
    -make: *** [all] Error 2
    I have no idea what all that means!

try this command at the # prompt

sudo apt-get install raspberrypi-kernel-headers
and give us the output

Response is: Unable to locate package raspberrypi-kernel-headers

can you try
sudo apt-get update
and
ping www.debian.org
let it go for a few sec then stop it with “control c”

Done. Ping is successful

Now I get: ….headers is already the newest version…

ok we confirmed that you have good network connection with dns resolving, and you went headed to get the latest versonof the headers… that is good.

can you try
cd /usr/src/asl-dahdi-linux-2.11.1
make clean
make

…2.11.1…dahdi/oct612x:no such file or directory. Stop
recipe for target ’ clean ’ failed

try just
cd /usr/src/asl-dahdi-linux-2.11.1
make

Just make results in the other error:
You do not appear to have the sources for the 4.9.80-v7+ kernel installed

Oh be careful you will be told like I was that you are bitching & need to learn

I am an average HAM that WANTS to learn. This thread is helping to do that. I do not know where else to get this info.

2 Likes

Len (guessing, sorry if I got name wrong) - I assure you there’s a bunch of good guys here that want to help you figure this out. Do not feel discouraged.

Please try a run of these two commands, and copy/paste the output so one of us can help you out:

uname -a

dpkg-query -l | grep raspberrypi-kernel

(Anyone else waking up that wants to chime in on this thread, please do)
Byron

I’m having the exact same issue that my friend Len is having…Here is what I get executing said command…root@repeater:~# uname -a
Linux repeater 4.9.80-v7+ #1098 SMP Fri Mar 9 19:11:42 GMT 2018 armv7l GNU/Linux
root@repeater:~# dpkg-query -l | grep raspberrypi-kernel
hi raspberrypi-kernel 1.20180313-1 armhf Raspberry Pi bootloader
hi raspberrypi-kernel-headers 1.20180313-1 armhf Header files for the Raspberry Pi Linux kernel
root@repeater:~#

1 Like

When running this portion of the instructions, did any packages fail to install or report any errors?

Update…

I noticed just as I tried to follow the instructions lengriff posted, I was getting some inconsistency in available packages while trying to install the required git item(s) in the apt-get statement.

Meaning, I was getting 404’s off a couple of different debian mirrors. (git was not found)
Seemingly on third try, I managed to round-robin to one that worked (http://mirror.umd.edu/) and got the packages for git needed. (in my case, http://mirror.umd.edu/raspbian/raspbian stretch/main armhf git armhf 1:2.11.0-3+deb9u6)

So can you guys just compare here, and make sure the required packages from the apt-get statement are fully installed? (This is why I asked in my last post if you saw any errors with the apt-get line?)

apt-get install gcc raspberrypi-kernel-headers make vim git

Hoping we can sort this out…
Byron

Seems like we need a different source for the headers?
’ You do not appear to have the sources for the 4.9.80-v7+ kernel installed ’

’ apt-get install raspberrypi-kernel-headers ’
When installing the headers, there are sources missing:
Do you want to continue? [Yin] y
Get:1 http://archive.raspberrypi.org/debian stretch main armhf raspberrypi-kernel-headers
Fetched 16.7 MB in 2s (6,536 kB/s)
Reading changelogs… Done
(Reading database … 72507 files and directories currently installed.)
Preparing to unpack …/raspberrypi-kernel-headers_1.20190819"stretch-1_armhf.deb
Unpacking raspberrypi-kernel-headers (1.20190819’stretch-1) over (1.20180313-1) …
Setting up raspberrypi-kernel-headers (1.20190819"stretch-1)
run-parts: executing /etc/kernel/header_postinst.d/dkom 4.19.66+
Error! Bad return status for module build on kernel: 4.19.66+ (armv7l)
Consult /var/lib/dkms/asl-dandi-linux/2.11.1/build/make.log for more information.
run-parts: executing /etc/kernel/header_postinst.d/ftms 4.19.66-v7+
Error? Bad return status for module build on kernel: 4.19.66-v7+ (armv01)
Consult /var/lib/dkms/asl-dandi-linux/2.11.1/buildmake.log for more information.
run-parts: executing /etc/kernel/header_postinst.d/dkms 4.19.66-v7+
Error* echo
Your kernel headers for kernel 4.19.66-v7+ cannot be found at
/lib/modules/4.19.66-v7+/build or /lib/modules/4.19.66-v7+/source.

Unfortunately the same errors occur, missing modules / headers.

Would you be able to elaborate on that? Because I just re-imaged the SD card and, with the exception of an “apt update” to be able to install packages, attempted to follow the wiki instructions as the first step after booting. I still end up with the same “You do not appear to have the sources for the 4.9.80-v7+ kernel installed.” message that everyone is dealing with.

That’s what I just did.

I have a semi-working system on which I’m attempting to install dahdi_dummy. I’ve been working on setting it up for a while, and while the kernel packages were held per the README, “apt upgrade” had been run a number of times.

So, per your prior post regarding needing to have a fresh image, I removed the SD card and re-imaged it. Prior to placing the card back into the Pi and booting, I did a few housekeeping items such as copying my saved configuration files in and changing hostname.

First thing after booting the Pi and logging in, I held the kernel packages with apt-mark. I then installed the required packages per the wiki, which as you know required refreshing the repositories with “apt update”.

Attempting to build using make threw the same error of not having the correct kernel sources.