Macro Not Found Issue

Good Morning,
I just got my 1st AllStar repeater up and running last night and I have the following issue and I don’t understand what is wrong, When I enter (Through DTMF) *3 and then the node # I get the response “macro not found”
Any help/direction is appreciated
Thanks
Jerry - W4JWC

Jerry,
The *3 needs to be followed by an actual active node number.

See the https://www.allstarlink.org/nodelist/ any node shown in green
is an online/active Node

Larry - N7FM

···

On 3/19/20 7:23 AM, Jerry W Conner via AllStarLink Discussion Groups wrote:

[w4jwc] w4jwc https://community.allstarlink.org/u/w4jwc
March 19

Good Morning,
I just got my 1st AllStar repeater up and running last night and I have
the following issue and I don’t understand what is wrong, When I enter
(Through DTMF) *3 and then the node # I get the response “macro not found”
Any help/direction is appreciated
Thanks
Jerry - W4JWC


Visit Topic
https://community.allstarlink.org/t/macro-not-found-issue/16655/1 or
reply to this email to respond.

You are receiving this because you enabled mailing list mode.

To unsubscribe from these emails, click here
https://community.allstarlink.org/email/unsubscribe/657fbb0ef5bf4573da1f9fb52ddf19e06d8e9dc47265589bf8f0b859a67da47a.

Thanks Larry,

The node I was attempting to connect to was an activate node.

I suspect something is not correct, when I was setting it up the 1st time but I am not sure what to look for.

Jerry Conner

Four Oaks Farms, LLC

400 Windfield Lane

Wirtz, VA. 24184

540-334-6257 (off)

540-238-1780 (cell)

www.4oaksfarms.com

sigimg0.jpg

···

-------- Original Message --------

Subject: [AllStarLink Discussion Groups] [App_rpt-users] Macro Not Found

Issue

From: Larry via AllStarLink Discussion Groups

noreply@community.allstarlink.org

Date: Thu, March 19, 2020 11:21 am

To: jerry@4oaksfarms.com


larry
March 19
Jerry,
The *3 needs to be followed by an actual active node number.

See the https://www.allstarlink.org/nodelist/ any node shown in green
is an online/active Node

Larry - N7FM

··· (click for more details)


Visit Topic or reply to this email to respond.


In Reply To


w4jwc
March 19
Good Morning, I just got my 1st AllStar repeater up and running last night and I have the following issue and I don’t understand what is wrong, When I enter (Through DTMF) *3 and then the node # I get the response “macro not found” Any help/direction is appreciated Thanks Jerry - W4JWC


Visit Topic or reply to this email to respond.

To unsubscribe from these emails, click here.

Very good Jerry,

Well I see your node 50984 is online and registered. It appears to be
trying to Link with a 6 digit Node number.

Not all Allstar Nodes recognize the addition of the extra digit.
I believe…There is a setting that needs changed to allow 6 digit
connects. Perhaps Tim will jump in and correct me if wrong and supply
the proper info, as I am unfamiliar with it.

Can you can give a few more particulars of what exactly is happening
when you dial. Number you are trying to connect to would help . Error
you receive if it fails etc.

Also have you tried connecting to 5 digit node numbers?

···

On 3/19/20 10:33 AM, Jerry W Conner via AllStarLink Discussion Groups wrote:

[w4jwc] w4jwc https://community.allstarlink.org/u/w4jwc
March 19

Thanks Larry,

The node I was attempting to connect to was an activate node.

I suspect something is not correct, when I was setting it up the 1st
time but I am not sure what to look for.

Jerry Conner

Four Oaks Farms, LLC

400 Windfield Lane

Wirtz, VA. 24184

540-334-6257 (off)

540-238-1780 (cell)

www.4oaksfarms.com http://www.4oaksfarms.com

sigimg0.jpg

··· (click for more details)
https://community.allstarlink.org/t/macro-not-found-issue/16655/3

Visit Topic
https://community.allstarlink.org/t/macro-not-found-issue/16655/3 or
reply to this email to respond.


    In Reply To

[larry] larry https://community.allstarlink.org/u/larry
March 19

Jerry, The *3 needs to be followed by an actual active node number. See
the https://www.allstarlink.org/nodelist/ any node shown in green is an
online/active Node Larry - N7FM ··· (click for more details)
https://community.allstarlink.org/t/macro-not-found-issue/16655/2

    Previous Replies

[larry] larry https://community.allstarlink.org/u/larry
March 19

Jerry,
The *3 needs to be followed by an actual active node number.

See the https://www.allstarlink.org/nodelist/ any node shown in green
is an online/active Node

Larry - N7FM

··· (click for more details)
https://community.allstarlink.org/t/macro-not-found-issue/16655/2
[w4jwc] w4jwc https://community.allstarlink.org/u/w4jwc
March 19

Good Morning,
I just got my 1st AllStar repeater up and running last night and I have
the following issue and I don’t understand what is wrong, When I enter
(Through DTMF) *3 and then the node # I get the response “macro not found”
Any help/direction is appreciated
Thanks
Jerry - W4JWC


Visit Topic
https://community.allstarlink.org/t/macro-not-found-issue/16655/3 or
reply to this email to respond.

You are receiving this because you enabled mailing list mode.

To unsubscribe from these emails, click here
https://community.allstarlink.org/email/unsubscribe/d6ce61d086f34e90ad0e57e5c574e5612baf2d837c6fe1f281db96b13d16e0b9.

Hi Larry,

Yes I am trying to connect to node number 505500.

When I send *3505500 it returns with “macro not found”.

I have not attempted to connect to a 5 digit note.

Thanks

Jerry-W4JWC

···

-------- Original message --------

From: Larry via AllStarLink Discussion Groups noreply@community.allstarlink.org

Date: 3/19/20 3:25 PM (GMT-05:00)

To: jerry@4oaksfarms.com

Subject: [AllStarLink Discussion Groups] [App_rpt-users] Macro Not Found Issue


larry

    March 19

Very good Jerry,

Well I see your node 50984 is online and registered. It appears to be

trying to Link with a 6 digit Node number.

Not all Allstar Nodes recognize the addition of the extra digit.

I believe…There is a setting that needs changed to allow 6 digit

connects. Perhaps Tim will jump in and correct me if wrong and supply

the proper info, as I am unfamiliar with it.

Can you can give a few more particulars of what exactly is happening

when you dial. Number you are trying to connect to would help . Error

you receive if it fails etc.

Also have you tried connecting to 5 digit node numbers?

··· (click for more details)


Visit Topic or reply to this email to respond.


In Reply To


w4jwc

    March 19

Thanks Larry, The node I was attempting to connect to was an activate node. I suspect something is not correct, when I was setting it up the 1st time but I am not sure what to look for. Jerry Conner Four Oaks Farms, LLC 400 Windfield Lane Wirtz, VA. 24184 540-334-6257 (off) 540-238-1780 (cel…


Visit Topic or reply to this email to respond.

To unsubscribe from these emails, click here.

There are 3 places in rpt.conf to understand regarding macros. The first 2 parts are likely already set correctly. You’ll just need to add lines to the 3rd part.

The 1st part is understanding where the various sections [stanza] are. This sets where the DTMF functions and macros stanza are.

; Example node number 1000
[1000]
functions=functions1000
macro=macro1000
...

The 2nd part is the functions stanza. This sets the macro function to *5:

; Fuctions for node 1000
[functions1000]
5 = macro
...

The 3rd part is the macro stanza. This sets the actual macro commands

; Macro Commands for node 1000
[macro1000]
1 = *11500  ;Disconnect 1500
2 = *31500  ;Connect 1500

Now *51 will disconnect node 1500 and *52 will connect to node 1500

Thanks,

All take a look and see what my settings are.

Jerry-W4JWC

···

-------- Original message --------

From: Tim Sawyer via AllStarLink Discussion Groups noreply@community.allstarlink.org

Date: 3/20/20 9:24 AM (GMT-05:00)

To: jerry@4oaksfarms.com

Subject: [AllStarLink Discussion Groups] [App_rpt-users] Macro Not Found Issue


wd6awp

      ASL Admin

    March 20

There are 3 places in rpt.conf to understand regarding macros. The first 2 parts are likely already set correctly. You’ll just need to add lines to the 3rd part.

The 1st part is understanding where the various sections [stanza] are. This sets where the DTMF functions and macros stanza are.


; Example node number 1000
[1000]
functions=functions1000
macro=macro1000

The 2nd part is the functions stanza. This sets the macro function to *5:


; Suctions for node 1000
[functions1000]
5 = macro

The 3rd part is the macro stanza. This sets the actual macro commands


; Macro Commands for node 1000
[macro1000]
1 = *11500 ;Disconnect 1500
2 = *31500 ;Connect 1500

Now *51 will disconnect node 1500 and *52 will connect to node 1500


Visit Topic or reply to this email to respond.

To unsubscribe from these emails, click here.

To ADMIN,

I did a new Debian ASL install on a PC using the link below

https://github.com/AllStarLink/Asterisk/releases/download/ASL-1.01/ASL_1.01-20180417-amd64-i386-debian-stretch-netinst.iso

With my URIx Sound device plugged in. Booted the PC and logged in as
user repeater
Set chan_simpleusb.so driver to load in the modules.conf
Made sure the rxchannel = SimpleUSB/usb_(node-number) was set correctly
in rpt.conf.
Saved the changes and restarted the PC.

As user repeater entered sudo asl-menu
The asl-menu started.

Selected item #4 ===> Run simpleusb-tune-menu for SimpleUSB configuration.

Does nothing other than to keep telling you…
“SimpleUSB must be enabled in modules.conf and selected in rpt.conf”

Since this was already done. It appears there is something wrong with
the asl-menu item 4.

Returning to the command line and entering — sudo simpleusb-tune-menu
The “simpleusb-tune-menu” runs without issue.

Someone want to take a look at this. I’m sure it would save some new
user a lot of frustration if they try using it while they attempt to get
their new ASL server up and running.

Larry - N7FM

Trying to cfg macros. I do not see either of the first 2 referenced sections you mentioned at all and only the following re macros:

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

; Macro Commands
5 = macro
; Place command macros here
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

I have tried it like this but get a nice lady saying “macros not found”:

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

; Macro Commands
5 = macro
[macro48654]
; Place command macros here
1=*76 *323455# ; so and so node info;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

The sections are there, just with different names. For example my [1000] is going to be your node number in square brackets. Keep looking, you’ll sort it out.

Jerry, If you are entering *3 for connect and it is replying with ‘macro not found’,
It’s not reading your DTMF correctly.
Go to the command line ( asterisk -rvvv ) and watch the screen as you press the DTMF for a quick test.
Macro’s start with a *5 so you can see the error as it sees it. Reading a 3 for a 5.
Maybe audio not adjusted well or your dtmf is not so good or some combo.

Ehh not seeing them
in order of appearance I have:

functions = functions ; Repeater Function stanza
;then later
[functions] ;(followed by commented out list of prefix/functions 1-9 and 0 and a-d)
;then later a section I played with and commented out bc did not work (macro not found)
; Macro Commands
;5 = macro
;[macro48654]
; Place command macros here
;1=76 399999#
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;then a macro section I just saw for first time:
[macro]
;1 = 32011#
;2 = 1200112011
12043
12040
120501206012009120021200312004111312030#
;3 = 3200132011
320503203032060#

Can someone post example of macros stanza please? I am reading the wiki and trying many things and getting nowhere. Macro use and format - AllStarLink Wiki
Stock image but things do not match up to descriptions in the wiki etc.
Also looking at
Rpt.conf - AllStarLink Wiki
some show macro=macro to define stanza others macro = macro
etc
When I have rpt.conf configured with macro info I lose disconnect of *76 and *806 just an aside effect for some reason.

91=*909801# ; clean-up /tmp folder script
92=*909802# ; daily PeaterStein archive at eod

Looks like you need to add a space between commands. But I would still be uncertain what commands those would be.

Each command should be a command you might enter directly from dtmf…
i.e. *32135 (connect to node 2135 in tx/rx) then a space then next command.
I think the wiki is clear on that by example anyway.
https://wiki.allstarlink.org/wiki/Macro_use_and_format

Yes I understand and have already read over that page at length. (I have the link in my post)
I just noticed this forum removed all the asterisk from my pasted content! Why did it do that??
I just need to see a working rpt.conf file.

[macro29285]
91=*909801# ; clean-up /tmp folder script
92=*909802# ; daily PeaterStein archive at eod
93=*81 *31999 *937 P P *995# ; say time, connect node, play net announcement, pause, and turn off telemetry for net

If you still do not understand this, please state what it is you are trying to run with a macro exactly.

First in this line, it is commented (’;’) out so nothing here is valid. and put a space between commands.
3 = *32001 *32011 *32050 *32030 *32060#

Cliff I sent you an off list note to your ARRL email
Larry - N7FM

1 Like

Yes I got it! Thank you. Been combing over it. Also looking over this is helping too-

[finally got it working] - argh posted a reply w my code and again it starts removing the asterisk symbols!! What is with this forum formatting?? Ahh finally figure it out using the “preformatted text” option.

I got macros working but very odd in some ways. I had tried “macro = 5” in diff places but only worked when I mirrored the example at github link to rpt.conf file example in prev post.
That file does not even have a macro=macro line at top w other stanza definitions as described elsewhere! Ugh I find a bit of conflicting info out there.

All I did was- remove: macro=macro, add 5 = macro section exactly same/same place as above example, and added [macro] stanza at exactly same location as in example. My macros stanza looks like this right now and works fine as well as the 76 and 806 disconnect commands on their own etc.

========================
========================
[macro]
;Place command macros here

1=*76#                                  ;Disconnects all links
2=*76*3458800#                          ;WM9W 220 Chicago ASL(Node 458800)10pm eves
3=*76*3515420#                          ;AE5ME 147.090 88.5 OK - Boredom Breakers
4=*76*350639#                           ;50639 KB0FJB Minneapolis
5=*76*345830#                           ;45830 N6ime JD in AZ
=============================
=============================

Maybe eventually I will understand the logic and flow of how the code is read. Don’t have the mental bandwidth right now but so glad to have it working.

I backed up my files right away!