Laptop WiFi issues, no driver installed

Old Dell laptop that had Win10 and WiFi worked. Bios WiFi enabled. Installed this version Index of /files/ASL_Images/Intel-AMD/Stretch
Ethernet works. Added supplicant and rfkill. To be honest I no education in Linux and can’t seem to find a good cheat sheet for dummies. All I can tell is there’s no driver for Wireless enp9s0. I can’t seem to run rfkill list because I don’t have the knowledge where or what directory to run it. I’ve tried sudo wpa_supplicant -B -c /etc/wpa_supplicant.conf -i enp9s0 and I’m denied access , no permission. For the life of me I don’t understand why WiFi wasn’t written in the programming? Thanks
No Wifi connection to laptop on home LAN

Picking up on the stated ‘no driver’
Much of the network drivers are not on the default repo’s
Especially laptop stuff.

You should try this for NONFREE (its free)
Find the manufacture and look for linux drivers.

You are probably going to need to id the interface and search if this does not work.

Got the driver installed. Now rfkill hard locks adapter when I enter this:
sudo wpa_supplicant -B -c /etc/wpa_supplicant.conf -i wlan0

No sure what it is you are trying to do ?

If you need to edit the config file, it’s located here…


perhaps make a backup before editing ?

sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

it should look like this…

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev


Note: erase unused connections in the file or comment them out. This stops delay from attempts to make connections that are not there. You should read a bit about how this works.

Because it’s a laptop the wireless WiFi wouldn’t work. I downloaded the Broadcom driver and installed it. Between two postings from two different websites I got it connected wireless on my WiFi.
I’m a newbie and never worked with Debian before. Now I need to figure out how to edit and save so it will connect automatically on boot. I’m unsure how to save the settings. Any help would be appreciated. I don’t know how to locate, backup and edit the files in the attached picture.

While I have not used ubuntu since ver 5, I don’t think they are the same for your debian install.

The rest of config may not have occurred because there was no wifi network as there was no network driver for wireless hardware. But somehow I doubt it.

While I know I did this once in a laptop, I do not think I w
had to do anything but edit the wpa suplicant file. My poor memory is no help I’m sure.

There is a network gui and here is what debian says on this matter…

Not sure where you should go from there.

Fixed used instructions here and the nano text editor.