Installing ASL on Debian 11 VPS

Hi everyone,

Trying to help out a friend who wants a hub installed on his Debian 11 VPS. Tried installing ASL on the VPS, but came up with the dreaded DAHDI/DKMS issues, causing building and installation of the DAHDI kernel module to fail.

Tried looking around both here and Google in general, but so far, haven’t found a solution. I did see one script that purported to install ASL on Debian 12, but that didn’t work either.

Does anyone know of a way to install ASL onto Debian 11?

Did you try :


I’m running Allan’s build on a Debian 12 VM (under Proxmox) and it works great.

I’m sure that’s the one I tried. Didn’t work on Debian 11. I don’t have a Debian 12 VPS available to coonfirm it works there (I’ll take yours and Allan’s word on that one).

Well…there is a Debian 11 version by F4HWD but it has a nasty memory leak (but it will run for a week or two before dying)

Might have to give that a try, can always get cron to help out. :slight_smile:

Be aware there’s a bad link in his script. Here’s a link to a post I made about fixing that

Just to clarify, is this an issue with F4HWD’s install or mine (Allan-N) ?

Update : Never mind. The [bad] link is in F4HWD’s clone of ASL-Asterisk.

Yours is working great with no edits needed!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.