I have temporarily stopped working on my AllStar node

Thanks to all who have helped me with troubleshooting my home built AllStar node (G7RPG design.) Unfortunately, I did not get it working, but I have some other projects I have been neglecting and need to attend to. I wish there was someone located close enough to me that I could get help from, but I fear that is not the case. Anyway, I have not given up and will return to this project when my head clears and I have more time. 73 de KJ4FX

We’ll be here when you get back to your AllStar project.

Hi, and thanks for your reply. I have gotten the node up and running, but I had to use HamVoIP to do so. As I posted a few times here, I could not complete the RX audio test in the AllStarLink ASL to work, so I wiped the microSD and flashed the HamVoIP version on it, and had no problem completing the RX audio test. Apparently, there was no problem with my homebuilt AllStar Node, but some issue with AllStarLink ASL. I have been able to access Parrot node 40894 and successfully leave an audio test and hear the playback. So, I unhooked my monitor and keyboard, and am now trying to SSH into the node. Sadly, I know next to nothing about Linux and have not been able to communicate via SSH. Honestly, I have been a ham for a long time, am able to read schematics and design simple circuits, program ucontrollers, but this project has been a nightmare. For example, my node just announced to me that “It’s four PM,” which is great except that it’s not four PM…it’s three PM here in the CST, but I have tried 9 times to change my time zone from America New York to America Chicago and failed every time. Just one more example of something that should be easy, but is impossible for me. If I sound frustrated, it’s because I am.

I understand those frustrations. Banging my head against it and it going no where. I would like to help. Are you using putty to ssh into the node? win 10 and 11 have ssh built into power shell. Feel free to hit me with questions, I will try to keep an eye on this thread.

Hi Paul, Thanks for your response. Yes, based on what I read, I did download Putty, and tried to use it. I entered the IP address for the node, and Putty didn’t respond. I am using Win 10, so if that’s the way to go, I am ready. I was using a USB cable from the PC to the Pi, but now, I wonder if that’s necessary. Maybe I only need the wifi connection. I did enter the Pi’s IP address in Chrome and the Pi responded via wifi with a confirmation message. So, I am all ears to hear your instructions.
Charles

Trying to use a usb cable on the terminal for the pi is a very difficult thing in my mind. Yes, put the ip address of the pi in the host section of Putty. The other option is to open power shell, I just type power shell after clicking the start menu. this will open a terminal and just type “ssh repeater@{the ip of the pi}”. Mine looks like

ssh repeater@192.168.0.8

Tell me more about how chrome responded, perhaps a screen shot?

Here is the top left part of my Chrome window.
image

Here are my attempts at ssh to the node: the first is while ASL is running and the second is after I stopped ASL.
image

I think that the “Connection refused” message means the node responded, but denied access, so that’s progress.

If you are using hamvoip, I believe that ssh listens on port 222

Jim, K6JWN

Hi Jim, Thanks for the info. Can you tell me how to direct PowerShell to change the port from 22 to 222? Thanks.

ssh repeater@192.168.0.13 -P 222

Thanks, but that still gives me the connection refused message. Of course, it’s entirely possible that I am making some mistake. Do I just enter that through PowerShell or do I have to reconnect my monitor and keyboard?

try ssh repeater@192.168.0.13:222

Hi Paul.
image
Thanks, but no joy.

I guess I stumbled on the right combo to make Putty work. I honestly don’t know what changed, but I am now able to get into HamVoIP and make changes. Thanks to all of you who helped and tried to help. 73 de KJ4FX