General ASL troubles

I have been trying to get a function ASL node running for about a week now.

I am not a Linux newbie. I am not an Asterisk newbie.

My first attempt was with compiling an install from the github repository on a modern Debian install. This was as out and out no-go as it will not build properly with a modern kernel, and I wasn’t going to fool with rolling it back for one program–particularly when pre-compiled images were available.

That brings me to my second attempt using the ASL image for Raspberry Pi B3+. This ran and works perfectly well as a radio-less node, but I wanted to attach a radio. Since ALSA was out, I acquired a RIM Alinco USB device. After reading every single thing I could find, I tried to set that up with chan_simpleusb. After hours of manipulation, simpleusb was completely incapable of detecting any RX to the node.

So next I did what everyone says not to do: I ran usbradio on the Rapsberry Pi. This worked–sort of. The node worked on RX and TX, and I could use DTMF commands–sort of. I am guessing the Pi3 is simply incapable of running the DSP sufficiently because the audio was sometimes stuttering, and thus DTMF failed about half the time.

So next I tried the ASL AMD64 image. (In an attempt to completely eliminate hardware problems, I installed it on a machine grossly overpowered for the purpose). After setting everything up, Asterisk will not start. Here is the status output:

#systemctl status asterisk.service
● asterisk.service - Asterisk PBX and telephony daemon
Loaded: loaded (/lib/systemd/system/asterisk.service; enabled; vendor preset: enabled)
Active: inactive (dead)
Docs: man:asterisk(8)

Mar 05 11:30:23 repeater systemd[1]: Dependency failed for Asterisk PBX and telephony daemon.
Mar 05 11:30:23 repeater systemd[1]: asterisk.service: Job asterisk.service/start failed with result ‘dependency’.

First off, how is this possible given that this is a newly installed image? How is everything needed not already there? I am not sure how to being to correct this as it seems that updating the wrong package could break the install.

Any help with any of the problems stated would be greatly appreciated.

That has been broken for awhile now. Why it hasn’t been addressed is news to me, after the amount of people that have complained about the same with ASterisk not starting. The last several installs, I have had to download the 9.0 version of Debian then down load ASL repo like In the ASL instructions. Has worked fine after that

I recently did a number of these and every one of the installs failed to build the dahdi module during the install, triggering an error like the one you have. All I needed to do was to go to the right place and make/make install ( from /usr/src/asl-dahdi-linux-2.11.1, I think it was).

But I also found USB “stuttering” (actually breaks in the audio stream - sometimes multiple times) with R-PI and lower-powered Intel CPU’s (Atom D2500, D525). It affects both simple and USB Radio. It’s really crazy if it happens during a CW ID. Going to higher-powered hardware does not eliminate the breaks, but makes them much less frequent and shorter (one 18 ms break in a 5 minute period, for example).

They really should fix this, but I think the problem has been there since inception - if must be hard to find (although ham voip seems to have fixed it for simple usb).

Ken

Debian has had the audio stutter issue for quite a bit of time
I was really fighting it on Atom cpus (building a 2 dongle stream box)
for kicks I tried Arch and poof all glitching was gone
then it occured to me the reason why Hamvoip switched to Arch
I dont know if the 5 series kernel would help this
but it spins around the way Debian uses ALSA

I have time to mess with this a little more, and I have discovered a few things:

  1. chan_usbradio with the dsp has been up for a day and half, and it is actually running pretty well on the Pi B3+. If an ASL build compatible for Buster is released, I am certain that the Pi 4 could handle it.

  2. My problems with usbradio properly detecting DTMF are actually limited to my Kenwood D72. Using an Icom ID-51A, a Yaesu FT2D, and an Anytone 878 DTMF is working fine. I may be able to dig into the D72 and change something to make DTMF work properly (I think it is just too quiet).

  3. The install I initially tried that had dependency problems was 64-bit. When I installed the x86 version, everything seems to be working (at least asterisk will start).

This weekend, I am going to swap out the Raspberry Pi for the x86 machine running usbradio with the dsp. This was planned for this node in any case as it is to serve as a hub, and will hopefully have numerous connections. (I never really expected the Pi 3 with its atom processor, stingy RAM, and 10/100 ethernet port would be up that anyway).

I run Linux software for IRLP, remote rig control to my shack, myriad HF digital mode packages, and a transcoding multi-mode reflector; and Allstar has been by far the most complicated.

Assuming you installed this image http://dvswitch.org/files/ASL_Images/Intel-AMD/Stretch/ after creating bootable media, booting it and installing, it should have “just worked”.

That not being the case attempt to launch the Asterisk CLI with asterisk -rvvv. Is Asterisk restarting over and over? If so shut it down with astdn.sh or systemctl stop asterisk. Once it’s not running do asterisk -fnvvv and look for the first failure. Post the results here if you like.

I finally got things running with the x86 image (sort of, but that is another discussion).

My best advice for anyone installing ASL on an AMD/Intel system is to avoid the 64-bit image. Right out of the gate, the x86 image performs as expected; but Asterisk will even start on the 64-bit image.

hey - I am interested! You installed Arch Linux and then built ASL on that?
Where did you get Arch and how did you do the build?

Thanks
Ken

no i did not put the ASL package set on ARCH
I have thought about it but, never attemped it

i have built it on Debian, but now its just easy to use a prebuilt ASL image

maybe you mistook my words
Hamvoip is built on ARCH (archlinuxarm) but with out the source code thats pretty much
where it will stay

Source code for ASL is available - its open source unlike the other one.

I actually compiled ASL on Centos 7 with only minor tweaks needed. But got stopped in the “make” phase and now too busy with other things. I do not remember which source I used - probably this one: https://github.com/AllStarLink/

Since ASL used to work much better under Centos 5, and Asterisk the PBX is Centos/RHEL based, I thought I would give Centos a try. For the RPI, though, it might be that arch linux is a better choice (as shown by hamvoip). Changes to the existing build instructions might be more substantial, unfortunately