Disabling connect / disconnect messages on radioless hub

I’ve tried everything to disable the voice connect / disconnect messages on our VPS based hub node and none of the usual recommendations work. Any AllStar hub operators out there tackled this before?

For some more background, this hub is used to aggregate connections to our various repeaters but we also allow members to connect their own nodes. Node connects / disconnects to the hub get announced out every repeater and it gets seriously annoying.

telemdefault = 0

My suggestions for a hub:
duplex = 0 ; 0 = Half duplex with no telemetry tones or hang time. Ah, but Allison STILL talks!

hangtime = 0 ; squelch tail hang time 0
althangtime = 0 ; longer squelch tail hang time 0

holdofftelem = 1 ; Hold off all telemetry when signal is present on receiver or from connected nodes
; except when an ID needs to be done and there is a signal coming from a connected node.

telemdefault = 0 ; 0 = telemetry output off

telemdynamic = 0 ; 0 = disallow users to change the local telemetry setting with a COP command,

linktolink = no ; disables forcing physical half-duplex operation of main repeater while
; still keeping half-duplex semantics (optional)

nounkeyct = 1 ; Set to a 1 to eliminate courtesy tones and associated delays.

; idrecording = |ie ; id recording or morse string see http://ohnosec.org/drupal/node/87
; idtalkover = |ie ; Talkover ID (optional) default is none see http://ohnosec.org/drupal/node/129

Yup, all those already in place, except for duplex=0 (which seems decidedly suboptimal for a hub).

Are you sure the announcement are coming from the hub?

100% sure.

When I connect to the hub from one of our simplex sites that’s running HamVoIP (where duplex=0), ALL hub connected sites hear “NODE hub CONNECTED TO NODE remote”. Of course, on the RF side of that simplex site there’s total silence due to duplex=0.

OK, I’m hearing through other sources that what I’m asking isn’t possible. The ASL pseudo node does not honor telemetry settings and voiced telemetry is sent out all connected nodes, no matter what.

HamVoIP supports this but obviously not an option for running on a VPS.

My VPS hubs do not send telemetry. Using the settings I posted. Try nodes, 2100 or 2600 to test…

Status page mentions DVswitch? That’s not really the same as it doesn’t use the pseudo device, right?

Yes, it uses psuedo. I set it up.

You must’ve done something beyond those obvious settings then. Looks like 2600 is idle, mind if I link up a couple nodes to test?

Go for it. I promise you I use the settings I provided.

Oh, I believe you. Just that I’m using the same. Gotta be something we’re missing.

Nah, yours is working exactly like mine. All connect / disconnect messages are passing to all nodes.

I’m listening to 2600 now, I hear no connect / disconnect messages

I connected 47818 to 2600. Immediately started hearing other non-related telemetry messages. Then I connected one of our repeaters, 410462 to 2600, and the connection was fully announced to 47818 via 2600. Same with the disconnect. There was also a non-related telemetry message from 2600 that went out the repeater while it was connected.

I have 45951 connected to 2600. I am connecting and disconnecting node 2150. I hear nothing. do your nodes have telemetry turned on all the time?

They’re both duplex=0 but even that wouldn’t matter as the node’s own telemetry settings would be applicable only to other nodes connecting to it, not stuff happening upstream.

Try turning telemetry off on a node and retest,

Doesn’t really solve the underlying problem as we can’t dictate how others run their nodes and disabling telemetry on repeater sites where we’re using AllStar as controller induces other issues.

Thanks for the assist tho.

look into:
holdofftelem = 0 ; Hold off all telemetry when signal is present on receiver or from connected nodes except when an ID needs to be done and there is a signal coming from a connected node.

telemdefault = 1 ; 0 = telemetry output off 1 = telemetry output on (default = 1) 2 = timed telemetry output on command execution and for a short time thereafter.