Dell Wyse 3040 computer cannot boot into Debian

I tried installing the ASL 2.0.0 Beta.6 image onto a Dell Wyse 3040, and it fails to boot. I then tried installing Debian 12.4.0 onto the Dell Wyse 3040, and it fails to boot.

I’ve found a possible way to fix the probem with the Dell Wyse 3040: “Force GRUB Installation to the EFI removable media path”, otherwise, it will fail to boot. But I cannot figure out how to get past the Dell Wyse 3040 failed to boot problem when attempting to install the ASL image or Debian 12.4.0. The Dell Wyse 3040 is a fairly common AllStarLink computer, so I think there must be a step by step method to get the Dell Wyse 3040 to boot after the ASL image is installed, or Debian 12.4.0 is installed.

Dave KY0L

Did you setup the BIOS to boot off the device with the images?


The AllScan web site has good info on setting up the 3040’s

and, if I recall, check the secure boot setting

Make sure you are using the i386 image of asl 2.0 beta 6

I booted the Dell Wyse 3040 computer to the ASL 2.0.0 Beta 6 and installed it with the ISO DVD in the DVD USB drive. But when the process completed, the Dell Wyse 3040 computer will not boot. Then I tried installing Debian 12.4.0, booting to the installation ISO DVD in the USB DVD drive. Debian 12.4.0 appeared to install, but when the installation was completed, the computer will not boot to Debian. It simply fails to boot.

I setup the BIOS in the Dell Wyse 3040 to only boot using the 15.8 gig internal hard drive, or the USB DVD drive. I disabled the network booting.

I then found this post, which said that you must force GRUB to the EFI removable media path, otherwise, it will fail to boot. But it wasn’t clear how you actually did that. I happened to try the option to install Debian 12.4.0 in “Expert” installation mode, and I was able to get the following dialog box:

                              Configuring grub-efi-amd64

Some EFI-based systems are buggy and do not handle new bootloaders
correctly. If you force an extra installation of GRUB to the EFI
removable media path, this should ensure that this system will boot
Debian correctly despite such a problem. However, it may remove the
ability to boot any other operating systems that also depend on this
path. If so, you will need to make sure that GRUB is configured
successfully to be able to boot any other 0S installations correctly.

Force extra installation to the EFI removable media path?

         <Yes>                         <No>

I chose Yes during the GRUB part of the Expert Debian 12.4.0 installation process. Then at the end of the installation, the Dell Wyse 3040 computer did boot into Debian 12.4.0. Now, I have Debian 12.4.0 installed and the booting problem is resolved. However, then I would need an ASL script to run on the working Debian 12.4.0 installation.

The ASL 2.0.0 Beta 6 ISO does not give me the option to use an Expert installation, so it is not possible for me to install that ASL version on the Dell Wyse 3040, because the installation is embedded into the ASL ISO installation DVD. I don’t know if there is any method that would allow the ASL installation ISO to install on the Dell Wyse 3040 computer. I could try running a script to install ASL, if I could find a script that works to install ASL.

Dave KY0L

check this site for good 3040 info

Mike (N3IDS)


Now that you have Debian 12 installed try this…

have you tried this…

the whole article is in the link posted by Mike (N3IDS) above.