ASL-2.0.0-beta.6 Ready for Download

Download ASL 2.0.0-beta.6 here
Report Bugs/Issues here

This is a minor release in terms of bugs / features and is mostly a maintenance release.

  • Add dynamic MOTD on /etc/issue and /etc/motd
  • Move customizations to .deb packages (ASL-Asterisk repo)
  • Update versions in app_rpt
  • Bug fixes

Download ASL 2.0.0-beta.6 here

1 Like

I submitted a issue on GitHub but thought I’d also reply here for discussion.

When using the ASL-Menu to set a password nothing happens as can be seen in the attached video. Am I doing something wrong?

As you can see from this screen shot taken at 29 seconds passwd is saying it was successful:

image

GitHub issue link:
https://github.com/AllStarLink/ASL-Live-Build/issues/22

Thanks for this! I’ll look into it.

@KK9ROB I on that in the new first-time script that’s on GitHub. Maybe I fixed it. Seemed ok while testing.

3 posts were split to a new topic: Install ASL Beta on Existing Debian Server

Tried new beta image. 3 issues

  1. Raspi-config won’t assign any other user then Pi. I logged in as root to run it (not su’d, logged in)

  2. LAN connected being forced to static IP of 169.254.35.57 even after running asl-menu to select DHCP and rebooting

  3. Receive “Can’t communicate with wpa_supplicant” (from raspi-config menu) despite fact that I created a correct /etc/wpa_supplicant/wpa_supplicant.conf. Also, the binary does exist in /usr/sbin

These issues are identical on a Pi3+ and Pi4

  1. Pi user isn’t used – only repeater and root
  2. The 169.254 IP is an auto-assigned IP when a dynamic IP can’t be retrieved. Check your cable connections, try a different ethernet cable, or try using WiFi
  3. wpa_supplicant is a daemon that runs for WiFi. Try running systemctl enable wpa_supplicant
  1. I know that but I’m just reporting what raspi-config was doing. I tried to change its forced user of pi to root but it would not allow it.

  2. Cable was good and the same cable/Pi had no issues obtaining an IP assignment from my router if NOT running the beta but rather ASL 1.01 I had a different SD card

  3. I’m aware what wpa_supplicant is. I checked for the daemon was running (ps aux | grep wpa) and it was. As it turns out, there is no wpa_supplicant.conf supplied as part of the distro image. But even after I created a valid one, raspi-config reported what it did. Seems the image build needs some tweaking…