Allstarlink Connecting issue

Hello EVeryone

so i just got into the ham world and getting allstarlink set up

the node shows connected on the node list, but i cant connect to it, its just timing out,
ive port forwarded everything, ive even tried changing the port allstarlink runs on, but nothing seems to be working where i can properly connect it

its driving me bonkers cuz its showing online but shows no time outs and thats all thats happening

my ISP is xplorenet they use a 5g network i have full access to port forwarding except ports they use wich is why i tried changing my allstarlink port

i have echolink installed on my comptuer and have to use a vpn plus a proxy in order to get it to work so im assuming its the isp, any help would be appreciated

thank you all in advance


There are a lot of possibilities.
Let’s try to narrow them down.

Can you say the node numbers in question. (both #'s involved) ?

While we sort it out, don’t make a bunch of wild changes, start back at your original config & port etc, because obviously changes did not help.

Hey Mike, ofc i can share my node numbers

Allstarlink Node 60133
Echolink node 195128

ive gone and done a fresh install of allstarlink and set it up so everything is back to default,
i have ports 4569, 5198,5199 all forwarded to the machine in question in my unifi gateway control panel

its showing up that its online but still timing out,

This is what is in the registration system Look it over to see if it is correct.

So, what I need to know is what exact node number are you trying to connect to what exact node number.

Just doing some preliminary checks before we look at your files if nothing is obvious.

that looks correct its my ip and port with node,

as for connecting ive had others in the area try to connect and it times out, and when i use my phone with an app called repeaterphone wich allows me to connect to both allstar and echolink nodes it times out,

when trying to connect through echolink desktop software it also times out, echolink cant even pingtest the node

ive tried connecting it to 579051, 579050, 43085 ive even had those nodes try to connect to mine and they tell me it times out,

i have to suspect its my isp but all my ports are forwarded

if it helps mike, when it comes to echolink on my desktop computer i have to run it through a proxy for it to connect and be able to be pinged,

Due to the common problems with both asl and echolink, which are separate systems in config,
I would venture to say the issue is in your proxy.
Your going to have to do some network tracing I guess.

But you might try to ping a known node and have them ping you back as I might suspect that the issue is in the return path for acknowledgement - Inbound route to port.

i was refering to my desktop pc not the allstarlink pc,

echolink on my desktop needs to be proxied to work

allstarlink is on a seperate machine

What exactly is ‘telling you’ timeout ?

The node via cli verbose
monitor software
Allison speech
something else

any kind of connection, if someone tries to dial in to link they tell me their told it times out, any apps i have that connect to allstar nodes time out,

Go to the command line,
asterisk -rvvv

Have one of them make attempt to connect

Watch the screen output and it will tell you what is erroring within all asterisk verbose traffic.
And if that is something you don’t understand, post it here.
If you see nothing, let us know that.

You might also look in /var/log/asterisk file for errors to get a hint where to look.

One possibility is your firewall is blocking them in which case you might not see any error.

But I am assuming that ‘as you said’ your router has correct port forwarding to the correct ip of your node.

But I know nothing you are not telling me. So we are still wide open for possibilities.

I tried to connect myself.
I ‘think’ you may not have an updated node list.

look in v/var/lib/asterisk

to the date / timestamp of a file named rpt_extnodes

If it is older than an hour

try this from a system command prompt

systemctl restart updatenodelist

so heres a screenshot of my port forwarding page,

and after trying to connect using an app on my phone, it rings 9 times then connect failed : Time out, however the asterisk shows nothing

Was that screenshot taken while/after someone attempted to connect ?

While you are the only one that can tell if the IP/ports are setup correct,
I will say that
The ASL IAX port forwards should be UDP

And I can’t tell from what I see that’s what is forwarded.
Will not work if TCP only. I might assume both udp and tcp is forwarded in that, I don’t know that…

this was taken after trying to connect twice

port forwarding is for both ports, i didnt think it would matter if it was on both

I have re-read everything you have stated here a few times to get it all in perspective.

My conclusion is that you either have a firewall issue or your 5g isp is blocking ports.

SO, I am wondering what you concluded with trying to ping each others server from a known node.
(ping from a system command propmt)
This might tell us if a block is in one direction only.

In the case it is the ISP,
You might try a test by changing the port to something arbitrarily high like 8120
But be sure to set it the same at the ASL self portal and in your iax.conf and rpt.conf files if you do.
And the router.
There is no real good reason to use the default 4569 anyway.
Just makes you the target of many telephony hacks.

Can you say what version of the software you are using ?
And if you installed the iptables and fail2ban firewall included in our packages ?

iptables and fail2ban is installed,
im running debian 10, with asl installed as per the guide,

ive tried different ports like 8400 and 4000 and still no luck, ill try 8120 when i get off work tonight,

as for pinging other known nodes, would i do that from the askerisk cli?