Weather_Data.php

I installed the Text-To-Speech following the HAMVOIP instructions. .TXT files are converted to .UL sound files. My problem is that Asterisk won’t play them. If I issue the command on the CLI client: rpt localplay <node#> /tmp/weather – it shows that the sound is playing but I hear nothing. It is finding the weather.ul file but it’s blank even though there is text in the weather.txt file. I can play any .gsm file just fine but not .ul files. What am I missing? I signed up with the website as instructed and entered my API key.

did you set the API code that you need to insert into the /usr/local/etc/tts.conf file?
Also did you set the following Lines?

tts_r=-1
# tts_r is speech rate (speed). Allows values:
# from -10 (slowest speed) up to 10
# (fastest speed).

tts_hl=en-us
# tts_hl is the language setting
# See voicerss.org documentation for further
# details of what languages are supported.

tts_v=Mary

tts_f=44khz_16bit_mono

Everything is set as you stated (except for Mary). The audio is playing – but it sounds like 10 seconds of audio compressed into a half a second – or like a couple of birds tweeting for a second or shorter.

I changed the speed to -10 to slow it down and see if there was some audio. This is what I hear with the speed set to -10. MP3 Sound

I would use exactly what HamVOIP instructions says for settings. I have had great success using ‘tts_audio.sh <example.txt>’ creating /tmp/example.ul and then executing asterisk -rx “rpt localplay 123456 /tmp/example” without the extension. This is important: to play example.ul, you would execute rpt localplay 123456 /tmp/example

For some reason, it just isn’t working for me. If I change the speed back to the default, what you hear in my MP3 Sound above just goes by much faster. It is totally unintelligible. Another local ham is doing what I’m doing and his works just fine. There is something obviously wrong with my setup – Everything works great except Text to Speech. I’ve double checked and triple checked my API key. It is correct. I’m giving up.

I can take any text file and run tts_audio.sh and I just get a crap audio sound.

My version of tts_audio.sh is /usr/local/bin

-rwxr-xr-x 1 root root 7109 Mar 7 2016 tts_audio.sh

Is there a more recent version?

Taking a guess since I don’t use hamvoip or TTS in any of the same manor,
try looking for typo’s in any script command lines.

You might need to google/check proper parm usage etc .
If you used a windows editor in any of the files, I would look for corrupting hidden characters in the file as well.