I tried searching but didn’t find this exact problem. I have a GM300 that I used previously for IRLP to connect to our local repeater and it worked fine there. I am currently trying to setup an Allstar node using the same radio but I’m not having the best luck. The node transmits via the GM300 and hits the repeater but it will not receive. I assumed that if transmit works receive would just work. My current setup is:

Motorola Maxtrac GM300 UHF
USB-RIM Lite Maxtrac
Raspberry Pi 3 Model B+
Hamvoip V1.7.1-04

I am hoping someone has experienced this issue. I am thinking it’s something simple. Thanks in advance.


on your hamvoip make sure in your rpt.conf file you have duplex =2 since your running one radio in a duplex mode. then you want to adjust your rxondelay in the simpleusb tune menu so you do not get the ping pong effect.

Did you confirm that the simple USB settings that you are getting a COS/CTCSS signal.
In the simple USB menu select “V” it will show you if the COS/CTCSS is active when the repeater keys up. When nothing being received it should read “Clear” when active it will display “Active”

Ok sorry for the late reply work slows me down. Ok so I confirmed that I had duplex=2 in rpt.conf. CTCSS shows keyed when I transmit from HT. COS input stays keyed when I select no, usb, and ppinvert. When I select usbinvert or pp it does nothing when I transmit from HT. Actually I have just noticed that if I select usb COS input stays keyed and when I press PTT on HT it will repeatedly cycle through, COS detected, idle and PTT keyed on Hamvoip.

Did you restart Asterisk after you edited rpt.conf and saved your changes?

I would start with verifying your actual COS logic and the setting you have for it in usbradio/simpleusb with a vom measurement.

Yes I did that until I was about blue in the face. haha

I have 4.6v on Pin 8. If I set COSFROM to ppinvert which keeps COS keyed and I hold down transmit on my HT it cycles between keyed and clear over and over.

There is no need to use ppinvert unless you are using a parallel port for cos/ptt and need to invert the logic of the PP pin.

So that would flag the software for something that does not exist and will not change state.

If I understand your setup from what you said, you are using a usb fob.

You can’t beat the USB-RIM Lite boards, I use many…

First off, you are trying to use your radio as a “remote base”, if I understand what you’ve posted. In that setup, you would set your following rpt.conf settings to:

rxchannel=SimpleUSB/usb (remove the ; in front of this one and make sure the other four have one in front of them so that only this one is active)

duplex=1 (since you’re using the radio to talk to & listen to your repeater this radio is now considered as a remote base/control station so you would set this to be just like a mobile and make it “half duplex”… #2 makes it act like a full duplex (like a repeater), not what you want.)

In your Motorola radio settings make sure under “Radio”, “External Accessories” that “ACC EXTERNAL” is set to General I/O, that Pin 8 is set to PL/DPL - COS Detect — output ---- low and that pin 12 is set to the same (If pin 12 shows on yours, some don’t)…

Save and exit rpt.conf, then type asterisk -rvvvvvvvvvvvv, and then at that command line enter “restart now” and then press enter that way asterisk restarts without having to reboot the whole machine. Or just reboot your machine if you wish, either way as long as you do one or the other so the changes in rpt.conf take place. Now you could have done this whole change by using asl-menu and running through all that again but this ways is the simplest.

Hope this helps and gets you what you are wanting. Let us know if this works for you or not.

William, KI5PHN

Thanks a bunch william-t2! So it is working now. I don’t have the correct interface to check radio settings but it was used previously for IRLP. I am pretty confused as what to set COSFROM Mode to. I currently have it set to USB but that leaves the COS (input) constantly keyed.

usbinvert is the opposite logic

If you have it set to USB and the radio is constantly keyed than you may have your PTT set wrong so invert the ptt and see if that correct your issues. I’m not currently at my main computer where I can actually look at the settings for this radio, but you can look at the RIM-Lite schematic and on it they have some proper settings for the different Motorola radios…