Unable to Setup Allmon2

I am unable to setup Allmon2, here is where I am at and what my problem is…

Following the directions at: Allmon2 Install - AllStarLink Wiki

I reached the “Configuration” step and edited allmon.ini.php here it is now:

[Off-site Link]
host= ;ip address of my node is host=
menu=yes ;not sure where I was to set “menu=yes” this line’s default was “nomenu=yes”

when I go to type:

repeater@repeater:~$ htpasswd -cB .htpasswd *******
I get the responsed, “-bash: htpasswd: command not found”

Hi there ABJ,

The user and password is not the the same as the Linux (ssh) login. You choose allmon.ini.php id/password by setting them in /etc/asterisk/manager.conf.

Here’s a sample. In this case the user is admin and the password is yourSecretPassword.

Also, be sure the bindaddr line is uncommented.

; AMI - The Asterisk Manager Interface
; Third party application call management support and PBX event supervision
; This configuration file is read every time someone logs in
; Use the "manager list commands" at the CLI to list available manager commands
; and their authorization levels.
; "manager show command <command>" will show a help text.
; ---------------------------- SECURITY NOTE -------------------------------
; Note that you should not enable the AMI on a public IP address. If needed,
; block this TCP port with iptables (or another FW software) and reach it
; with IPsec, SSH, or SSL vpn tunnel.  You can also make the manager
; interface available over http if Asterisk's http server is enabled in
; http.conf and if both "enabled" and "webenabled" are set to yes in
; this file.  Both default to no.  httptimeout provides the maximum
; timeout in seconds before a web based session is discarded.  The
; default is 60 seconds.
displaysystemname = yes
enabled = yes
;webenabled = yes
port = 5038

;httptimeout = 60
; a) httptimeout sets the Max-Age of the http cookie
; b) httptimeout is the amount of time the webserver waits
;    on a action=waitevent request (actually its httptimeout-10)
; c) httptimeout is also the amount of time the webserver keeps
;    a http session alive after completing a successful action

bindaddr =   ; Local interface only!
;displayconnects = yes
; Add a Unix epoch timestamp to events (not action responses)
;timestampevents = yes

secret = yourSecretPassword
read = all,system,call,log,verbose,command,agent,user,config
write = all,system,call,log,verbose,command,agent,user,config

I’m not sure why htpasswd is not on your system. But that sets yet another ID/password, one for the Allmon login, which you don’t need right now. So let’s worry about that later. Post back when you get your node showing on Allmon or if you have a problem with that.

I am not sure how to get allmon to show. If I open up a browser and type in the ip address of my node, or I get a message that states Unable to connect, can’t establish a connection to the server

Sounds like Allmon is not installed on your node. You may have to install Apache, PHP, and Allmon. Depending on your Linux skill it might be easier to install a new version of AllStar.

Do you see anything at