Unable to install ASL on Dell Wyse 3040

I know this might have already been resolved before, however I have been working on trying to get a good install for a couple of weeks.

here are some facts:

Using a Dell Wyse 3040

Using image: ASL_1.01-20180417-amd64-i386-debian-stretch-netinst.iso

Goal is to use the Allscan duplex setup.

What I have done:

  1. Downloaded latest version
  2. Formatted and copied the image onto a 16gb USB drive
  3. Plugged in the USV flash drive on the front panel
  4. Followed all of the BIOS settings that Allscan recommended
  5. Booted the USB drive
  6. Followed the prompts
  7. Last message is about configuring DHCPv6
  8. Then nothing but a blank blue screen (Let this run overnight)
  9. When I hit ctrl+f2 I get a screen that opens up BusyBox


Tried again using asl-2.0.0-beta.6-kc1kcc-20210324-intel-amd64.hybrid.iso and the same results.

You may wanna try installing ASL from repo. With that you need to install debian first on your 3040.

I never had a successful install from image file either.

I used these directions on several and worked just fine!

1 Like

Forking Pork,

I have been using these instructions without success.

Are you available by phone?

Did you get this resolved yet? If not, maybe try this method…

1: Download and install to a 32 gig thumb drive the latest AllstarLink ASL 2.0.0.beta image — I use Etcher for this process,
2: Start up your Wyse 3040, hit Del several times during the beginning of the boot up so that it gets you to the bios setup screen,
3: Check your date & time – set it as needed, I have found if date off by far due to low on-board battery the system will hang, this has eaten my lunch more than once on occasion,
4: Select “Advance” tab, scroll down to “SATA MODE” and select “AHCI”, then scroll down more to “Boot Mode”, there you will have option for “Legacy/UEFI/Both” — even though mine said for “64 bit OS use Both” it didn’t work for me, finally I selected “Legacy” and off it went flying like a charm,
5: Then select “Boot Tab” — make sure that your thumb drive is in the number one spot (use the + or - move your selection up or down) and that your "SATA 0 (that’s a zero not a oh no) is in number two spot,
6: select Exit Tab, save and exit,
it should now boot and start the install process.

This worked for me on all the Wyse 3040’s, 5020’s, and 5060’s thin Clients here so hopefully it will work for you. No promises, no guarantees as they say.

The ASL Beta installs nice and clean — easy-peasy, and generally works well at first install either as a radioless node or radio node/repeater controller. As a repeater controller using the RIM-Maxtrac_RM interface between repeater/radio and Wyse machine it sets up and runs first go around — as long as you pay attention to what you are doing which I didn’t do a few times and it caused me pains in my you know what. If using the RIM-Maxtrac-RM I use the “simpleusb_tune” and not the usb_tune mode and all usually sets up and requires no further adjustments — of course that will depend on your radio(s) being used.

Again, hope this helps, let us know if it does…

William, KI5PHN