Two Node system not working

I am trying to upgrade from another controller software to Allstar Link.
I am running Beta 2.0.0-Beta.6 on a Pi 4 with two USB FOBs. My first attempt was setting up just one Node and it worked fine. Then I edited the .conf files for a second Node and neither Node works now. I have tried to build the configuration 3-4 times with no luck. One of the things that I did was to start Asterisk manually with the -fnvvv options and I get the following errors at the end of the file.

[Feb 5 15:31:10] WARNING[1042]: config.c:774 process_text_line: parse error: No category context for line 1 of /etc/asterisk/extensions.conf
Asterisk Ready.
[Feb 5 15:31:11] WARNING[1048]: config.c:774 process_text_line: parse error: No category context for line 1 of /etc/asterisk/rpt.conf
[Feb 5 15:31:11] NOTICE[1048]: app_rpt.c:22451 rpt_master: Unable to open radio repeater configuration rpt.conf. Radio Repeater disabled.

Any suggestions? BTW, examples of working .conf files from a 2 Node system would be great.

Thanks, Rick WA6SUZ

Well Rick,
Let me start by asking if you sutdown asterisk before running it again in the foreground ?

If it is running and you want to see verbose output,
asterisk -rvvv

If you want to run it in the foreground,
systemctl stop asterisk
asterisk -fnvvv

If that helps any
But let us know where you are from this point.
You likely have made some type error when you set-up the second node.
Perhaps attach your rpt.conf for some more eyes on the file.

Thanks for your quick reply Mike. I did have Asterisk stopped and tried it again with the same errors. I’m a rookie here and don’t see a way to attach my file.

Click on the upload button in the toolbar
(shows when you click the reply button)

Ok, thanks Mike. I didn’t see the .pdf option before. File is attached now.

rpt.pdf (44.6 KB)

Top of the file [nodes]
(and descriptions under it)
You have moved this to the top and it needs to be at the bottom of the file
Look at one of your old files for guidance.

One stanza describing all nodes described at the bottom.

; Note, if you are using automatic update for allstar link nodes,
; no allstar link nodes should be defined here. Only place a definition
; for your local nodes, and private (off of allstar link) nodes here.
1331 = radio@,NONE ; This must be changed to your node
; 1335 added by raa ****************
1335 = radio@,NONE ; and iax port number if not the default

put it just above this line
#includeifexists custom/rpt.conf

Don’t make to many changes at once or you will never sort this out.
Lets see what you have now…

Rick, I need to ask a question as I don’t know the answer but it may save you some frustration in the long run.

There was an issue with the Pi4 being unable to run 2 pi nodes if 2 USB devices were required.

Do you know if that issue has been overcome?
Hopefully one of the GURU’s will chime in and enlighten us.

If it hasn’t been fixed you might be wasting your time trying to use a Pi4 vs a Pi3+ as a 2 node controller.

Larry - N7FM

No, that did not help. Strange that I am getting the same context error for all four files that I edited. Extensions, iax, rpt, usbradio. I did the editing on my Linux desktop using a text editor. Maybe I should start over using Nano on the Pi to do the editing?

Thanks for your question Larry. That was my original problem. I was running two Nodes on HamVOIP using a Pi3. I get random lockups with the old system. I wanted to upgrade to a Pi4 but HamVOIP said that there was a problem with 2 nodes.
So, I hoped that Allstar Link would work with the Pi4 and 2 USB FOBs.

Well, that change was needed.
Let’s go on to extensions.conf

Ok, thanks Mike here is the extensions file.
extensions.pdf (23.6 KB)

Larry, I just booted up the 2 Node configuration on a Pi 3B+ and got the same errors

Very good Rick. Just thought I’d mention that and save you some time if that was still the case.

Hope you get it worked out.

Strange about a Pi3 not doing 2 nodes. Was that prior to their latest version upgrade.

Out of curiosity what errors do you get off the pi3 ?

Larry - N7FM

Larry, I get the same errors that I got on the Pi4, No category context. Both are running Beta 6. I have not run an earlier version of Allstar link. I inherited the maintenance of our local repeater which was running 2 nodes with HamVoip

ok on extensions
Lets try iax.conf
Mask you passwords

Ok here it is. And thanks for looking at my files.
iax.pdf (22.4 KB) raa ******** < this line is error, you need to comment out after the reg string

uncomment this
; bindaddr =
and make the address

Move your iax registration strings to after your port and address definitions but before or after the general codecs.
something like this

; Inter-Asterisk eXchange driver definition
bindport = 4569
bindaddr = ; < raa ***

disallow = all ; The permitted codecs for outgoing connections
; Audio Quality Bandwidth
;allow = ulaw ; best 87 kbps
;allow = adpcm ; good 55 kbps
;allow = gsm ; medicore 36 kbps
allow = ulaw
allow = adpcm
allow = g722
allow = g726aal2
allow = gsm
allow = ilbc

Not trying to butt into Mikes help but…

Extensions.conf file

[iaxrpt] — You show

exten => 1331,1,rpt(1331|X)
exten => 1335,1,rpt(1335|X)

Edit to be like so …
exten => 1331,1,rpt,1331|X
exten => 1335,1,rpt,1335|X

Haven’t seen your iax.conf so no comment there.

Also as a comment— Your rpt.conf file reads as quite a jumble and might be a confusion factor for you…

Were it me I would load a basic rpt.conf and copy the pertinent file settings belonging to the main node number.
to the first Stanza within. Once that is done I would copy that whole Stanza from the new rpt.conf and paste the copy at the bottom of the
first Stanza (main node) and then edit the second to utilize the number belong to your second node.

Doing things that way will allow you to tailor different settings for each of the 2 nodes.

Plus if you have problems with one node doing something wrong it is controlled by its own setting and not a shared setting.

That and if running 2 nodes from the same server you will need to define a [nodes] section for each of your node numbers.
In each your [nodes] you will need to indicate a path to the opposite node if you should you ever desire to connect the 2 nodes together.

Larry - N7FM

Thanks for the changes Mike. Good catch on my missing semicolon.
I made the changes but it didn’t help. Still getting the samd “no category context” errors

Thanks for your inputs Larry. I tried removing the parenthesis from the extensions.conf file but it still doesn’t work. I get the same context errors.

What I did was to start with a single Node (radio) and got that working with no problems. Then I followed the instructions in this Wiki “Two Nodes on One Server - AllStarLink Wiki” to add the second node. Now here I am.

I think that I should have asking a different question "Does anyone have a working configuration using one Pi4 to control two nodes using two radios?