Time announcements on Node

I have setup in the rpt.config file to do the on the hour time. I dont get the audio. Do I need to activate a module? I see app_sayunixtime is no load.
What else do I need to do?

Unless you have disabled something, no.
But likely, you have an error in your settings.

While often there are several ways to do the same thing, generally, you will need to use a macro and the scheduler.

So, post those here so we can look at them for error.

Under Status Reporting I have:
80 = status, 11 ;ID (local)
81 = status, 12 ; Time of Day (local)

If I use dtmf it will play the cw id, but will not play audio of time announcement.

Under Macro Commands I have:
1 = 8081# ; play cwid, time

Under Scheduler I have:
1= 00 * * * * ; Run Macro 1 on the hour

Formatting gets lost when you use some characters in this forum, but I got what you did.

Try this…
1 = *80,*81#

Insert a comma between each command when running more that one in a macro.

Ok. I have the comma inserted. Still nothing.
It’s like the sound file isn’t there and the scheduler isn’t correct.

to manually run the macro, the command is


star five one

Since it is macro 1

Be sure you dont have self created command conflict starting with with the 5
or more than one macro 1

So, Phil,
Did you get this to work or are you still rubbing the pumpkin ?
Curious what you found as it may help others.

Actually no. When I run the macro I get no time audio. I will get the CWID. Also, the scheduler will not run. Not sure if it’s running. I have tried enabling it but no luck yet. At this point I am running in a circle…


Let’s run a few tests.

You do have the star in the string with both commands of macro or is it lost in the format of post ?

Run the dtmf command *81 (play time), does it speak ?

Ok, if I do *81 or *80 it now comes back with the time and cwid! Great progress! No idea why it started working but progress is progress!

As for the macro; When I key up and enter *51 it keys up but no audio at all.
I have the macro as 1 = *80,*81#


Could you upload your rpt.conf file for me to eyeball.
(use upload icon in message box)

To post it here as text, formatting and char’s get lost.