Supermon 7+ "Could Not Login to Asterisk Manager" error

Just installed Supermon 7+ on a brand new node # 56550. When I login with my username and password, my node give me the message it’s attempting to log into the asterisk manager and then shortly thereafter the “Could Not Login to Asterisk Manager”

I’ve checked the manager.conf file and allmon.ini to make sure the passwords match, the IP of matches as does port 5038.

I also made sure that “web enabled” was uncommented .

I forwarded port 5038 from the outside world to my private IP also.

Is there another port or other modifications that need to be completed to make this work?

the manager password cannot have special caractere in it. And I think it is limited to 8 caractere.

change the password into the manager.conf to something simple like IDontCar

and change the passwortd into the ini file of supermon and confirm that with a simple password it does work before doing anything special

Dont forget to reload or restart asterisk before making the test so that it will have the new passord loaded in memmory

I’m sure that’s the problem - the two passwords I was trying to use both had a special character in them. I’ll give that a shot.

While we’re talking about passwords - what exactly has to match? Sounds like manager.conf and allmon2.ini have to match - but there’s also a password on the site and then the root & repeater logins. I believe root and repeater can be different - but doesn’t repeater have to match what’s on the allstarlink website?

Sorry for the basic questions - first node I’ve worked on and simply trying to get it operational so I can start toying with other features.

Well, that did not fix it - I tried a password of Abcd1234 - changed it in the Allmon.ini file and the Manager.conf file and it still says “trying to connect to asterisk”.

Would there be a port forwarding issue to address? I have Port’s 5038 & 4069 opened up to my private IP for the Asterisk node. I’m seeing some chatter about a Supermon manual, I need to track that down - that might be very helpful!

Found my problem:

My userID in the manager.conf file was set to admin still. Once I changed it to what I wanted to match the allmon.ini file, all was good. The password was able to accept special characters and more than 8 (I tried so I would learn).

I am now connecting to the asterisk manager and my node is showing up properly and I can make / break connections.