startup_macro=

According to , ********************
Startup Macro
Additionally, there is one macro type which can executed once on
system startup. Each node can have one startup macro defined in its
node stanza.
To define the startup macro, place the something similar to this in
your node stanza:
startup_macro=95320119532000
This example executes two DTMF commands to establish two links at
startup. The startup macro does not require a trailing # like a
function macro.

···

http://ohnosec.org/drupal/node/143

The start up macro executes a macro not a regular “rpt fun” command.

The start up macro should be like this:

startup_macro=*5300

 The nomncalyture is *[macro prefix](Macro)

In the case above I have a macro defined in the macro stanza that is
[macro1234]

300 = *911235#            ; Macro 300 perm link 1235 to 1234 perm

link prefix defined as *91

I have my macro prefix defined as 5 from the this statement in the

functions stanza:

[functions2249]

5=macro,1            ; Enable macro prefix = 5

The above example does work.

I agree the ohnosec example is not very clear. I'm thinking here the

macro prefix is 953 and the macros are 2011 and 2000 , not actual
node numbers, just to confuse you.

Jon VA3RQ
···

http://ohnosec.org/drupal/node/143

_______________________________________________
App_rpt-users mailing list

App_rpt-users@ohnosec.orghttp://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users

This is not correct.

The startup macro really can be any string of commands.

The reason that your macro is probably not connecting at startup is that your /var/lib/asterisk/rpt_extnodelist file hasn’t yet populated, or in any case, asterisk doesn’t yet know where the nodes are in order to connect to them.

···

--
Buddy Brannan, KB5ELV - Erie, PA
Phone: (814) 860-3194 or 888-75-BUDDY

On Nov 3, 2013, at 7:39 AM, REDBUTTON_CTRL <jrorke@cogeco.ca> wrote:

The start up macro executes a macro not a regular "rpt fun" command.

The start up macro should be like this:

startup_macro=*5300

The nomncalyture is *[macro prefix](Macro)
In the case above I have a macro defined in the macro stanza that is 300.

[macro1234]

300 = *911235# ; Macro 300 perm link 1235 to 1234 perm link prefix defined as *91

I have my macro prefix defined as 5 from the this statement in the functions stanza:

[functions2249]

5=macro,1 ; Enable macro prefix = 5

The above example does work.

I agree the ohnosec example is not very clear. I'm thinking here the macro prefix is 953 and the macros are 2011 and 2000 , not actual node numbers, just to confuse you.

Jon VA3RQ

On 11/2/2013 11:20 PM, Geoff wrote:

According to http://ohnosec.org/drupal/node/143,

********************
Startup Macro
Additionally, there is one macro type which can executed once on system startup. Each node can have one startup macro defined in its node stanza.
To define the startup macro, place the something similar to this in your node stanza:

startup_macro=*9532011*9532000
This example executes two DTMF commands to establish two links at startup. The startup macro does not require a trailing # like a function macro.
********************

Let's be honest... have you ever entered at the CLI> prompt the command of
> rpt fun [your-node] *3[their-node] {enter}
and have it fail? (Note the lack of #?)

Either way, it works for me... except when the command is entered into a node stanza...

ie:

[1776] (*) ; Change this to your assigned node number
rxchannel=Radio/usb1776 ; Rx audio/signalling channel
duplex=1
linktolink=yes
erxgain=-3 ; Echolink receive gain adjustment ; Note: Gain is in db-volts
etxgain=3 ; Echolink transmit gain adjustment ; Note: Gain is in db-volts (20logVI/VO)
scheduler=schedule
morse=morse
macro=macro
functions=functions ; Repeater Function Table
phone_functions=functions ; Repeater Function Table
link_functions=functions ; Link Function Table
telemetry=telemetry ; Telemetry descriptions
wait_times=wait-times ; Wait times
context = radio ; dialing context for phone
callerid = "Repeater" <0000000000> ; callerid for phone calls
idrecording = rpt/repeater_id ; id recording or morse string
accountcode=RADIO ; account code (optional)
hangtime=1000 ; squelch tail hang time (in ms) (optional)
althangtime=4000 ; longer squelch tail
totime=170000 ; transmit time-out time (in ms) (optional)
idtime=540000 ; id interval time (in ms) (optional)
politeid=30000 ; time in milliseconds before ID timer
; idtalkover=|i ; Talkover ID (optional) default is none
unlinkedct=ct2 ; unlinked courtesy tone (optional) default is none
remotect=ct3 ; remote linked courtesy tone (indicates a remote is in the list of links)
linkunkeyct=ct8 ; sent when a transmission received over the link unkeys
startup_macro=*3[node-number] ; this crap doesn't work.

(* = note: this story is true. The actual node number and callsigns were altered to protect the innocent)

Why doesn't it work, is what I want to know. I tried the command in the [macro1776] stanza - no good.
Re-read and saw where it -had- to be in the 'node' stanza - entered it there and still - no bueno. Que pasa?

-Geoff

_______________________________________________
App_rpt-users mailing list

App_rpt-users@ohnosec.org
http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users

_______________________________________________
App_rpt-users mailing list
App_rpt-users@ohnosec.org
http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users

Well there you go! Learned something new.

I just assumed that a start up macro would only execute macros and not normal connection commands.

RQ

···

On 11/3/2013 8:01 AM, Buddy Brannan wrote:

This is not correct.

The startup macro really can be any string of commands.

The reason that your macro is probably not connecting at startup is that your /var/lib/asterisk/rpt_extnodelist file hasn�t yet populated, or in any case, asterisk doesn�t yet know where the nodes are in order to connect to them.
--
Buddy Brannan, KB5ELV - Erie, PA
Phone: (814) 860-3194 or 888-75-BUDDY

On Nov 3, 2013, at 7:39 AM, REDBUTTON_CTRL<jrorke@cogeco.ca> wrote:

The start up macro executes a macro not a regular "rpt fun" command.

The start up macro should be like this:

startup_macro=*5300

  The nomncalyture is *[macro prefix](Macro)
In the case above I have a macro defined in the macro stanza that is 300.

[macro1234]

300 = *911235# ; Macro 300 perm link 1235 to 1234 perm link prefix defined as *91

I have my macro prefix defined as 5 from the this statement in the functions stanza:

[functions2249]

5=macro,1 ; Enable macro prefix = 5

The above example does work.

I agree the ohnosec example is not very clear. I'm thinking here the macro prefix is 953 and the macros are 2011 and 2000 , not actual node numbers, just to confuse you.

Jon VA3RQ

On 11/2/2013 11:20 PM, Geoff wrote:

According to http://ohnosec.org/drupal/node/143,

********************
Startup Macro
Additionally, there is one macro type which can executed once on system startup. Each node can have one startup macro defined in its node stanza.
To define the startup macro, place the something similar to this in your node stanza:

startup_macro=*9532011*9532000
This example executes two DTMF commands to establish two links at startup. The startup macro does not require a trailing # like a function macro.
********************

Let's be honest... have you ever entered at the CLI> prompt the command of
> rpt fun [your-node] *3[their-node] {enter}
and have it fail? (Note the lack of #?)

Either way, it works for me... except when the command is entered into a node stanza...

ie:

[1776] (*) ; Change this to your assigned node number
rxchannel=Radio/usb1776 ; Rx audio/signalling channel
duplex=1
linktolink=yes
erxgain=-3 ; Echolink receive gain adjustment ; Note: Gain is in db-volts
etxgain=3 ; Echolink transmit gain adjustment ; Note: Gain is in db-volts (20logVI/VO)
scheduler=schedule
morse=morse
macro=macro
functions=functions ; Repeater Function Table
phone_functions=functions ; Repeater Function Table
link_functions=functions ; Link Function Table
telemetry=telemetry ; Telemetry descriptions
wait_times=wait-times ; Wait times
context = radio ; dialing context for phone
callerid = "Repeater"<0000000000> ; callerid for phone calls
idrecording = rpt/repeater_id ; id recording or morse string
accountcode=RADIO ; account code (optional)
hangtime=1000 ; squelch tail hang time (in ms) (optional)
althangtime=4000 ; longer squelch tail
totime=170000 ; transmit time-out time (in ms) (optional)
idtime=540000 ; id interval time (in ms) (optional)
politeid=30000 ; time in milliseconds before ID timer
; idtalkover=|i ; Talkover ID (optional) default is none
unlinkedct=ct2 ; unlinked courtesy tone (optional) default is none
remotect=ct3 ; remote linked courtesy tone (indicates a remote is in the list of links)
linkunkeyct=ct8 ; sent when a transmission received over the link unkeys
startup_macro=*3[node-number] ; this crap doesn't work.

(* = note: this story is true. The actual node number and callsigns were altered to protect the innocent)

Why doesn't it work, is what I want to know. I tried the command in the [macro1776] stanza - no good.
Re-read and saw where it -had- to be in the 'node' stanza - entered it there and still - no bueno. Que pasa?

-Geoff

_______________________________________________
App_rpt-users mailing list

App_rpt-users@ohnosec.org
http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users

_______________________________________________
App_rpt-users mailing list
App_rpt-users@ohnosec.org
http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users

I gotta learn to click "reply to List" instead of "Reply to Sender" so that EVERYONE can see my screwup :wink:

statup_macro
does _not_ equal
startup_macro

oops... darn typos!

Where's that 'fuzzy logic' at, when ya need it? )grinz)

-Geoff/W5OMR

···

On 11/03/2013 07:18 AM, REDBUTTON_CTRL wrote:

Well there you go! Learned something new.

I just assumed that a start up macro would only execute macros and not normal connection commands.

RQ

On 11/3/2013 8:01 AM, Buddy Brannan wrote:

This is not correct.

The startup macro really can be any string of commands.

The reason that your macro is probably not connecting at startup is that your /var/lib/asterisk/rpt_extnodelist file hasn�t yet populated, or in any case, asterisk doesn�t yet know where the nodes are in order to connect to them.

I agree with Buddy, the startup macro can be any function or functions, not just other macros.
I just tested this in various combinations and all worked.

The most likely reason your connect startup macro doesn’t work will be because one or the other node does not know about the other one yet.

You can overcome this by manually configuring each node in the [nodes] stanza. Do this on both systems, the one connecting and the one being connected to. That way they can connect to each other even if they do not have internet connectivity to the allstarlink system. Naturally this will not work if they need the Internet to connect to each other and they use DHCP and their address might change.

Chuck WB9UUS

···

On Sun, Nov 3, 2013 at 7:18 AM, REDBUTTON_CTRL jrorke@cogeco.ca wrote:

Well there you go! Learned something new.

I just assumed that a start up macro would only execute macros and not normal connection commands.

RQ

On 11/3/2013 8:01 AM, Buddy Brannan wrote:

This is not correct.

The startup macro really can be any string of commands.

The reason that your macro is probably not connecting at startup is that your /var/lib/asterisk/rpt_extnodelist file hasn’t yet populated, or in any case, asterisk doesn’t yet know where the nodes are in order to connect to them.

Buddy Brannan, KB5ELV - Erie, PA

Phone: (814) 860-3194 or 888-75-BUDDY

On Nov 3, 2013, at 7:39 AM, REDBUTTON_CTRLjrorke@cogeco.ca wrote:

The start up macro executes a macro not a regular “rpt fun” command.

The start up macro should be like this:

startup_macro=*5300

The nomncalyture is *macro prefix

In the case above I have a macro defined in the macro stanza that is 300.

[macro1234]

300 = *911235# ; Macro 300 perm link 1235 to 1234 perm link prefix defined as *91

I have my macro prefix defined as 5 from the this statement in the functions stanza:

[functions2249]

5=macro,1 ; Enable macro prefix = 5

The above example does work.

I agree the ohnosec example is not very clear. I’m thinking here the macro prefix is 953 and the macros are 2011 and 2000 , not actual node numbers, just to confuse you.

Jon VA3RQ

On 11/2/2013 11:20 PM, Geoff wrote:

According to http://ohnosec.org/drupal/node/143,


Startup Macro

Additionally, there is one macro type which can executed once on system startup. Each node can have one startup macro defined in its node stanza.

To define the startup macro, place the something similar to this in your node stanza:

startup_macro=95320119532000

This example executes two DTMF commands to establish two links at startup. The startup macro does not require a trailing # like a function macro.


Let’s be honest… have you ever entered at the CLI> prompt the command of

CLI> rpt fun [your-node] *3[their-node] {enter}

and have it fail? (Note the lack of #?)

Either way, it works for me… except when the command is entered into a node stanza…

ie:

[1776] (*) ; Change this to your assigned node number

rxchannel=Radio/usb1776 ; Rx audio/signalling channel

duplex=1

linktolink=yes

erxgain=-3 ; Echolink receive gain adjustment ; Note: Gain is in db-volts

etxgain=3 ; Echolink transmit gain adjustment ; Note: Gain is in db-volts (20logVI/VO)

scheduler=schedule

morse=morse

macro=macro

functions=functions ; Repeater Function Table

phone_functions=functions ; Repeater Function Table

link_functions=functions ; Link Function Table

telemetry=telemetry ; Telemetry descriptions

wait_times=wait-times ; Wait times

context = radio ; dialing context for phone

callerid = “Repeater”<0000000000> ; callerid for phone calls

idrecording = rpt/repeater_id ; id recording or morse string

accountcode=RADIO ; account code (optional)

hangtime=1000 ; squelch tail hang time (in ms) (optional)

althangtime=4000 ; longer squelch tail

totime=170000 ; transmit time-out time (in ms) (optional)

idtime=540000 ; id interval time (in ms) (optional)

politeid=30000 ; time in milliseconds before ID timer

; idtalkover=|i ; Talkover ID (optional) default is none

unlinkedct=ct2 ; unlinked courtesy tone (optional) default is none

remotect=ct3 ; remote linked courtesy tone (indicates a remote is in the list of links)

linkunkeyct=ct8 ; sent when a transmission received over the link unkeys

startup_macro=*3[node-number] ; this crap doesn’t work.

(* = note: this story is true. The actual node number and callsigns were altered to protect the innocent)

Why doesn’t it work, is what I want to know. I tried the command in the [macro1776] stanza - no good.

Re-read and saw where it -had- to be in the ‘node’ stanza - entered it there and still - no bueno. Que pasa?

-Geoff


App_rpt-users mailing list

App_rpt-users@ohnosec.org

http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users


App_rpt-users mailing list

App_rpt-users@ohnosec.org

http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users


App_rpt-users mailing list

App_rpt-users@ohnosec.org

http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users

OK Im using startup_macro =*9531999
my thought is that my node 42282 would automatically reconnect to 1999 which is my allstar dmr bridge

and I wrong or does this still work

please advise, thanks