Sleep Mode issue

I’m looking install a node on our local repeater that users can bring online and take off line as needed, have it sleep till a user wants to bring it up. A time out to but it back in sleep mode after a timeout disconnects it from remote nodes. It sounds like sleep mode would be an option for this. But it’s possible I’m not understanding the intended use of sleep mode.

I’m wondering if I’m missing something to enable sleep mode as an option.
I have added the following to my rpt.conf

> ; Sleep modes
> ;949=cop,49 ;Disable incoming connections (control state NOICE)
> ;950=cop,50 ;Enable incoming connections (control state NOICD)
> 951=cop,51 ;Enable sleep mode
> 952=cop,52 ;Disable sleep mode
> 953=cop,53 ;Wake up from sleep
> 954=cop,54 ;Go to sleep
> sleeptime = 120 ; 

Currently a short sleep time for testing. short sleep time for testing.
If I issue a *951 followed by a *854 the system does nothing with either entry making me wonder if the version I have supports it. Version 153.327

Welcome @w3edp,

The node should say the letters ‘S L E P N’ when you execute *951.

Just test on my ASL and my HamVoIP nodes:

PBX*CLI> rpt cmd 2522 cop 51 xx
    -- <DAHDI/pseudo-1293455915> Playing 'letters/s' (language 'en')
    -- <DAHDI/pseudo-1293455915> Playing 'letters/l' (language 'en')
    -- <DAHDI/pseudo-1293455915> Playing 'letters/p' (language 'en')
    -- <DAHDI/pseudo-1293455915> Playing 'letters/e' (language 'en')
    -- <DAHDI/pseudo-1293455915> Playing 'letters/n' (language 'en')
    -- Hungup 'DAHDI/pseudo-1293455915'
    -- Hungup 'DAHDI/pseudo-1888068130'
PBX*CLI> rpt cmd 2522 cop 54 xx
    -- <DAHDI/pseudo-1277364724> Playing 'letters/s' (language 'en')
    -- <DAHDI/pseudo-1277364724> Playing 'letters/l' (language 'en')
    -- <DAHDI/pseudo-1277364724> Playing 'letters/e' (language 'en')
    -- <DAHDI/pseudo-1277364724> Playing 'letters/e' (language 'en')
    -- <DAHDI/pseudo-1277364724> Playing 'letters/p' (language 'en')
    -- Hungup 'DAHDI/pseudo-1277364724'
PBX*CLI> rpt cmd 2522 cop 52 xx
    -- <DAHDI/pseudo-837240084> Playing 'letters/s' (language 'en')
    -- <DAHDI/pseudo-837240084> Playing 'letters/l' (language 'en')
    -- <DAHDI/pseudo-837240084> Playing 'letters/p' (language 'en')
    -- <DAHDI/pseudo-837240084> Playing 'letters/d' (language 'en')
    -- <DAHDI/pseudo-837240084> Playing 'letters/s' (language 'en')
    -- Hungup 'DAHDI/pseudo-837240084'
PBX*CLI>

Have you seen https://wiki.allstarlink.org/wiki/Sleep_Mode?

Does that help?

Thanks I do get the same results.
It does not seem to prevent a user from connecting to another node when asleep, but that could be my misunderstanding the use of the sleep option.

I was looking for a way to disable the node in such a way that it looks for a wake up before it will let you connect out to any other nodes, and while asleep would not broadcast id or other announcements.

I may end up doing it with a relay to remove the connection to radio.

There’s a way to do it without a relay.

Maybe this will help you:
https://wiki.allstarlink.org/wiki/Activity_Timer

or this:
https://wiki.allstarlink.org/wiki/Rpt.conf#Control_States_Stanza
And the Schedule Stanza just below this.