Simple usb error

I have this error when trying to use simple usb.
SimpleUSB must be enabled in modules.conf and selected in rpt.conf .
As far as I can tell It is selected. I cannot config simpleusb.

Mike

Just confirming:
In rpt.conf
rxchannel = SimpleUSB/usb_<node_number>

In modules
noload => chan_usbradio.so
load => chan_simpleusb.so

Thanks,
Bob
K6ECM

Hi Bob,
Here is my modules.conf for channels
; Channels

noload => chan_agent.so ; Agent Proxy Channel
noload => chan_alsa.so ; ALSA Console Channel Driver
noload => chan_beagle.so ; Beagleboard Radio Interface Channel Driver
load => chan_dahdi.so ; DAHDI Telephony
noload => chan_echolink.so ; echolink Channel Driver
noload => chan_features.so ; Feature Proxy Channel
noload => chan_gtalk.so ; Gtalk Channel Driver
load => chan_iax2.so ; Inter Asterisk eXchange (Ver 2)
load => chan_local.so ; Local Proxy Channel (Note: used internal
noload => chan_oss.so ; Channel driver for OSS sound cards
noload => chan_phone.so ; Generic Linux Telephony Interface driver
noload => chan_pi.so ; DMK Engineering “PITA” Board on Rpi2/3 Channel Driver
load => chan_simpleusb.so ; CM1xx USB Cards with Radio Interface Channel Driver (No DSP)
noload => chan_sip.so ; Session Initiation Protocol (SIP)
noload => chan_tlb.so ; TheLinkBox Channel Driver
noload => chan_usbradio.so ; CM1xx USB Cards with Radio Interface Channel Driver (DSP)
noload => chan_usrp.so ; GNU Radio interface USRP Channel Driver
noload => chan_voter.so ; Radio Voter Channel Driver

Here is my rpt.conf

592991 = radio@127.0.0.1:4569/592991,NONE ; This must be changed to your node number
; and iax port number if not the default

[592991] ; Change this to your assigned node number

                                    ; Must also be enabled in modules.conf
				; Rx audio/signalling channel. Choose ONLY 1 per node stanza

				; Enable the selected channel driver in modules.conf !!!

; rxchannel = dahdi/pseudo ; No radio (hub)
rxchannel = SimpleUSB/usb_592991 ; SimpleUSB
; rxchannel = Pi/1 ; Raspberry Pi PiTA
; rxchannel = Radio/usb_1999 ; USBRadio (DSP)
; rxchannel = Dahdi/1 ; PCI Quad card
; rxchannel = Beagle/1 ; BeagleBoard
; rxchannel = USRP/127.0.0.1:34001:32001; GNU Radio interface USRP
; rxchannel = Voter/1999 ; RTCM device

if you have ASL - simpleusb-tune-menu
if you have HAMVOIP select # 12 from the menu when you log in using putty(ssh) or run
simpleusb-tune-menu

Sorry, your comment didn’t make much sense in context.
I know how to start simple usb, but the problem is, when I try, all I get is a statement saying simpleusb needs to be selected in 2 config files, this has been set but still get the error message.
I am using ASL
Mike

can you also show your simpleusb.conf ?

; If you are going to use this channel driver, you MUST enable it in modules.conf
; change:
; noload => chan_simpleusb.so ; CM1xx USB Cards with Radio Interface Channel Driver (No DSP)
; to:
; load => chan_simpleusb.so ; CM1xx USB Cards with Radio Interface Channel Driver (No DSP)

; SimpleUSB configuration

[general]

[usb_592991]

eeprom = 0 ; EEPROM installed: 0,1
; 0 = no (default)
; 1 = yes

hdwtype = 0 ; Leave this set to 0 for USB sound fobs modified using
; the instructions from usbfob.pdf. Use a setting of
; 1 is for Dingotel/Sph interfaces.

; Receiver parameters

rxboost = 0 ; 0 = 20db attenuator inserted, 1= 20db attenuator removed
; Set to 1 for additonal gain if using a low-level receiver output

carrierfrom = usbinvert ; no,usb,usbinvert
; no - no carrier detection at all
; usb - from the COR line on the USB sound fob (Active high)
; usbinvert - from the inverted COR line on the USB sound fob (Active low)

ctcssfrom = usbinvert ; no,usb,usbinvert
; no - CTCSS decoding, system will be carrier squelch
; usb - CTCSS decoding using input from USB sound fob (Active high)
; usbinvert - from the inverted CTCSS line on the USB sound fob (Active low)

deemphasis = no ; enable de-emphasis (input from discriminator)

plfilter = no ; enable PL filter

;rxondelay = 0 ; number of 20ms intervals to hold off receiver turn-on indication

; Transmitter parameters

txmixa = voice ; Left channel output (A): no,voice
; no - Do not output anything
; voice - output voice only

txmixb = voice ; Right channel output (B): no,voice
; no - Do not output anything
; voice - output voice only

txboost = 0

invertptt = 0 ; Invert PTT: 0,1
; 0 - ground to transmit
; 1 - open to transmit

preemphasis = 0 ; Perform standard 6db/octave pre-emphasis

; pager = no ; no,a,b (e.g. pager = b means “put the normal repeat audio on channel A, and the pager audio on channel B”)

; duplex3 = 0 ; duplex 3 gain setting (0 to disable)

duplex = 0 ; Duplex 0,1
; 0 - half duplex
; 1 - full duplex

#includeifexists custom/simpleusb.conf

So,
Let’s see if the SO module is loaded. From a asterisk CLI>

module show like usb

This should show you that simpleusb is loaded into memory.

Let me know if not.

Connected to Asterisk GIT 6a9b0c6 currently running on n3idsdell (pid = 454)
Verbosity is at least 3
n3idsdellCLI> module show like usb
Module Description Use Count
chan_simpleusb.so simple usb Radio Interface Channel Drive 0
1 modules loaded
n3idsdell
CLI>

It is loaded.

SO, if we go back to your original error, post
What exactly are you doing when you get the error? as in command you are running etc

From asl main menu,
option #4 Run simpleusb-tune-menu for simpleusb configuration.
When selected I get this error - simpleusb must be enabled in modules.conf and selected in rpt.conf.

both of those requirements are met.

This prevents me from adjusting any of the simpleusb options.

after more experimenting, going into the bash shell.
entering sudo -s
simple-tune-menu

I was able to get into the simpleusb menu
but on the asl-menu i still get the error

Mike

That is where I was eventually headed.

You need to run the menu as root/su/sudo to have rights to execute the menu option. Which is the same as if you typed it at command line.

Can I ask what guide you were using to do this?

I think I stumbled upon it on some forum post. I don’t remember exactly where.
But I thought … ok, lets give that a try.
would I do … sudo -s asl-menu?

tried…didn’t work

Mike

LOL
Well, hard for me to relate in practice as I run everything local or ssh ‘as root’.

But I’ll look into the menu issue. It’s likely known except for me LOL

Am having the same issue. It all worked until I changed from the simpleusb to the radiousb. I had this happen before on a different allstar node. Had to reflash the pi and start all over again. Must be something in the code for the asl menu that does not overwrite some file. If you find something on a way to fix this let me know. Am using 2.0 asl on a pi and a dell client computer. Well, the dell client is working. Not the pi. I would hate to start over and lose my settings.

Good luck

The same issue as which ?

Can’t use usbradio ?

Did you edit modules.conf and enable usbradio ?

Hello Mike

Am using ASL Version 2.0.0-beta.6

The same issue as which ?

From asl main menu,
option #4 Run simpleusb-tune-menu for simpleusb configuration.
When selected I get this error - simpleusb must be enabled in modules.conf and selected in rpt.conf.

Can’t use usbradio ?

When I switched to usbradio I get the same error.

Did you edit modules.conf and enable usbradio ?

I have updated the modules.conf and the rpt.conf and still get the same response.

This all started when I tried to switch from simpleusb to radiousb.

I believe, since my memory sometimes is so short, this has come up a few times and was recently answered.
I think the menu item is amuck.
You have to run the file it runs manually.

It may take me a while to look it up myself, but perhaps someone has the info before I look it up from where I am now.

I did find a post that you can run it manually.

bash shell.
entering sudo -s
radio-tune-menu

It’s just a pain going back and forth.

Thanks for your help. Take care.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.