RTCM Squelch with Motorola SLR5700

Hello all,
I’ve been fighting an issue for months now. Am trying to use a Motorola SLR5700 repeater in analog mode with an RTCM. It has the exact same issue as using an RTCM without the “Chuck Squelch” modification. It has unreliable squelch detection and often keeps squelch open long after signal (and PL) are gone, at the worst, up to a full second.

I opened a case with Motorola, and eventually got to the engineer that designed some of the hardware. The SLR5700 was a digital repeater from the ground up, and never really designed for analog, so this might be an uphill battle… nonetheless, I thought I’d ask this here first.

The audio that is “discriminator” is really a DSP version of audio. It works fine, but it cuts off rather sharply at 4khz on the dot. More than 40db down above 4khz. Moto says “as designed”. Not being a C, or DSP wizard, I am wondering the the RTCM “squelch” works much like a normal analog squelch by looking at the audio in the typical 6khz range, and since there is almost nothing there on the SLR5700, isn’t working right.

Can anyone here help me verify that this is how the RTCM squelch works, and if I have any options given that the audio I have to work with from the repeater is only available up to 4khz?

Been tearing my hair out on this one for a while, and hoping to come to some other conclusion than “Don’t use an SLR5700”. Any thoughts, ideas, or guidance welcome.
Thanks
73
James
KI0KN

Unfortunately that’s the botton line, it will never work. Been there done that… Sorry be the bearer of bad news. K9IAA did extensive work on this and came to the same conclusion.

The only hope, and it’s a thin hope, is there is a DC RSSI output on the 5700. A clever person might be able to modify the RTCM to use that.

We have 2 SLR 8000’s working in Analog mode… arent they the same animal, but just in 100 watts?

OK, now you’ve got my ears perked!! Yes, I believe in my discussions with Motorola that the 8000 has the same RX chain as the 5700.

You have these running in Analog wide-band mode with an RTCM? And you have no squelch problems after the incoming signal unkeys? Are you using DIAL?

I’d love to learn more about your setup, what firmware you are running in the repeater, what firmware you are running in the RTCM, and what is different between you setup and mine.

Would you mind sharing details?

73

James

KI0KN

···

On Wed, Apr 29, 2020 at 9:22 PM Conrad Baker via AllStarLink Discussion Groups noreply@community.allstarlink.org wrote:


KG5FQT

    April 30

We have 2 SLR 8000’s working in Analog mode… arent they the same animal, but just in 100 watts?


Visit Topic or reply to this email to respond.

To unsubscribe from these emails, click here.

Conrad, any chance you could share anything about your setup? I am at a crossroads right now with several expensive repeaters on the bench I need to decide what to do with soon if I can’t make further progress. Anything you can share would be most appreciated. Thanks!
73
James
KI0KN

Hi James,

Are you trying to do just straight analog CSQ audio, or are you trying to deal with PL too?

I have two SLR’s sitting here on the bench, getting ready to go out in to the field later this year (when I can get to the top of the mountain). They are connected to a VOTER, which is the through-hole version of the RTCM.

I haven’t seen any issues yet with squelch issues like you describe, but this is just bench testing.

Interesting to hear your response from Motorola, that confirms what I found on my own. If you listen to the “discriminator” audio out of the SLR, it doesn’t doesn’t sound like “normal” audio. Indeed it sounds like “digital audio”, and looks like the same on a scope (it is clipped/limited).

I have the procedure I used to align my radios with the VOTER’s, but you’ll need to let me know a little more about your setup.

I will tell you that the SLR is VERY sensitive to audio levels.

You need to have a service monitor, and the Motorola CPS and Tuner software to make this go.

Specifically for aligning the receiver, you will need to do it in the Tuner software, and you have to align it as a 12.5kHz radio.

I am using the VOTER/RTCM firmware version 1.5 with “Chuck Squelch” and “BEW”. I am not using the BEW option, at this point, that may change when I get it up on the mountain. Your mileage may vary, and you may want to try other firmware versions (the details for recompiling firmware is on the Wiki).

I’ll post my notes, when you let me know what you are working with.

Cheers!

Lee

Hi Lee,

Thanks for the response. We use PL on everything, too much “squawk” around anymore to leave the machines CSQ. I am running RTCM with 1.5 firmware and with the Chuck modifications. Been working beautifully on all the Kenwood stacks, but it’s horrible on the SLR5700. Been fighting this for almost a year.

I have not seen or heard of the “BEW” option. That is worth a look as it sounds like it’s attempting to fix the exact problem I am having. I just found it documented here:

https://wiki.allstarlink.org/wiki/RTCM_Client#DSP.2FBEW and I see the compiled and source files on github now.

For some background, I run a local instance of DIAL at each site to keep latency low. Voters and link obviously ride the microwave everywhere. We make extensive use of voted sites, but do not use any simulcast.

I have a service monitor and all other necessary equipment, and I have CPS and Tuner. I haven’t done any specific tuning to the repeater. I’ve done the noise/diode cal on the RTCM, and i’ve set levels on RX and TX like I do for everything else. I use the dipswitch/LED setting for balancing the incoming RX audio while injecting a full quieting 1khz tone modulated signal that is deviated 3.6khz (I usually set for 600hz deviation of PL) Then generate an output signal with the control op code on the asterisk console and set the TX pot for a matching 3.6khz out. Alternatively, I set everything for 3khz in/out without PL when it’s more appropriate to adjust without PL first.

I’d love to hear your procedure for alignment/tuning. I have 2 of these SLRs now which both suck to listen to because of the squelch, and we would really like to keep swapping out the older analog machines with these if I can fix this since we use the 5700 for our DMR sites as well. Nice to have a single platform where possible.

Anxious to learn more…

Thanks

73

James

KI0KN

···

On Wed, May 13, 2020 at 8:41 PM Lee via AllStarLink Discussion Groups noreply@community.allstarlink.org wrote:


ve7fet

    May 14

Hi James,

Are you trying to do just straight analog CSQ audio, or are you trying to deal with PL too?

I have two SLR’s sitting here on the bench, getting ready to go out in to the field later this year (when I can get to the top of the mountain). They are connected to a VOTER, which is the through-hole version of the RTCM.

I haven’t seen any issues yet with squelch issues like you describe, but this is just bench testing.

Interesting to hear your response from Motorola, that confirms what I found on my own. If you listen to the “discriminator” audio out of the SLR, it doesn’t doesn’t sound like “normal” audio. Indeed it sounds like “digital audio”, and looks like the same on a scope (it is clipped/limited).

I have the procedure I used to align my radios with the VOTER’s, but you’ll need to let me know a little more about your setup.

I will tell you that the SLR is VERY sensitive to audio levels.

You need to have a service monitor, and the Motorola CPS and Tuner software to make this go.

Specifically for aligning the receiver, you will need to do it in the Tuner software, and you have to align it as a 12.5kHz radio.

I am using the VOTER/RTCM firmware version 1.5 with “Chuck Squelch” and “BEW”. I am not using the BEW option, at this point, that may change when I get it up on the mountain. Your mileage may vary, and you may want to try other firmware versions (the details for recompiling firmware is on the Wiki).

I’ll post my notes, when you let me know what you are working with.

Cheers!

Lee


Visit Topic or reply to this email to respond.

To unsubscribe from these emails, click here.

Well, I just dropped the DSP/BEW code in, re-did my noise/diode calibrations, checked all levels and tried with BEW =0 and BEW=1
There is absolutely no noticeable difference from the non BEW code, with either BEW setting.

To be honest, I am not even sure I am chasing the right thing down here anymore. I spent months thinking it was a PL detection issue with the SLR as I could see a wicked delay in the output pin state change from the time PL stopped being present on the carrier. That turned out to actually be a problem, but Motorola fixed it in the 2.X firmware. That made no difference.

One thing that is very noticeable. If I use a radio with reverse-burst capability, the problem is almost non-existent. 9 times out of 10, I get no unsquelched audio transmitted upon releasing PTT, and on the 10th time, it’s a really really small amount. If I use any other radio without reverse burst, the problem is quite bad. It’s absolutely the worst with Yaesu radios. I can duplicate the problem 100% of the time on 100% of the transmissions with nearly any Yaesu radio, while my XRP6550, XPR7550’s are nearly perfect.

Maybe I am chasing the wrong thing here and possibly it’s not squelch or PL? I’d love to hear if there are ideas outside of what I’ve been investigating.

Thanks

James

KI0KN

···

On Thu, May 14, 2020 at 1:41 PM James Cizek james.m.cizek@gmail.com wrote:

Hi Lee,

Thanks for the response. We use PL on everything, too much “squawk” around anymore to leave the machines CSQ. I am running RTCM with 1.5 firmware and with the Chuck modifications. Been working beautifully on all the Kenwood stacks, but it’s horrible on the SLR5700. Been fighting this for almost a year.

I have not seen or heard of the “BEW” option. That is worth a look as it sounds like it’s attempting to fix the exact problem I am having. I just found it documented here:

https://wiki.allstarlink.org/wiki/RTCM_Client#DSP.2FBEW and I see the compiled and source files on github now.

For some background, I run a local instance of DIAL at each site to keep latency low. Voters and link obviously ride the microwave everywhere. We make extensive use of voted sites, but do not use any simulcast.

I have a service monitor and all other necessary equipment, and I have CPS and Tuner. I haven’t done any specific tuning to the repeater. I’ve done the noise/diode cal on the RTCM, and i’ve set levels on RX and TX like I do for everything else. I use the dipswitch/LED setting for balancing the incoming RX audio while injecting a full quieting 1khz tone modulated signal that is deviated 3.6khz (I usually set for 600hz deviation of PL) Then generate an output signal with the control op code on the asterisk console and set the TX pot for a matching 3.6khz out. Alternatively, I set everything for 3khz in/out without PL when it’s more appropriate to adjust without PL first.

I’d love to hear your procedure for alignment/tuning. I have 2 of these SLRs now which both suck to listen to because of the squelch, and we would really like to keep swapping out the older analog machines with these if I can fix this since we use the 5700 for our DMR sites as well. Nice to have a single platform where possible.

Anxious to learn more…

Thanks

73

James

KI0KN

On Wed, May 13, 2020 at 8:41 PM Lee via AllStarLink Discussion Groups noreply@community.allstarlink.org wrote:


ve7fet

    May 14

Hi James,

Are you trying to do just straight analog CSQ audio, or are you trying to deal with PL too?

I have two SLR’s sitting here on the bench, getting ready to go out in to the field later this year (when I can get to the top of the mountain). They are connected to a VOTER, which is the through-hole version of the RTCM.

I haven’t seen any issues yet with squelch issues like you describe, but this is just bench testing.

Interesting to hear your response from Motorola, that confirms what I found on my own. If you listen to the “discriminator” audio out of the SLR, it doesn’t doesn’t sound like “normal” audio. Indeed it sounds like “digital audio”, and looks like the same on a scope (it is clipped/limited).

I have the procedure I used to align my radios with the VOTER’s, but you’ll need to let me know a little more about your setup.

I will tell you that the SLR is VERY sensitive to audio levels.

You need to have a service monitor, and the Motorola CPS and Tuner software to make this go.

Specifically for aligning the receiver, you will need to do it in the Tuner software, and you have to align it as a 12.5kHz radio.

I am using the VOTER/RTCM firmware version 1.5 with “Chuck Squelch” and “BEW”. I am not using the BEW option, at this point, that may change when I get it up on the mountain. Your mileage may vary, and you may want to try other firmware versions (the details for recompiling firmware is on the Wiki).

I’ll post my notes, when you let me know what you are working with.

Cheers!

Lee


Visit Topic or reply to this email to respond.

To unsubscribe from these emails, click here.

Maybe I can shed a little light on this. The BEW mode (Baseband Examination Window) only works for RTCM noise squelch. Noise squelch only works when menu item 13 is set to 0 (normal). Setting menu item 13 to 1 (Ignore COR) uses the CTCSS input pin for COR.

With 13 set to 1 how you wire the RTCM CTCSS pin to your radio will determine squelch operation. You typically have 3 options depending on how the radio is programed 1) Noise squelch, 2) CTCSS or 3) Noise squelch and CTCSS. Generally option 3 is preferred.

Hi James,

This is going to be long, so grab a coffee. :slightly_smiling_face:

As you know, these radios were really made for 12.5kHz channel operation, it is a bit of a kludge that they do to make them do 25kHz, basically by bonding two 12.5kHz channels together inside the radio… at least, that is what it looks like they are doing.

Here are my notes on alignment… note, I have an HP8920/8921 series test set, so some of the cues in here are for it’s audio filters…

This procedure is for if you are using Asterisk/RTCM to generate PL. (I have a slightly different procedure if you are generating PL in the SLR TX instead).

The SLR5700 is very sensitive to levels… things go sideways when you over-drive the modulator.

There is a note in the Service Manual:

“If the manufacturer of the third party controller specifies that the Tx Audio is not to be pre-emphasized, use Pin 1 instead of Pin 22.” Fact, or fiction?

Anyways…

Here are the pre-requisite conditions:

-using an RTCM/VOTER
-loaded with v1.5/Chuck Squelch/DSP BEW firmware (BEW disabled)
-Intent to support RX PL
-Configured for TX PL
-Configured to fallback to offline repeat

In voter.conf, make sure we have: MAKE SURE YOU EDIT THE RIGHT VOTER CONTEXT IF MORE THAN ONE EXISTS

txctcss = 136.5
;txctcsslevel = 50 ;this is a calibrated value, DO NOT CHANGE
txctcsslevel = 0
txtoctype = phase

Yes, we want to initially set txctcsslevel to 0… we’ll set the level later. We need these settings so that the channel drive configures itself properly for flat audio.

CPS Settings:

Accessories --> Audio Type --> Flat Unsquelch
-This disables the audio gate to let audio out of the RX pin at all times.
-The “discriminator audio” is clipped and looks (and sounds) more like data than true analog audio.
-Haven’t run that in to an audio spectrum analyzer, but I suspect it is missing a lot of high frequency
spectrum audio, hence maybe requiring the use of BEW.

GPIO
Pin #2 - External PTT, Active Low, Debounce
Pin #4 - CSQ, Active Low (not used)
Pin #5 - PL/Talkgroup Detect, Active High

Channel 1 - Analog
Channel Bandwidth - 25kHz
Squelch - Normal (no effect, since we’re not using CSQ detect)
MPT1237 - Un-checked (this changes something about the RX audio… so we’ll just leave it alone)

Set the RX Squelch Type to CSQ for tuning. Set to PL, if desired, when done.
Leave TX Squelch Type at CSQ, we’ll generate the PL externally (in the RTCM/VOTER/Asterisk).

RX Audio is from Pin 1 of the DB25.
TX Audio is to Pin 13 (TX Data). This “should” go direct to the modulator… at least it normally would…

Get the RTCM up and running and connected to the host.

JP1 should be IN to disable the 20dB pad.
JP2 should be OUT.

With no signal applied, do the Diode Calibration routine. Insert JP10, then insert JP9.

This will do the Diode Calibration and the Squelch Calibration at the same time.

Wait for the RX LED to stop flashing and go solid.

The console should show the Diode Calibration being written to EEPROM (about 57).

Remove JP10 then remove JP9.

Squelch Calibration should be written to EEPROM (about 45).

Launch the Motorola Tuner. This is where things start getting hinky. The repeater is designed for 12.5kHz, they do some funny business to make it work at 25kHz. Alignment needs to be done at 1.5kHz deviation (60% rated system deviation for 12.5kHz) to get the levels to work right.

Click Read.

Click on Rated Volume.

Feed 460.050 (155.075) with 1kHz @ 1.5kHz in to the RX.

If you scope JP1 in the RTCM, you should see 560mVpp/345mVrms.

In the RTCM console, select 97 to look at the RX bar graph.

Adjust the RX Gain (R35) in the RTCM to get 3kHz lined up… trust me.

Click Write (we’re not going to change the softpot in the repeater, but you have to “write” to exit).

Click on Audio Level.

Set the test set to RX 460.025 (155.025). Note the repeater RX is still configured for 460.050 (155.075)

Send 460.050 (155.075) with 1kHz @ 1.5kHz in to the RX.

Click on PTT Toggle.

This should send the audio through Asterisk and in to the transmitter to be demodulated by the test set.

Filter on the PL in the test set. There shouldn’t be any PL modulation… or very little (like 0.015kHz). If it is more… did you edit the right context in voter.conf?!

Anyways leave that… Back to the level adjustment…

If we set the filters to 300Hz HPF and 15kHz LPF, we can knock out any PL modulation.

Adjust the TX Gain (R61) in the RTCM to get 1.5kHz deviation.

Click Write.

Exit the tuner.

This should get us where we need to be… now some fine tuning.

Let’s go check the offline repeat first.

Disable the GPS by setting it to NMEA instead of TSIP. This will drop the host connection and put us in to offline repeat.

Send an on-channel carrier with 1kHz @ 3kHz in to the receiver and demod the repeater output.

Offline repeat is set for CTCSS with a value around 1500 and De-emphasis Override is 1. If you change the De-emphasis Override, you MUST save the values and reboot for it to take effect!!

We want De-emphasis Override = 1 so that the de-emphasis filter is bypassed and we get flat audio through the RTCM in offline mode. If it is set incorrectly, when you sweep the modulating frequency, the deviation will change.

Set the filters in the test set for 300Hz HPF and 15kHz LPF to strip any PL.

The TX should be modulating around 2.7kHz.

Bump R61 up to give us 3kHz deviation.

Set the filters to measure PL deviation.

Adjust the CTCSS level in the RTCM to get about 0.6kHz.

Now, if we widen the filters to include PL and the 1kHz (<20 & 15), we should get about 3.5kHz composite deviation.

If we sweep the modulating frequency, the deviation changes… this SHOULDN’T happen… but it does. Setting the Offline De-emphasis Override doesn’t seem to make a difference. Since offline repeat should not happen very often, we’ll just leave it. ***There is a bug… if you change De-emphasis override, you MUST save and reboot for it to take effect. We want De-emphasis Override = 1 to bypass the De-emphasis Filter and have flat audio through the RTCM in offline mode. It DOES work properly when De-emphasis Override = 1… the deviation is constant (within TX specs) when the frequency is swept.

Re-enable the GPS to lock back up to the host and send our audio through Asterisk.

Send on-channel with 1kHz @ 3kHz in to the RX.

Filter and measure the PL… change the level in rpt.conf and run astres.sh to restart Asterisk to adjust the PL level for about 0.6kHz. Should be about 47.

Set the test set filters for >300Hz & <15kHz. Check the 1kHz level is pretty darn close to 3kHz (3.1kHz).

Widen the test set filters and check the composite modulation is around 3.6kHz.

Sweep the audio frequency and see that the deviation remains about the same (around 3.6kHz).

It should start to drop when you hit 300Hz. And it will start to roll off gradually when you get above 1.6… but it will dive when you hit about 3kHz, and drop right off at 3.4kHz… that seems to be characteristics of the transmitter.

Finally, set the squelch using R22 on the RTCM by feeding an on-channel signal in to the RX and lowering the level until the squelch closes. Adjust as necessary. A squelch level on the console of about 560 is probably a good place to start. Might need to adjust it tighter in the field.

Don’t crank the squelch too high, weird shit happens! Had it set to 920 and the RTCM would squelch when the frequency was swept up to 2600Hz.

OK! We’re pretty much at the end.

If we are going to use CSQ on RX, we’re done.

If we want to use PL on RX. Program the repeater for TPL on RX, set GPIO 5 for PL Detect, and set the RTCM for External CTCSS Non-inverted.

In fact, you can program the repeater for TPL anyways, and the only side effect is that the RxA and RxB LED’s on the front won’t light on a received signal (since PL isn’t satisfied).

Then, the decision to enable PL decode is entirely done by changing the option in the RTCM.

If CTCSS is enabled in the RTCM and no valid PL is on the received carrier, the RX light on the RTCM will flash at the same rate as the ACT light.

So, give that a go, and see if it clears things up. The key here is aligning the radio in the Tuner, as a 12.5kHz radio, and then let it do its thing when it bonds the channels back in to 25kHz.

Good luck!

Lee

Wow!! OK, the Keurig is on “large” and brewing :), the test equipment is on and stabilizing, and I’ve printed out this email.

Thanks Tim for the pointers, and thanks Lee for the in-depth procedure. I am going to stick the non-BEW Chuck-enabled code back in the RTCM now and start at the top! Really appreciate you taking the time to share.

I’ll report back soon.

James

···

On Thu, May 14, 2020 at 3:37 PM Lee via AllStarLink Discussion Groups noreply@community.allstarlink.org wrote:


ve7fet

    May 14

Hi James,

This is going to be long, so grab a coffee. :slightly_smiling_face:

As you know, these radios were really made for 12.5kHz channel operation, it is a bit of a kludge that they do to make them do 25kHz, basically by bonding two 12.5kHz channels together inside the radio… at least, that is what it looks like they are doing.

Here are my notes on alignment… note, I have an HP8920/8921 series test set, so some of the cues in here are for it’s audio filters…

This procedure is for if you are using Asterisk/RTCM to generate PL. (I have a slightly different procedure if you are generating PL in the SLR TX instead).

The SLR5700 is very sensitive to levels… things go sideways when you over-drive the modulator.

There is a note in the Service Manual:

“If the manufacturer of the third party controller specifies that the Tx Audio is not to be pre-emphasized, use Pin 1 instead of Pin 22.” Fact, or fiction?

Anyways…

Here are the pre-requisite conditions:

-using an RTCM/VOTER

-loaded with v1.5/Chuck Squelch/DSP BEW firmware (BEW disabled)

-Intent to support RX PL

-Configured for TX PL

-Configured to fallback to offline repeat

In voter.conf, make sure we have: MAKE SURE YOU EDIT THE RIGHT VOTER CONTEXT IF MORE THAN ONE EXISTS

txctcss = 136.5
;txctcsslevel = 50 ;this is a calibrated value, DO NOT CHANGE

txctcsslevel = 0

txtoctype = phase

Yes, we want to initially set txctcsslevel to 0… we’ll set the level later. We need these settings so that the channel drive configures itself properly for flat audio.

CPS Settings:

Accessories --> Audio Type --> Flat Unsquelch

-This disables the audio gate to let audio out of the RX pin at all times.

-The “discriminator audio” is clipped and looks (and sounds) more like data than true analog audio.

-Haven’t run that in to an audio spectrum analyzer, but I suspect it is missing a lot of high frequency

spectrum audio, hence maybe requiring the use of BEW.

GPIO

Pin #2 - External PTT, Active Low, Debounce

Pin #4 - CSQ, Active Low (not used)

Pin #5 - PL/Talkgroup Detect, Active High

Channel 1 - Analog

Channel Bandwidth - 25kHz

Squelch - Normal (no effect, since we’re not using CSQ detect)

MPT1237 - Un-checked (this changes something about the RX audio… so we’ll just leave it alone)

Set the RX Squelch Type to CSQ for tuning. Set to PL, if desired, when done.

Leave TX Squelch Type at CSQ, we’ll generate the PL externally (in the RTCM/VOTER/Asterisk).

RX Audio is from Pin 1 of the DB25.

TX Audio is to Pin 13 (TX Data). This “should” go direct to the modulator… at least it normally would…

Get the RTCM up and running and connected to the host.

JP1 should be IN to disable the 20dB pad.

JP2 should be OUT.

With no signal applied, do the Diode Calibration routine. Insert JP10, then insert JP9.

This will do the Diode Calibration and the Squelch Calibration at the same time.

Wait for the RX LED to stop flashing and go solid.

The console should show the Diode Calibration being written to EEPROM (about 57).

Remove JP10 then remove JP9.

Squelch Calibration should be written to EEPROM (about 45).

Launch the Motorola Tuner. This is where things start getting hinky. The repeater is designed for 12.5kHz, they do some funny business to make it work at 25kHz. Alignment needs to be done at 1.5kHz deviation (60% rated system deviation for 12.5kHz) to get the levels to work right.

Click Read.

Click on Rated Volume.

Feed 460.050 (155.075) with 1kHz @ 1.5kHz in to the RX.

If you scope JP1 in the RTCM, you should see 560mVpp/345mVrms.

In the RTCM console, select 97 to look at the RX bar graph.

Adjust the RX Gain (R35) in the RTCM to get 3kHz lined up… trust me.

Click Write (we’re not going to change the softpot in the repeater, but you have to “write” to exit).

Click on Audio Level.

Set the test set to RX 460.025 (155.025). Note the repeater RX is still configured for 460.050 (155.075)

Send 460.050 (155.075) with 1kHz @ 1.5kHz in to the RX.

Click on PTT Toggle.

This should send the audio through Asterisk and in to the transmitter to be demodulated by the test set.

Filter on the PL in the test set. There shouldn’t be any PL modulation… or very little (like 0.015kHz). If it is more… did you edit the right context in voter.conf?!

Anyways leave that… Back to the level adjustment…

If we set the filters to 300Hz HPF and 15kHz LPF, we can knock out any PL modulation.

Adjust the TX Gain (R61) in the RTCM to get 1.5kHz deviation.

Click Write.

Exit the tuner.

This should get us where we need to be… now some fine tuning.

Let’s go check the offline repeat first.

Disable the GPS by setting it to NMEA instead of TSIP. This will drop the host connection and put us in to offline repeat.

Send an on-channel carrier with 1kHz @ 3kHz in to the receiver and demod the repeater output.

Offline repeat is set for CTCSS with a value around 1500 and De-emphasis Override is 1. If you change the De-emphasis Override, you MUST save the values and reboot for it to take effect!!

We want De-emphasis Override = 1 so that the de-emphasis filter is bypassed and we get flat audio through the RTCM in offline mode. If it is set incorrectly, when you sweep the modulating frequency, the deviation will change.

Set the filters in the test set for 300Hz HPF and 15kHz LPF to strip any PL.

The TX should be modulating around 2.7kHz.

Bump R61 up to give us 3kHz deviation.

Set the filters to measure PL deviation.

Adjust the CTCSS level in the RTCM to get about 0.6kHz.

Now, if we widen the filters to include PL and the 1kHz (<20 & 15), we should get about 3.5kHz composite deviation.

If we sweep the modulating frequency, the deviation changes… this SHOULDN’T happen… but it does. Setting the Offline De-emphasis Override doesn’t seem to make a difference. Since offline repeat should not happen very often, we’ll just leave it. ***There is a bug… if you change De-emphasis override, you MUST save and reboot for it to take effect. We want De-emphasis Override = 1 to bypass the De-emphasis Filter and have flat audio through the RTCM in offline mode. It DOES work properly when De-emphasis Override = 1… the deviation is constant (within TX specs) when the frequency is swept.

Re-enable the GPS to lock back up to the host and send our audio through Asterisk.

Send on-channel with 1kHz @ 3kHz in to the RX.

Filter and measure the PL… change the level in rpt.conf and run astres.sh to restart Asterisk to adjust the PL level for about 0.6kHz. Should be about 47.

Set the test set filters for >300Hz & <15kHz. Check the 1kHz level is pretty darn close to 3kHz (3.1kHz).

Widen the test set filters and check the composite modulation is around 3.6kHz.

Sweep the audio frequency and see that the deviation remains about the same (around 3.6kHz).

It should start to drop when you hit 300Hz. And it will start to roll off gradually when you get above 1.6… but it will dive when you hit about 3kHz, and drop right off at 3.4kHz… that seems to be characteristics of the transmitter.

Finally, set the squelch using R22 on the RTCM by feeding an on-channel signal in to the RX and lowering the level until the squelch closes. Adjust as necessary. A squelch level on the console of about 560 is probably a good place to start. Might need to adjust it tighter in the field.

Don’t crank the squelch too high, weird shit happens! Had it set to 920 and the RTCM would squelch when the frequency was swept up to 2600Hz.

OK! We’re pretty much at the end.

If we are going to use CSQ on RX, we’re done.

If we want to use PL on RX. Program the repeater for TPL on RX, set GPIO 5 for PL Detect, and set the RTCM for External CTCSS Non-inverted.

In fact, you can program the repeater for TPL anyways, and the only side effect is that the RxA and RxB LED’s on the front won’t light on a received signal (since PL isn’t satisfied).

Then, the decision to enable PL decode is entirely done by changing the option in the RTCM.

If CTCSS is enabled in the RTCM and no valid PL is on the received carrier, the RX light on the RTCM will flash at the same rate as the ACT light.

So, give that a go, and see if it clears things up. The key here is aligning the radio in the Tuner, as a 12.5kHz radio, and then let it do its thing when it bonds the channels back in to 25kHz.

Good luck!

Lee


Visit Topic or reply to this email to respond.


In Reply To


james.m.cizek

    May 14

Well, I just dropped the DSP/BEW code in, re-did my noise/diode calibrations, checked all levels and tried with BEW =0 and BEW=1 There is absolutely no noticeable difference from the non BEW code, with either BEW setting. To be honest, I am not even sure I am chasing the right thing down here anym…


Visit Topic or reply to this email to respond.

To unsubscribe from these emails, click here.

OK, need a tiny bit of clarification.

You state:

GPIO:

Pin #2 External PTT

Pin #4 CSQ

Pin #5 PL detect.

Just for clarity, do you actually mean pins 2,4 and 5 or is it GPIO 2,4,5 (which would be pins 4,23,24) I don’t know if that’s important as both sets of pins are capable of all signals.

But, you state RX Audio is from Pin 1 of the DB25 the manual for the SLR says Pin 1 is “Tx audio 1” Did you actually maybe mean Pin2 which is "Rx audio 2 Receiver audio nominal output 330mVrms with 60% deviation)? Or maybe Pin 7 which is “RX audio 1”?

I am definitely not currently using Pin 13 for TX audio, I am currently injecting on Pin 22 “TX audio 1”, so I’ll change my wiring to go to “Tx data”.

Thanks for the clarification!

James

···

On Thu, May 14, 2020 at 4:00 PM James Cizek james.m.cizek@gmail.com wrote:

Wow!! OK, the Keurig is on “large” and brewing :), the test equipment is on and stabilizing, and I’ve printed out this email.

Thanks Tim for the pointers, and thanks Lee for the in-depth procedure. I am going to stick the non-BEW Chuck-enabled code back in the RTCM now and start at the top! Really appreciate you taking the time to share.

I’ll report back soon.

James

On Thu, May 14, 2020 at 3:37 PM Lee via AllStarLink Discussion Groups noreply@community.allstarlink.org wrote:


ve7fet

    May 14

Hi James,

This is going to be long, so grab a coffee. :slightly_smiling_face:

As you know, these radios were really made for 12.5kHz channel operation, it is a bit of a kludge that they do to make them do 25kHz, basically by bonding two 12.5kHz channels together inside the radio… at least, that is what it looks like they are doing.

Here are my notes on alignment… note, I have an HP8920/8921 series test set, so some of the cues in here are for it’s audio filters…

This procedure is for if you are using Asterisk/RTCM to generate PL. (I have a slightly different procedure if you are generating PL in the SLR TX instead).

The SLR5700 is very sensitive to levels… things go sideways when you over-drive the modulator.

There is a note in the Service Manual:

“If the manufacturer of the third party controller specifies that the Tx Audio is not to be pre-emphasized, use Pin 1 instead of Pin 22.” Fact, or fiction?

Anyways…

Here are the pre-requisite conditions:

-using an RTCM/VOTER

-loaded with v1.5/Chuck Squelch/DSP BEW firmware (BEW disabled)

-Intent to support RX PL

-Configured for TX PL

-Configured to fallback to offline repeat

In voter.conf, make sure we have: MAKE SURE YOU EDIT THE RIGHT VOTER CONTEXT IF MORE THAN ONE EXISTS

txctcss = 136.5
;txctcsslevel = 50 ;this is a calibrated value, DO NOT CHANGE

txctcsslevel = 0

txtoctype = phase

Yes, we want to initially set txctcsslevel to 0… we’ll set the level later. We need these settings so that the channel drive configures itself properly for flat audio.

CPS Settings:

Accessories --> Audio Type --> Flat Unsquelch

-This disables the audio gate to let audio out of the RX pin at all times.

-The “discriminator audio” is clipped and looks (and sounds) more like data than true analog audio.

-Haven’t run that in to an audio spectrum analyzer, but I suspect it is missing a lot of high frequency

spectrum audio, hence maybe requiring the use of BEW.

GPIO

Pin #2 - External PTT, Active Low, Debounce

Pin #4 - CSQ, Active Low (not used)

Pin #5 - PL/Talkgroup Detect, Active High

Channel 1 - Analog

Channel Bandwidth - 25kHz

Squelch - Normal (no effect, since we’re not using CSQ detect)

MPT1237 - Un-checked (this changes something about the RX audio… so we’ll just leave it alone)

Set the RX Squelch Type to CSQ for tuning. Set to PL, if desired, when done.

Leave TX Squelch Type at CSQ, we’ll generate the PL externally (in the RTCM/VOTER/Asterisk).

RX Audio is from Pin 1 of the DB25.

TX Audio is to Pin 13 (TX Data). This “should” go direct to the modulator… at least it normally would…

Get the RTCM up and running and connected to the host.

JP1 should be IN to disable the 20dB pad.

JP2 should be OUT.

With no signal applied, do the Diode Calibration routine. Insert JP10, then insert JP9.

This will do the Diode Calibration and the Squelch Calibration at the same time.

Wait for the RX LED to stop flashing and go solid.

The console should show the Diode Calibration being written to EEPROM (about 57).

Remove JP10 then remove JP9.

Squelch Calibration should be written to EEPROM (about 45).

Launch the Motorola Tuner. This is where things start getting hinky. The repeater is designed for 12.5kHz, they do some funny business to make it work at 25kHz. Alignment needs to be done at 1.5kHz deviation (60% rated system deviation for 12.5kHz) to get the levels to work right.

Click Read.

Click on Rated Volume.

Feed 460.050 (155.075) with 1kHz @ 1.5kHz in to the RX.

If you scope JP1 in the RTCM, you should see 560mVpp/345mVrms.

In the RTCM console, select 97 to look at the RX bar graph.

Adjust the RX Gain (R35) in the RTCM to get 3kHz lined up… trust me.

Click Write (we’re not going to change the softpot in the repeater, but you have to “write” to exit).

Click on Audio Level.

Set the test set to RX 460.025 (155.025). Note the repeater RX is still configured for 460.050 (155.075)

Send 460.050 (155.075) with 1kHz @ 1.5kHz in to the RX.

Click on PTT Toggle.

This should send the audio through Asterisk and in to the transmitter to be demodulated by the test set.

Filter on the PL in the test set. There shouldn’t be any PL modulation… or very little (like 0.015kHz). If it is more… did you edit the right context in voter.conf?!

Anyways leave that… Back to the level adjustment…

If we set the filters to 300Hz HPF and 15kHz LPF, we can knock out any PL modulation.

Adjust the TX Gain (R61) in the RTCM to get 1.5kHz deviation.

Click Write.

Exit the tuner.

This should get us where we need to be… now some fine tuning.

Let’s go check the offline repeat first.

Disable the GPS by setting it to NMEA instead of TSIP. This will drop the host connection and put us in to offline repeat.

Send an on-channel carrier with 1kHz @ 3kHz in to the receiver and demod the repeater output.

Offline repeat is set for CTCSS with a value around 1500 and De-emphasis Override is 1. If you change the De-emphasis Override, you MUST save the values and reboot for it to take effect!!

We want De-emphasis Override = 1 so that the de-emphasis filter is bypassed and we get flat audio through the RTCM in offline mode. If it is set incorrectly, when you sweep the modulating frequency, the deviation will change.

Set the filters in the test set for 300Hz HPF and 15kHz LPF to strip any PL.

The TX should be modulating around 2.7kHz.

Bump R61 up to give us 3kHz deviation.

Set the filters to measure PL deviation.

Adjust the CTCSS level in the RTCM to get about 0.6kHz.

Now, if we widen the filters to include PL and the 1kHz (<20 & 15), we should get about 3.5kHz composite deviation.

If we sweep the modulating frequency, the deviation changes… this SHOULDN’T happen… but it does. Setting the Offline De-emphasis Override doesn’t seem to make a difference. Since offline repeat should not happen very often, we’ll just leave it. ***There is a bug… if you change De-emphasis override, you MUST save and reboot for it to take effect. We want De-emphasis Override = 1 to bypass the De-emphasis Filter and have flat audio through the RTCM in offline mode. It DOES work properly when De-emphasis Override = 1… the deviation is constant (within TX specs) when the frequency is swept.

Re-enable the GPS to lock back up to the host and send our audio through Asterisk.

Send on-channel with 1kHz @ 3kHz in to the RX.

Filter and measure the PL… change the level in rpt.conf and run astres.sh to restart Asterisk to adjust the PL level for about 0.6kHz. Should be about 47.

Set the test set filters for >300Hz & <15kHz. Check the 1kHz level is pretty darn close to 3kHz (3.1kHz).

Widen the test set filters and check the composite modulation is around 3.6kHz.

Sweep the audio frequency and see that the deviation remains about the same (around 3.6kHz).

It should start to drop when you hit 300Hz. And it will start to roll off gradually when you get above 1.6… but it will dive when you hit about 3kHz, and drop right off at 3.4kHz… that seems to be characteristics of the transmitter.

Finally, set the squelch using R22 on the RTCM by feeding an on-channel signal in to the RX and lowering the level until the squelch closes. Adjust as necessary. A squelch level on the console of about 560 is probably a good place to start. Might need to adjust it tighter in the field.

Don’t crank the squelch too high, weird shit happens! Had it set to 920 and the RTCM would squelch when the frequency was swept up to 2600Hz.

OK! We’re pretty much at the end.

If we are going to use CSQ on RX, we’re done.

If we want to use PL on RX. Program the repeater for TPL on RX, set GPIO 5 for PL Detect, and set the RTCM for External CTCSS Non-inverted.

In fact, you can program the repeater for TPL anyways, and the only side effect is that the RxA and RxB LED’s on the front won’t light on a received signal (since PL isn’t satisfied).

Then, the decision to enable PL decode is entirely done by changing the option in the RTCM.

If CTCSS is enabled in the RTCM and no valid PL is on the received carrier, the RX light on the RTCM will flash at the same rate as the ACT light.

So, give that a go, and see if it clears things up. The key here is aligning the radio in the Tuner, as a 12.5kHz radio, and then let it do its thing when it bonds the channels back in to 25kHz.

Good luck!

Lee


Visit Topic or reply to this email to respond.


In Reply To


james.m.cizek

    May 14

Well, I just dropped the DSP/BEW code in, re-did my noise/diode calibrations, checked all levels and tried with BEW =0 and BEW=1 There is absolutely no noticeable difference from the non BEW code, with either BEW setting. To be honest, I am not even sure I am chasing the right thing down here anym…


Visit Topic or reply to this email to respond.

To unsubscribe from these emails, click here.

Pins 2, 4, 5 would be the physical pins on the DB-25, as they are referenced to in the CPS (GPIO Physical Pins).

Using DB-25 Pin 7 for receiver audio, and Pin 13 for transmit audio.

Pin 13 “should” go straight to the modulator (in theory), allowing you to send PL, without it getting filtered/processed out.

Just pulled my cable apart, and confirmed those are the pins in use.

Lee

OK, I was doing great for quite a few steps… and then I hit a snag.

When I load TRBOtuner, as soon as the “read” is complete, pin 7 goes silent. No more audio, nothing. If I hit “Rated audio”, the discriminator audio returns for about a 1/4 of a second while the menu loads, then flat lines again. Doesn’t matter if I put a signal in or not, absolutely nothing comes out Pin 7. If I “write” or “exit”, the repeater resets and audio comes out again. I put an oscope on that pin to witness this, and sure enough, nice unsquelched audio coming out all the time, until the read completes and it completely disappears.

I originally had Tuner 16.0 loaded on my laptop, thought that might be the issue, so I downloaded 18.0 from my Motorola account. That did not solve it either. This is a VHF repeater so I am injecting 155.075 @ 1.5khz deviation of 1khz. The Tuner screen after a read confirms that that is the RX frequency it’s using. The injected signal does not come out either.

Am I doing something wrong here? This is the first time I’ve used tuner with a “new” repeater. I’ve got lots of experience using the old RSS tuners :slight_smile:

Thanks Lee.

James

···

On Thu, May 14, 2020 at 5:37 PM Lee via AllStarLink Discussion Groups noreply@community.allstarlink.org wrote:


ve7fet

    May 14

Pins 2, 4, 5 would be the physical pins on the DB-25, as they are referenced to in the CPS (GPIO Physical Pins).

Using DB-25 Pin 7 for receiver audio, and Pin 13 for transmit audio.

Pin 13 “should” go straight to the modulator (in theory), allowing you to send PL, without it getting filtered/processed out.

Just pulled my cable apart, and confirmed those are the pins in use.

Lee


Visit Topic or reply to this email to respond.


In Reply To


james.m.cizek

    May 14

OK, need a tiny bit of clarification. You state: GPIO: Pin #2 External PTT Pin #4 CSQ Pin #5 PL detect. Just for clarity, do you actually mean pins 2,4 and 5 or is it GPIO 2,4,5 (which would be pins 4,23,24) I don’t know if that’s important as both sets of pins are capable of all signals. Bu…


Visit Topic or reply to this email to respond.

To unsubscribe from these emails, click here.

Well, that does seem odd.

Looks like I’ve got Tuner 16.1 installed, for reference.

Audio should come out on Pin 7, when doing the Rated Audio test. It says so on Page 10-4 of the service manual.

I will fire up the test equipment tomorrow, and double check my notes.

Lee

So, I just went in to the Rated Volume for the RX in Tuner, and it was spitting out audio the whole time.

Maybe it has to do with the codeplug configuration you are using? Maybe it needs to be set to use discriminator audio output first?

Lee

OK, I had a divergence there while I worked out the audio stuff with Motorola. I am back on track.

I’ve followed your procedure all the way through Lee, and the squelch problem is much worse than it was before. I did have 1 very different result than you list though. I was successful entirely getting through your steps of setting calibration, squelch, and RX audio levels. I was then able to set things for Offline mode just as you suggest. The difference came when I hooked back up to DIAL. I still have voter.conf set for 0 CTCSS output at this point. Your document says this:

Re-enable the GPS to lock back up to the host and send our audio through Asterisk.

Send on-channel with 1kHz @ 3kHz in to the RX.

Filter and measure the PL… change the level in rpt.conf and run astres.sh to restart Asterisk to adjust the PL level for about 0.6kHz. Should be about 47.

Set the test set filters for >300Hz & <15kHz. Check the 1kHz level is pretty darn close to 3kHz (3.1kHz).

Widen the test set filters and check the composite modulation is around 3.6kHz.

Sweep the audio frequency and see that the deviation remains about the same (around 3.6kHz).

When I send the onchannel signal, I am already over 4khz deviation with no PL. If I lower it back to 3, then adjust the PL setting in DIAL to bring it to 3.6, I end up with a CTCSS setting of 175 in DIAL instead of the 47 you mention.

Of course when I do this, the offline level becomes far too low.

Am I missing something here?

Just so we have a complete picture, here are the relevant sections of the voter.conf and the RTCM menus (passwords removed/obscured)

RTCM main menu:

Select the following values to View/Modify:

1 - Serial # (1234) (which is MAC ADDR 00:04:A3:00:04:D2)
2 - VOTER Server Address (FQDN) (192.168.94.234)
3 - VOTER Server Port (667), 4 - Local Port (Override) (0)
5 - Client Password (CLIENT), 6 - Host Password (HOST)
7 - Tx Buffer Length (750)
8 - GPS Data Protocol (0=NMEA, 1=TSIP) (0)
9 - GPS Serial Polarity (0=Non-Inverted, 1=Inverted) (0)
10 - GPS PPS Polarity (0=Non-Inverted, 1=Inverted, 2=NONE) (0)
11 - GPS Baud Rate (4800)
12 - External CTCSS (0=Ignore, 1=Non-Inverted, 2=Inverted) (0)
13 - COR Type (0=Normal, 1=IGNORE COR, 2=No Receiver) (0)
14 - Debug Level (0)
15 - Alt. VOTER Server Address (FQDN) ()
16 - Alt. VOTER Server Port (Override) (0)
17 - DSP/BEW Mode (0)
18 - “Duplex Mode 3” (0=DISABLED, 1-255 Hang Time) (1/10 secs) (0)
19 - Simulcast Launch Delay (0) (approx 200 ns, 5 = 1us, > 0 to ENA SC)
97 - RX Level, 98 - Status, 99 - Save Values to EEPROM
i - IP Parameters menu, o - Offline Mode Parameters menu
q - Disconnect Remote Console Session, r - reboot system, d - diagnostics

Enter Selection (1-27,97-99,r,q,d) :

and offline menu:

OffLine Mode Parameters Menu

Select the following values to View/Modify:

1 - Offline Mode (0=NONE, 1=Simplex, 2=Simplex w/Trigger, 3=Repeater) (3)
2 - CW Speed (400) (1/8000 secs)
3 - Pre-CW Delay (4000) (1/8000 secs)
4 - Post-CW Delay (4000) (1/8000 secs)
5 - CW “Offline” (ID) String (OFL)
6 - CW “Online” String (OK)
7 - “Offline” (CW ID) Period Time (0) (1/10 secs)
8 - Offline Repeat Hang Time (15) (1/10 secs)
9 - Offline CTCSS Tone (100.0) Hz
10 - Offline CTCSS Level (0-32767) (1505)
11 - Offline De-Emphasis Override (0=NORMAL, 1=OVERRIDE) (1)
99 - Save Values to EEPROM
x - Exit OffLine Mode Parameter Menu (back to main menu)
q - Disconnect Remote Console Session, r - reboot system

Enter Selection (1-9,99,c,x,q,r) :

and voter.conf:

[general]
port = 667
buflen = 250
password = HOST

[1115]
Horsetooth115 = CLIENT,transmit
plfilter = y
txctcss = 100.0
txctcsslevel = 175 ; Transmit CTCSS level. Set to zero for off
txtoctype = phase ; reverse burst
;thresholds = 255,110=5
linger=0

Wondering if my results trigger any thoughts on what to check next?

The interesting thing is, the squelch burst noise (before moving to this new procedure) was often quite radio dependent. One thing I noticed is if I used a Motorola HT (XPR6550 or 7550), the squelch blast didn’t happen about 90% of the time, and when it did, was very short. If I used ham transceivers, and especially anything made by Yaesu, it was terrible everytime. Now that I’ve moved to the DSP/BEW firmware, it’s bad on all radios including the Motorolas. I don’t know if that is a clue to what’s going on here or not, but thought I’d include it since I’ve observed it.

I feel like I am just missing something small here, I have a hard time believing this repeater can’t be made to work with an RTCM properly. Maybe it’s just a pipe dream…

Thanks for your continued help.

James

KI0KN

···

On Fri, May 15, 2020 at 7:31 PM Lee via AllStarLink Discussion Groups <noreply@community.allstarlink.org> wrote:

| ve7fet
May 16 |

  • | - |

So, I just went in to the Rated Volume for the RX in Tuner, and it was spitting out audio the whole time.

Maybe it has to do with the codeplug configuration you are using? Maybe it needs to be set to use discriminator audio output first?

Lee


Visit Topic or reply to this email to respond.


In Reply To

| ve7fet
May 15 |

  • | - |

Well, that does seem odd. Looks like I’ve got Tuner 16.1 installed, for reference. Audio should come out on Pin 7, when doing the Rated Audio test. It says so on Page 10-4 of the service manual. I will fire up the test equipment tomorrow, and double check my notes. Lee


Visit Topic or reply to this email to respond.

To unsubscribe from these emails, click here.

Hi James,

What are you using for a service monitor?

Can you send me your codeplug to look at?

Lee