Rpt_extnodes not showing

Making a short story:
Trying to install ASL distribution on a mini PC with ISO did not work due to some possible drivers problems
Succeeded installing Debian 10, adding rtl drivers in the root DOS partition
Installed AllStarLink Beta manually
Everything works great except one important thing:
/var/lib/asterisl/rpt_extnodes does not exists.
However my node 469612 seems to be properly registered
Looks like the updatnodelist faciltiy just dont run even if the asl-menu diagnostic says it is running
I was able to enter my main nodes in RPT.conf, but this is not the way we expect allstarlink to work!

give this a try to see if it starts back up…

systemctl restart updatenodelist

I’m assuming you know the node list is in /var/lib/asterisk to check the timestamp of the file.

Let us know if it kickstarts.

I tried that, but after reading more on the web I discovered the files required to start the service:
/usr/local/bin/rc.updatenodelist
/usr/lib/systemd/system/updatenodelist.service
Both files where missing on my installation, dont know why…
I just copied them from another allstar pc I have in our network.
After I did:
sudo chmod +x rc.updatenodelist
sudo systemctl start updatenodelist
sudo systemctl enable updatenodelist
Works now like a charm!

Conclusion:
There something missing or wrong in the procedure for manual installation, the apt get sequence is not clear. Is there something more to install than asl-dadhi, asl-asterisk and asl-helpers?
The asl-menu diagnostic checking update-node-list declares it is running even if the process is not present (checked with ps -e)

Likely something unexpected happened during install that went un-noticed.
Look at the install log to find out what it was.

I think the kernel has been updated a few times since initial release.
There is a link in the wiki for bug reports for this beta once you can be sure it is a bug.

I had the same problem. The directions were never updated to have you install the “asl-update-node-list” package which provides that service and associated files.

I might note that beta means BETA, one should not expect 100%, it is a release for testing.
Beta is not for anyone not willing to risk errors.
If not reported in a BUG report (see wiki), don’t expect a fix.