Radioless node (Not Hub )Transmit audio issue

I am building a radioless node using a Masters communications RL-20 interface. They are quick to take money but won’t email back on support. Anyway, I have it all connected up and it will receive just fine, I key the mic and have no audio out. I can see that I am keying my other node at the repeater site. Ptt is going to COS pin 3 and mic is going to pin 6, PTT is active high and usbinvert. I have also tried active low even though that should not change audio out. Any help would be greatly appreciated. Oh, I have wired three mics with the same results. So I am pretty sure this is not a mic problem. One Alinco ems-54 with DTMF 5 volts and two Alinco DTMF with 5 volts.

While I’m not familiar with the hardware you are using, problems like this are normally simple but take some time for you to realize that the PTT is not following the same logic as the audio gating.

You may need a transistor to invert the logic.
Radiowise, most PTT’s switch to ground ‘active’ which is not the same as just a low signal of 0V.

Take your time and follow that logic through based on what I just said.

Thanks Mike. Yea I have built a couple of nodes in the past using Maxtrac, 888’s, and uv5r. This project is radioless, there is not radio involved. It is just a Pi, interface,and microphone. PTT from the mic goes to the COS pin and Mic goes to discriminator, I think. I am sure this is going to be something simple.

As a test, why not force the ptt (cos) and try some other mic.
Think you need to use process of elimination.
Next, I would try a local/remote connection from iaxrpt and look for audio out.
Setup/Download IAXRpt - AllStarLink Wiki

btw… if you have not located it, please show us your usbradio.conf

A Few questions and suggestions…
Is the RL-20 a kit you built? If so did you recheck soldering for R9 Pot
Have you tried adjusting R9 or read the pot to make sure it isn’t faulty?
Also do you have boost turned on in the node’s sound driver settings.
If a new node which driver are you using? Is the node Public or Private?
Have you made sure that your repeater node opens the proper port for your incoming Radioless node’s audio?

Just things to look at.

Larry - N7FM

I found that the problem was the Microphone. When I switched from the three Kenwood mics to a Yaesu MH-27, I had audio. You just have to make sure you have a good quality mic.

Moral of the story… never assume. LOL Thanks for the follow up.

It seems to me, while my memory for such things is poor when I have not delt with them for 20 years, That there is something different about the Kenwood mics as far as how the mic element is switched through the PTT switch. But , I’m probably off my rocker LOL.
But worth investigating if you still want to use them. Let us know if you should try and find something.