Question about Allmon2 install on Raspberry 3

In the Allmon2 Install from the AllStarLink Wiki, I get to the line “repeater@repeater:~$ htpasswd -cB .htpasswd admin” I get the following:
" -bash htpasswd: command not found "
What do I need to do to make this work?
Thanks,
Dave N

Try it as root. Do sudo su - and run the htpasswd command again.

Thanks for the reply.
I tried it and got the following:
-su htpasswd command not found

I have had same problem with Allmon2. What I do is type the command in with user name and I repeat do not copy & paste. It works for me maybe for you also 73 Don N0EBB

Hello Don. I did a google search for ‘htpasswd’ and found some info saying it should be located in /var/www/ but I did not find anything installed there. These were both Raspian installs using image ASL_1.01-20180228-armhf=raspian-stretch-img , and were both updated and upgraded. So I guess the file is either in a different directory, or else perhaps Allmon2 isn’t something one would want to run on a Raspberry Pi installation.
Dave n

There are two htpasswd files, the executable htpasswd and the hidden config file .htpasswd (note the leading dot). You use hatpasswd to create .htpasswd per the Allmon2 README.

I thought htpasswd was installed as part of the Apache2 install but maybe not. Try install it with sudo apt-get install apache2-utils.

Thanks! I ran sudo htpasswd -cB .htpasswd admin , and ’ new password:’ appeared. I entered, then re-entered a new password, then ran
sudo chmod 777 astdb.php That seemed to work, so I then tried http:192.168.1.109/allmon2 Got the response ‘This site can’t be reached’ ‘192.168.1.109 refused to connect’ Maybe I can’t do this while connected with ssh.
I’ll try some more.
Dave N
n0km

That error is not related to htpasswd. Without ,htpasswd your Allmon site will work, you just won’t be able to make connections, etc without a login.

Sounds like Apache is not running or firewall is blocking. Which distro are you running, HamVoIP?

No, I was told by another ASL admin to avoid HamVoIP. This is a recent install from this site.

ASL Version: x
x Asterisk GIT Version adaec47 built by root @ odroidxu4 on a armv7l x
x running Linux on 2018-03-07 14:53:41 UTC x
x

I have no idea what that version is about. Maybe someone can jump in here and help with that one?

Maybe try to grab another SD card and try this image.
http://dvswitch.org/files/ASL_Images/Raspberry_Pi/Stretch/