Private node links

Hi, I’m fairly new to allstar and am trying to setup a system which is not connected to allstarlink. I’ve installed the allstar image on two virtual machines and am trying to test the connection between them with the rpt fun command but not seeing a change when using the rpt stats command on the other machine.

I can’t help thinking i’m doing something wrong, is there any guides on how to do this anywhere?

I’ve added details of the nodes into the iax.conf files and added the node details in the rpt.conf files under the [nodes] section. Is there anything else i should be doing? I can send more information if required

I really appreciate any help that anyone can give me.

What exact commands are you issuing and what are you expecting to see?
I can’t tell if you may be doing it wrong or expecting the impossible.

Likely a separate issue than having the private nodes set-up correct.

Perhaps this will help.

I’m sending command from ASL CLI :
rpt fun allstar/0001@repeater-server connect

and monitoring on the node 0001 called repeater-server using
rpt stats 0001

I get no connected nodes shown from rpt stats 0001

Well, it looks like your command format is off a bit.

rpt fun (node#) (command)

rpt fun 1000 *31001

Sends dtmf command *31001 to 1000 which should connect 1000 to 1001

*3 connect in transcieve mode to node 1001

Unless Allison’s voice is disabled, she will announce the connection.


try from cli
help rpt
help rpt fun
help rpt (xxx)

Hope that gets you somewhere.

I might add I think you are trying to do asterisk commands (guessing you are prone to it) and I think while in the radio channel, you will have to stay with the internal ‘radio channel’ command format.
The app_rpt program is a walled garden so to speak. Many asterisk functions do work here but I doubt when controlling anything internal to app_rpt/allstar. Everything is a extension.or a stanza.

One last thing.
I would suguest you start your node#'s with a 4 digit number that does not start with ‘0’
While it may be done, it may have strange effects in some circumstances.

Thank you. I have now got some response. It seems to be an error though, I guess this might be due to node numbers starting with a 0?
I get error: channel.c:3051 ast_request: No channel type registered for ‘IAX2’
Any ideas where i should look to remedy this?

you see that error after commanding exactly what ?