Port 4569 is open on both hosts - yet no connection

Working on my dad’s node. Both nodes are on their own unique virtual servers, with only a single instance of ASL running. Both nodes have port 4569 open. Both nodes are reporting. But I can not connect them, no matter which one initiates the connection.

Any advice?

Dad’s Node - 42329

Dad’s Ports

My Node - 42177

My Ports

If these servers are behind a NAT router you need to do two things:

  • Use different IAX ports, 4569 on one and 4570 on the other.
  • Make sure you have the other server’s IP and port in the [nodes] stanza.


At this point I will try anything, but I thought that was typically only done when setting permanent connections and usually with private nodes? Have I misunderstood?

*EDIT: The reason I bring this up is because I am not trying to permanently connect these two nodes. But I can’t connect using 3. It feels like the same errors that one would get from port issues.

Thank for the suggestions Tim. Setting the separate ports didn’t do anything on it’s own, but after adding 42177 = radio@,NONE to dad’s rpt.conf and 42329 = radio@,NONE to my rpt.conf I was able to connect 42329 > 42177… but not the other way around… Some progress is better than none, I am satisfied for now.

Concerned as to why the same settings were not producing the same results on both servers concerns me a bit though and What should I do if I don’t have backend access to the next random node I am trying to connect to?

For now though, good enough. I can just run a remote shh command to his node if I need to be the node initiating the connection because I know the guy and he trusts me. :slight_smile:

Recheck your settings. I pretty sure the wiki document covers all the changes.

Remember to point each server to the other’s IP and port. Also be sure to change the port in iax.conf and rpt.conf of the server with the changed port. in iax.conf the bindport needs to be directly below the [general] stanza as shown. Restart asterisk on both servers after the changes are made.

Not related but you must change the server port on web-tpa.allstarlink.org in order for external nodes to connect.

They could be, they are located at the same data center.

Please send the IP addresses, in a PM if you prefer?

No, I am not overly stressed over it… I prefer to save my favors from smart guys till I really need them. Not worried about sharing my IP addresses, I just know I will call in a couple from you when I start playing with AMI haha

I appreciate the offer though, thank you kindly. :slight_smile:

I asked about the IP because I was trying to help you figure out if these are being a NAT router or not.

If in a data center maybe not. If the servers have different public IPs you shouldn’t have to do anything special. Just set them like a regular node.

Only servers that share the same public IP need to be on different IAX ports.

Ohh I know, I was just trying to be funny Tim…I do appreciate the extra help.

The IP on 42177 is
The IP on 42329 is

No worries, help is help. No such thing as extra help.

Because those are both public IPs they can be the same port or different ports, your option.

Again thank you for taking the time to help look into it. Most errors typically come down to user error. I am certainly no exception. I often get excited at some progress or idea and will work on it through to the morning hours and first pots of coffee, only hurting myself with typos and modifying the wrong files on the wrong servers and what not. I am sure these are my mistakes somewhere.

Yesterday I went through all the steps of adding a node and when finished I had no DTMF control. After 30 minutes I realized I had lit up one of my node numbers on a remote server of friend instead of my test server by accident. Not just one typo, but had the node completely online on the wrong host by accident. The curse of the old guy trying to still be the night owl.