Other nodes can't connect to my node 56376

Othe nodes get a Connection Failed message when trying to connect to my node. I have port 4569 forwarded on my router to the ASL node, which is on a PC at my home. More information below
estesvalley*CLI> iax2 show registry
Host dnsmgr Username Perceived Refresh State Y 56376 180 Registered

In iaxrpt.conf the bindport is set to 4569.
rpt_extnodes exists in the /var/lib/asterisk directory

Node: 56376

I just made a connection from 29999. No problem. Also from 29283.
Perhaps you found the issue ?
Let us know as I do have some ideas if it’s still a issue for you.
But also let me know if there are private nodes connected to 56376 when you have the issue.

Interesting. I have a second node 56517 at a different location. That node can connect to other nodes but not 56376. I based my problem description on this observation, assuming if one node couldn’t connect to 56376 all nodes would have the same problem. I am using the iaxrpt Windows app to make the connections.

Also, when I run Supermon on the 56517 node it is unable to connect to 56376 to display its status.


I run into this frequently. It always turns out to be a network provider problem, in my case Spectrum, the worst of the worst. A friend in Austin going thru this right now, having to re-arrange connections to our group of five. Usually in a day it resolves…
GeorgeC W2DB

Probably the first thing to check is if you are receiving node list updates.

check date/timestamp on /var/lib/asterisk/rpt_extnodes

if it is more than 30 minutes old, (any system within connection path)

systemctl restart updatenodelist

Also take a read of this for possibilities…


Well, today it is working. I had configured the iaxrpt app using my internal IP address for the node like this I changed to 56376.asnode.org:4569. I’m not sure if this fixed it, but in any case it is working now.

If you try to link nodes on 2 servers that are both behind the same NAT,
you will have a issue until you put the exact path & port of the other system in rpt.cof [nodes]
for they do not see the node by your external IP which is what the nodeslist shows.

I’m seeing a similar issue. I have 2 nodes, both are the same home network ie. behind NAT:

  1. Node 570570: This is a new node I just built with ASL beta 2. It can connect fine to any other node, including my node below.

  2. Node 570571: This is a ClearNode running hamVoip. It can connect to other nodes fine but when I try to connect to my node above it will not do so and gives the following error messages:

[Nov 5 20:28:15] NOTICE[383]: chan_iax2.c:9271 socket_process: Rejected connect attempt from, request ‘571570@radio-secure’ does not exist
[Nov 5 20:28:15] WARNING[385]: chan_iax2.c:9449 socket_process: Call rejected by No such context/extension

It’s not clear from this whether Node 2’s connect request actually got to Node 1 or not. I wouldn’t think this is a network issue because Node 1 can connect to 2 just fine.

Node 1 is updating its nodelist as it should, but node 2 (the ClearNode) seems to be missing the nodelist… there is a symlink from /var/lib/asterisk/rpt_extnodes → /tmp/rpt_extnodes but rpt_extnodes does not exist in /tmp/. I tried running ‘systemctl restart updatenodelist’ but it says ‘updatenodelist.service not found’.

If anyone has any ideas how to further debug this let me know. Or if I could at least confirm which of the nodes the issue is with that would help too. (The ClearNode does have node_lookup_method=dns set in rpt.conf so maybe hamVoip is just looking the node up on ASL’s site rather than maintaining a node list).

There are 2 basic reasons why you cannot connect from one node to the other when both servers are behind the same NAT.

Follow these instructions.

The other reason can be if both nodes are connected to any node of the same number.
A connection loop prevention in the software will not allow the connection. Even if they are private nodes “of the same number” that are not the same thing.
Hence you should never really use the suguested default 1999, but pick a arbitrary number between 1000 and 1999 or other scheme. See this.