Node Registration

My two nodes 482180 and 482181 show up in Green Highlights with a “wt” and “nnx” displayed and when I click on them I get “Node is ONLINE but is not reporting statistical data” checking other messages and the wiki help I went in to “iax.conf” and checked the registration line and it showed: register => 482180:(my actual password)@register.allstarlink.org The difference from the Wiki example was the => and spacing. So I changed it to match the wiki info - register=482180:(my actual password)@register.allstarlink.org. I did it both nodes and nothing has changed. I don’t show up on the map either. However if I go to the node that I am connected to I show up on the list, as well as the bubble chart. I am running the latest Allstar software as I regularly check. Any idea what else I can do or what the problem could be?

When the node is green on the nodelist your node is registered. When you click the node number that is a link to the status page. Status reporting is optional. To opt-in you must uncomment the
;statpost_url = http://stats.allstarlink.org/uhandler.php ; Status updates
line (in /etc/asterisk/rpt.conf) for each node you wish to report to the stats server.

Thanks for the quick response - I uncomment the statpost lines and added the url as directed. I re-started Asterisk and have waited 20 plus hours and nothing has changed. Do I have to power down the node completely to get the changes to take place?

Maybe try rebooting the node, but restarting asterisk should be all you need to take care of that. Is it possible to send a snippet of your rpt.conf to see which lines where uncommented out?

Jim, K6JWN

Thank you when I added the ; Status updates to the line everything seemed to work. When I first changed the line I omitted the last section. Node status showed up next I did the same to the second node and that showed up.

Follow-up - late yesterday one node (482180) isn’t sending status updates. Earlier yesterday I fixed the rpt.conf files of both nodes 482180 and 482181 and both had identical lines and both started showing status. 482181 showed up on the Map however 482180 didn’t show up on the map. Both nodes when clicked on showed status information. This morning the only one showing status is 482181 and 482180 is showing Node is ONLINE but is not reporting statistical data. I think I figured it out today - In case someone else has the same situation here is what I did - When I first updated the Status line information on node 482180 I accidentally scrolled down too far and put the information in the second node status lines. I did realize it yesterday and put the information in the status section of the first node but didn’t re-comment the lines in the second node listing and at first the node status showed up. When it didn’t show up today I went back and checked the rpt.conf file and commented out the status lines in the second node section of file and after I restarted the node the status showed up correctly however the node doesn’t not show up on the map.- just the 482181 shows on the map. Is there something else I missed??.

Follow-up - not to belabor this - node 482180 after reporting status yesterday is not reporting status this morning. Unless anyone has another suggestion I figure my next course of action is to reformat the SD card in node 48180, download the latest program from hamvoip and start from scratch setting up the node. I will print out a copy of the rpt.conf file and iax.conf file before I re-format the node. Any other suggestions would be appreciated.

So, since each node has it’s own configuration in rpt.conf, you will need to have the statpost_url line twice in that file (one for each node). For the mapping part, not really sure whats up there. I noticed that only one of my nodes shows up on the map (but I have 4 here at home).

Jim, K6JWN