Node 433260 connects OUT but refuses connections IN

Hello Community,
I having a strange problem with one of my nodes. It refuses to accept connections from other nodes, however, if I initiate a connection TO another node it works.

Example:
433260 >>>>>>>> 431420 - CONNECTION ESTABLISH
431420 >>>>>>>> 433260 - CONNECTION FAILED
431420 >>>>>>>>xxxxxxN - CONNECTION ESTABLISH - TO ALL OTHER NODES TESTED

Here is the CLI Warning:
== Manager ‘admin’ logged off from 127.0.0.1
– Accepting UNAUTHENTICATED call from 127.0.0.1:
> requested format = gsm,
> requested prefs = (gsm|ulaw|adpcm|g722|g726aal2|ilbc),
> actual format = ulaw,
> host prefs = (ulaw|adpcm|g722|g726aal2|gsm|ilbc),
> priority = mine
– Call accepted by 127.0.0.1 (format ulaw)
– Format for call is ulaw
– Executing [433260@radio-secure:1] Rpt(“IAX2/127.0.0.1:4569-15262”, “433260”) in new stack
[Jul 1 23:31:42] WARNING[1583]: app_rpt.c:22930 rpt_exec: Node 431420 IP 149.28.232.105 does not match link IP 127.0.0.1!!
== Spawn extension (radio-secure, 433260, 1) exited non-zero on ‘IAX2/127.0.0.1:4569-15262’
– Hungup ‘IAX2/127.0.0.1:4569-15262’
– Hungup ‘IAX2/127.0.0.1:4569-6454’
– Hungup ‘DAHDI/pseudo-1630450430’
– Hungup ‘DAHDI/pseudo-841527757’
– <DAHDI/pseudo-784443050> Playing ‘rpt/node’ (language ‘en’)
– <DAHDI/pseudo-784443050> Playing ‘digits/4’ (language ‘en’)
– <DAHDI/pseudo-784443050> Playing ‘digits/3’ (language ‘en’)
– <DAHDI/pseudo-784443050> Playing ‘digits/3’ (language ‘en’)
– <DAHDI/pseudo-784443050> Playing ‘digits/2’ (language ‘en’)
– <DAHDI/pseudo-784443050> Playing ‘digits/6’ (language ‘en’)
– <DAHDI/pseudo-784443050> Playing ‘digits/0’ (language ‘en’)
– <DAHDI/pseudo-784443050> Playing ‘rpt/connection_failed’ (language ‘en’)

THE KICKER

431420 resides on the same virtual server as 433260.

The iax, extentions, usbradio and rpt config scripts for 431420 are all edits of 433260. That is to say the required stantza for 431420 were copied, pasted and edited from 433260. Yet 431420 WORKS perfectly and 433260 REFUSES CONNECTIONS.

Looking forward to your kind assistance.

1 Like

I was able to connect to both nodes.

Rick

Thanks for checking. I really do not understand why 432660 is not accepting any of my connections; However, if you can connect to it - that makes me happy. I will wait to see if anyone else presents a possible solution…
Thanks a million
73
Paul

1 Like

See if this helps

https://wiki.allstarlink.org/wiki/Two_Nodes_on_One_Server

1 Like

Hello wd6awp,

Firstly, thank you very much for taking the time to respond.
That is the very document I used to create the additional nodes. All of the additional nodes, 431420 and 431421 are working perfectly. What bothers me is that I started off the 433260 as the primary node. Then I followed the instructions you just guided me to create the others. The only difference (notwithstanding the obvious configurations) is that 433260 has echolink enabled.

Thanks a million for the tip and I truly appreciate the help.

I keep at it.
K9PSL

1 Like

You say 431420 resides on the same virtual server as 433260.

Since both Nodes are on the same server …
In rpt.conf try adding each Node’s info using the server’s LAN IP not
12.0.0.1 to the stanza for opposite NODE’s stanza.

Like so

431420 = radio@192.168.8.50:4569/431420,NONE
433260 = radio@192.168.8.50:4569/433260,NONE

Then restart Asterisk

Larry - N7FM

···

On 7/2/20 8:23 AM, Paul Lowman (K9PSL) via AllStarLink Discussion Groups wrote:

[k9psl] k9psl https://community.allstarlink.org/u/k9psl
July 2

Hello wd6awp,

Firstly, thank you very much for taking the time to respond.
That is the very document I used to create the additional nodes. All of
the additional nodes, 431420 and 431421 are working perfectly. What
bothers me is that I started off the 433260 as the primary node. Then I
followed the instructions you just guided me to create the others. The
only difference (notwithstanding the obvious configurations) is that
433260 has echolink enabled.

Thanks a million for the tip and I truly appreciate the help.

I keep at it.
K9PSL


Visit Topic
https://community.allstarlink.org/t/node-433260-connects-out-but-refuses-connections-in/17240/6
or reply to this email to respond.


    In Reply To

[wd6awp] wd6awp https://community.allstarlink.org/u/wd6awp ASL Admin
July 2

See if this helps https://wiki.allstarlink.org/wiki/Two_Nodes_on_One_Server

    Previous Replies

[wd6awp] wd6awp https://community.allstarlink.org/u/wd6awp ASL Admin
July 2

See if this helps

https://wiki.allstarlink.org/wiki/Two_Nodes_on_One_Server

[k9psl] k9psl https://community.allstarlink.org/u/k9psl
July 2

Thanks for checking. I really do not understand why 432660 is not
accepting any of my connections; However, if you can connect to it -
that makes me happy. I will wait to see if anyone else presents a
possible solution…
Thanks a million
73
Paul

[KR8T] KR8T https://community.allstarlink.org/u/kr8t
July 2

I was able to connect to both nodes.

Rick

[k9psl] k9psl https://community.allstarlink.org/u/k9psl
July 2

Hello Community,
I having a strange problem with one of my nodes. It refuses to accept
connections from other nodes, however, if I initiate a connection TO
another node it works.

Example:
433260 >>>>>>>> 431420 - CONNECTION ESTABLISH
431420 >>>>>>>> 433260 - CONNECTION FAILED
431420 >>>>>>>>xxxxxxN - CONNECTION ESTABLISH - TO ALL OTHER NODES TESTED

Here is the CLI Warning:
== Manager ‘admin’ logged off from 127.0.0.1
– Accepting UNAUTHENTICATED call from 127.0.0.1:

requested format = gsm,
requested prefs = (gsm|ulaw|adpcm|g722|g726aal2|ilbc),
actual format = ulaw,
host prefs = (ulaw|adpcm|g722|g726aal2|gsm|ilbc),
priority = mine
– Call accepted by 127.0.0.1 (format ulaw)
– Format for call is ulaw
– Executing [433260@radio-secure:1] Rpt(“IAX2/127.0.0.1:4569-15262”,
“433260”) in new stack
[Jul 1 23:31:42] WARNING[1583]: app_rpt.c:22930 rpt_exec: Node 431420
IP 149.28.232.105 does not match link IP 127.0.0.1!!

== Spawn extension (radio-secure, 433260, 1) exited non-zero on
‘IAX2/127.0.0.1:4569-15262’
– Hungup ‘IAX2/127.0.0.1:4569-15262’
– Hungup ‘IAX2/127.0.0.1:4569-6454’
– Hungup ‘DAHDI/pseudo-1630450430’
– Hungup ‘DAHDI/pseudo-841527757’
– <DAHDI/pseudo-784443050> Playing ‘rpt/node’ (language ‘en’)
– <DAHDI/pseudo-784443050> Playing ‘digits/4’ (language ‘en’)
– <DAHDI/pseudo-784443050> Playing ‘digits/3’ (language ‘en’)
– <DAHDI/pseudo-784443050> Playing ‘digits/3’ (language ‘en’)
– <DAHDI/pseudo-784443050> Playing ‘digits/2’ (language ‘en’)
– <DAHDI/pseudo-784443050> Playing ‘digits/6’ (language ‘en’)
– <DAHDI/pseudo-784443050> Playing ‘digits/0’ (language ‘en’)
– <DAHDI/pseudo-784443050> Playing ‘rpt/connection_failed’ (language ‘en’)

THE KICKER

431420 resides on the same virtual server as 433260.

The iax, extentions, usbradio and rpt config scripts for 431420 are all
edits of 433260. That is to say the required stantza for 431420 were
copied, pasted and edited from 433260. Yet 431420 WORKS perfectly and
433260 REFUSES CONNECTIONS.

Looking forward to your kind assistance.


Visit Topic
https://community.allstarlink.org/t/node-433260-connects-out-but-refuses-connections-in/17240/6
or reply to this email to respond.

You are receiving this because you enabled mailing list mode.

To unsubscribe from these emails, click here
https://community.allstarlink.org/email/unsubscribe/dc361543516b75444e9ae47c1d57f119200a5820a5b37bdded51d3c84fb043d3.

1 Like

Hello k9psl,

Echolink is unlikely to be the problem. You can always rename or move the echolink.conf file to test. Also, if you can have someone put another set of eyes on your configs that might help. I’m guessing there is a small mistake there somewhere.

1 Like

Hello Larry,
PROBLEM SOLVED!!!

I have been pulling at my scalp about his for a few weeks now because I wanted to be sure that I did all I could before coming to the forum. A million ‘thank you’ for the tip, 433260 now functions perfectly.
I can connect IN and OUT with each of the nodes.

All the best!
73
Paul

1 Like

Hello Tim,
Once again thanks for pointing me in the right direction. I was about to tear down the Echolink portion of 433260, but I attempted Larry’s fix and that worked. A suggestion to perhaps add the text of this fix as an amendment to the documentation on the Wiki just in case others encounter the same problem. I think Larry contextualized it best, so here is a quick cut and paste if you concur:

PROPOSED AMENDMENT BEGINS****
If you experience connection problems among your nodes residing on the same server, in rpt.conf try using the server’s LAN IP instead of the default 127.0.0.1 for each NODE stanza configuration:
For example:
XXX420 = radio@192.168.8.50:4569/XXX420,NONE
433XXX = radio@192.168.8.50:4569/433XXX,NONE
Then restart Asterisk
PROPOSED AMENDMENT ENDS****

Again,
I really appreciate the help and I hope I can be of help to others in the future.
73
K9PSL
Paul

Glad you got it working Paul…

Larry - N7FM

···

On 7/2/20 9:56 PM, Paul Lowman (K9PSL) via AllStarLink Discussion Groups wrote:

[k9psl] k9psl https://community.allstarlink.org/u/k9psl
July 3

Hello Larry,
PROBLEM SOLVED!!!

I have been pulling at my scalp about his for a few weeks now because I
wanted to be sure that I did all I could before coming to the forum. A
million ‘thank you’ for the tip, 433260 now functions perfectly.
I can connect IN and OUT with each of the nodes.

All the best!
73
Paul


Visit Topic
https://community.allstarlink.org/t/node-433260-connects-out-but-refuses-connections-in/17240/9
or reply to this email to respond.


    In Reply To

[larry] larry https://community.allstarlink.org/u/larry
July 2

You say 431420 resides on the same virtual server as 433260. Since both
Nodes are on the same server … In rpt.conf try adding each Node’s info
using the server’s LAN IP not 12.0.0.1 to the stanza for opposite NODE’s
stanza. Like so 431420 = radio@192.168.8.50:4569/431420,NONE 433260 =
radio@19…

    Previous Replies

[wd6awp] wd6awp https://community.allstarlink.org/u/wd6awp ASL Admin
July 3

Hello k9psl,

Echolink is unlikely to be the problem. You can always rename or move
the echolink.conf file to test. Also, if you can have someone put
another set of eyes on your configs that might help. I’m guessing there
is a small mistake there somewhere.

[larry] larry https://community.allstarlink.org/u/larry
July 2

You say 431420 resides on the same virtual server as 433260.

Since both Nodes are on the same server …
In rpt.conf try adding each Node’s info using the server’s LAN IP not
12.0.0.1 to the stanza for opposite NODE’s stanza.

Like so

431420 = radio@192.168.8.50:4569/431420,NONE
433260 = radio@192.168.8.50:4569/433260,NONE

Then restart Asterisk

Larry - N7FM

··· (click for more details)
https://community.allstarlink.org/t/node-433260-connects-out-but-refuses-connections-in/17240/7
[k9psl] k9psl https://community.allstarlink.org/u/k9psl
July 2

Hello wd6awp,

Firstly, thank you very much for taking the time to respond.
That is the very document I used to create the additional nodes. All of
the additional nodes, 431420 and 431421 are working perfectly. What
bothers me is that I started off the 433260 as the primary node. Then I
followed the instructions you just guided me to create the others. The
only difference (notwithstanding the obvious configurations) is that
433260 has echolink enabled.

Thanks a million for the tip and I truly appreciate the help.

I keep at it.
K9PSL

[wd6awp] wd6awp https://community.allstarlink.org/u/wd6awp ASL Admin
July 2

See if this helps

https://wiki.allstarlink.org/wiki/Two_Nodes_on_One_Server

[k9psl] k9psl https://community.allstarlink.org/u/k9psl
July 2

Thanks for checking. I really do not understand why 432660 is not
accepting any of my connections; However, if you can connect to it -
that makes me happy. I will wait to see if anyone else presents a
possible solution…
Thanks a million
73
Paul


Visit Topic
https://community.allstarlink.org/t/node-433260-connects-out-but-refuses-connections-in/17240/9
or reply to this email to respond.

You are receiving this because you enabled mailing list mode.

To unsubscribe from these emails, click here
https://community.allstarlink.org/email/unsubscribe/576807865db34c42b8c125ef562b8ab2055e02c1955c59c25e7a4229963b2993.