New User - Raspberry Pi4 - Can't Seem To Connect - RIM-Alinco

Hi Everyone.
Thank you in advance for your patience. I have installed the Beta 2.0 Allstarlink software on a Raspberry Pi 4. I followed all of the setup instructions step by step and seem to have everything configured correctly. However, the only thing that seems to be happening is when I start up the Pi, the radio (Alinco DR-235 MkIII with RIM-Alinco interface) transmits a courtesy tone, followed by my callsign in Morse code. The screen on the Pi shows Allstarlink Beta 2.0.0 at the top and I have a login prompt at the bottom. Questions:

  1. What am I missing? Should I be able to transmit DTMF tones and connect to other nodes at this point? That doesn’t seem to work. I already have a node and am registered.
  2. Do I need a port opened on my router? (i.e. 4569)?
  3. On the Allmon screen (when I use a web browser and go to the IP address of the Pi) I get a message “Could not login to Asterisk Manager.” Any idea why?

Thanks in advance for helping me with this. I did some extensive Internet searches (and Youtube) but I can’t seem to find these answers.


Rowe, KO4PK

As to question 3, You do not have something set correctly. It appears you are missing correct login/setup for the AMI/asterisk manager. Be sure you have proper user/pass set in manager.conf and your allmonini.php

As to question 2, You do not need the 4569 (default) port opened in your router for outbound connects. But you will need it to properly route inbound connects.

As to the first question, I’m not sure what you are missing as we do not know a lot about your perticular conf. Like duplex mode etc.
Assuming you have this config’d for a simplex node, you should be able to issue a command like
*2 2135 and connect for monitor the on the WAN system.

I am assuming you have set your audio levels up via the instruction for usbradio / simpleusb and it should decode your dtmf.
a internal command of *81 should playback the time.
*70 would say list of connected nodes
That should give you enough to test with.
So let us know some more about testing the above and where you are, with perhaps additional info on your config.

Thanks for your email. I have been able to progress a little bit but still having some issues. To answer your questions:
Question 3 - The issue with my not being able to log into Asterisk Manager was because I had an exclamation point in my password. Once I got rid of that (changing the config files) it worked.

Question 2 - Thank you. I will not open up any ports as I only plan for outbound.

Question 1 - I have run through the config section of the usbradio/simpleusb. Everything seems to be okay except for option 2 "Set Rx Voice Level (using display). When I choose that option, the only thing that comes up is “v – 3KHz v – 5KHz.” Although the instruction say to transmit voice or a tone, nothing changes on my display.

I have it set up as a simplex node. I am able to connect to another node through using Allmon on my Windows computer, but I don’t seem to be able to transmit to the node. I can hear received audio just fine, but when I transmit or use DTMF nothing happens on the Alinco radio other than the squelch closing once I am done transmitting. My issue seems to be that the node doesn’t hear me. I tried the additional DTMF tones you suggested and no response. Sounds like I’m probably missing a setting somewhere, but not sure where to go from here. Thanks in advance for any additional help you can provide.

Before you go through much,
what is your duplex mode in rpt.conf ?
and in your usbradio or simpleusb duplex = ?

In rpt.conf - Duplex = 1
In usbradio - Duplex = 0 / Duplex3 = 0
In simpleusb - Duplex = 0, duplex3 = 0

Additional settings:
usbradio.conf - carrierfrom = usb, ctcssfrom = no
simpleusb.conf - carrierfrom = usb, ctcss from = usb


simpleusb.conf - carrierfrom = usb, ctcss from = no

Ok. so after tinkering with the settings, I can now transmit out to a node that I am connected to. Had a nice QSO with Australia. However, I still cannot connect/disconnect to a node using the DTMF commands. I have to use the Allmon monitor to make the changes.

Getting closer. I wonder what else needs to change in order for it to respond to DTMF?


I can only assume that since you have 2 way audio working and cos/ptt logic is correct that your duplex settings are good

That leaves us with correct audio as measured at the DSP input, which means that it is too hot or cold to decode.

But you will have to forgive me a little as I have never run a simplex system before.
Just repeaters, dahdi. & usrp, So there could possibly be something else I am not aware of.
And maybe someone will chime in.

But just because it sounds good on your tx side does not mean that the rx is at the right level. It could be cold and be made up at the tx side. But your rx will never decode that way. (or visa-versa)

You do need to know what you are using - simpleusb or usbradio
To see what it is set at look in your rpt.conf for this
[29285] ;assigned node number UHF repeater

;rxchannel = dahdi/pseudo
rxchannel = SimpleUSB/usb_29285 ; Rx audio/signalling channel <<<<<<<<<<<<<
;rxchannel = Radio/usb_29285

Notice the one that is not commented out is the active one we are using.
So you need to review the correct audio settings procedure for the method selected as they are not exactly the same.

Here is what I have in rpt.conf
;rxchannel = dahdi/pseudo
rxchannel = SimpleUSB/usb_56311 ; SimpleUSB
;rxchannel - Radio/usb_56311 ;USBRadio (DSP)


So, you need to run the ‘asl-menu’
and select simpleusb radio tune

You likely were selecting usbradio tune before and you are not using that channel driver.


Everything in usbtune seems to be fine.
I figured out the problem. The “3” button on my HT (Baofeng UV-S9X3) isn’t transmitting the 3 tone correctly. All other tones are decoded property except for the “3.” I used my Yaesu FT-70 to send the tones and I keyed the Baofeng and it worked (I only have 220 on the Baofeng).

Thank you for all of your help. You got me a lot further with this and I am very grateful.
By the way, I have two of these HT’s and both of them cannot send a “3” that the system recognizes. Very odd.

Thanks again and 73,

Rowe, KO4PK

I would say dtmf levels on many of those radios leave a lot to be desired as well as being on freq.
Both issues combine for a multitude of problems. You would not be the first.

I might add, you can watch asterisk decode, or not by watching it live…

asterisk -rvvv


Great! I was able to see that too. Very helpful. Thanks again.


Rowe, KO4PK


Are you using the RIM_Lite - Alinco (Item# RIM_Lite-Alinco) made for AllStarLink OR are you using the RIM Lite 9600 Board for Alinco? I believe there is a difference in those two boards. The 9600 does not seem to work for AllStarLink but works great for Winlink/Packet/Vara FM.

I have an Alinco DR-135 MkIII. The "Set Rx Voice Level (using display). When I choose that option, the only thing that comes up is “v – 3KHz v – 5KHz.” problem you describe was exactly what was happening to me. When I bought the RIM_Lite - Alinco (Item# RIM_Lite-Alinco) made for AllStarLink, Option 2 worked immediately. As Mike noted, just because the radio can transmit, doesn’t mean the RX Voice level is correct.

My setup is a RPi 3B, Repeater-Builder RIM Alinco for AllStarLink, and the Alinco DR-135 MkIII. It seems to be working perfectly now. I’d be happy to share my config file(s) if that would help.


Repeater Builder Website (scroll down that page for the AllStarLink RIM Board).