New user, mostly working, a question about "busy"

Hi all. I’m brand new to Allstar, and today I spun up a node on a cloud server running ASL.

I’ve got it configured and working, and I can dial in from IAX clients, and I can successfully use the allstar system when I’m connected.

The problem comes when I disconnect my IAX client, but leave my node connected to another node. For as long as the nodes are connected, I can’t dial back in.

I dial the node number, I hear the node number read out to me, then I’m disconnected. I get the following error output in the Asterisk CLI whenever is happens:

[May 30 23:16:38] NOTICE[747]: app_rpt.c:22668 rpt_exec: Radio Channel Busy.

If I disconnect the other node I’m connected to before I hang up, I can dial back in. And if I use an external management tool to disconnect the node I can dial back in.

Is this normal behavior?

I hadn’t noticed this in my own testing initially as I was manually disconnecting things when I was finished. But today, someone connected to my node and I had to kick them off before I could dial back in. Which lead me to testing and discovering that I get the same “problem” whenever a node is connected to my node.

Obviously this is in the cloud, there’s no real radio involved, and I’m using purely IAX access.

Any pointers would be appreciated. And I can provide any logs or output that might be useful.

By what method do you connect to your node? are you using the same allstalink node number and password to connect to the node? what software do you connect to the node with? Mobile? iaxrpt?

did you followed the entry in the wiki to configure the software connecting to the node?

https://wiki.allstarlink.org/wiki/Setup_IAXRPT_use

By what method do you connect to your node?

I am connected with a few different methods:

iaxrpt, DVSwitch Mobile, Zoiper. They all show me the same problem.

are you using the same allstalink node number and password to connect to the node?

I’m not exactly sure what you mean. But yes - as I say, I can dial in successfully if my node isn’t actively connected to another one.

did you followed the entry in the wiki to configure the software connecting to the node?

Yes. I’ve tried those settings, I’ve also tried these ones:

https://dvswitch.groups.io/g/Mobile/wiki/8719

I’ll share what I think are my important configurations.

My iax.conf stanza (PASSWORD is swapped in real life):

[MM7DDG]
type = friend
context = phone-iaxrpt
auth = md5
secret = PASSWORD
host = dynamic
disallow = all
allow = ulaw
allow = adpcm
allow = gsm
allow = slin
transfer = no
codecpriority = caller
calltokenoptional=0.0.0.0/0.0.0.0
requirecalltoken=no

Extensions:

[phone-iaxrpt]
exten => ${NODE},1,Ringing
exten => ${NODE},n,Wait(3)
exten => ${NODE},n,Answer
exten => ${NODE},n,Set(RPT_NODENUM=${CALLERID(number)})
exten => ${NODE},n,Playback(connected)
exten => ${NODE},n,Set(CALLERID(num)=0)
exten => ${NODE},n,Rpt,${NODE}|P|${CALLERID(name)}
exten => ${NODE},n,Hangup
exten => ${NODE},n(hangit),Answer
exten => ${NODE},n(hangit),Wait(1)
exten => ${NODE},n(hangit),Hangup

So just to reiterate the behaviour:

If my node is not connected to any other node, I can dial in from iaxrtpt, DVSwitch movbile and zoiper. Everything works fine. I can conenct to another node, I can have a QSO. All works great.

If I hang up my client and leave the node conneced to another one, then when I try to dial in with any of my iax clients I get the same thing. It dials, seems to connect for half a second then hangs up with the following error is the asterisk CLI:

[May 30 23:16:38] NOTICE[747]: app_rpt.c:22668 rpt_exec: Radio Channel Busy.

As a quick follow up, just incase I’d done something obviously wrong during setup. I’ve just started from scratch, built the server and node from the ground up and I get the same behaviour. Works totally fine. However, if when I hang up, I leave my node connected to another node, I can’t dial back in. I have to first use allmon2 (or an iphone management app) to disconnect the other node.

Then I can dial in via IAX clients again.

My current configuration is similar to above. iax.conf stanza:

[iaxclient]
type = friend
context = iax-client
auth = md5
secret = PASSWORD
host = dynamic
disallow = all
allow = ulaw
allow = adpcm
allow = gsm
transfer = no

And my extensions stanza:

[iax-client]
exten => ${NODE},1,Ringing
exten => ${NODE},n,Wait(3)
exten => ${NODE},n,Answer
exten => ${NODE},n,Set(NODENUM=${CALLERID(number)})
exten => ${NODE},n,Playback(rpt/node|noanswer)
exten => ${NODE},n,SayDigits(${EXTEN})
exten => ${NODE},n,Set(CALLERID(num)=0)
exten => ${NODE},n,Rpt,${NODE}|P|${CALLERID(name)}
exten => ${NODE},n,Hangup
exten => ${NODE},n(hangit),Answer
exten => ${NODE},n(hangit),Wait(1)
exten => ${NODE},n(hangit),Hangup

Using the username “iaxclient” on my DVSwitch Mobile app, with the same PASSWORD as in the above excerpt.

Ok, a real update. iaxRpt works properly and how I expect if I dial in using the account “iaxrpt” with the following Stanza:

[iaxrpt]
type = user
context = iaxrpt
auth = md5
secret = maythefourth85
host = dynamic
disallow = all
allow = ulaw
allow = adpcm
allow = gsm
transfer = no

and

[iaxrpt]                                ; entered from iaxrpt in iax.conf
exten => ${NODE},1,rpt(${NODE}|X)       ; NODE is the Name field in iaxrpt
                                        ; Info: The X option passed to the Rpt application
                                        ; disables the normal security checks.
                                        ; Because incoming connections are validated in iax.conf,
                                        ; and we don't know where the user will be coming from in advance,
                                        ; the X option is required.

It’s just the DVSwitch Mobile client and Zopier that behaves how I describe. Progress! :smiley:

I am having the same issue, using both of the iaxrpt or iaxclient logins that came pre-configured. All I changed was the password, and I’m actually connecting from another Asterisk server of mine.