New to Allstar and have a slight problem

Hi, just new to Allstar and got a node built for me by Peter (G7RPG)

Everything works fine apart from a slight issue which I am having no luck finding a solution for.

I have a Yaesu 7250 which is connected to the antenna on the roof and when I key up this radio it will transmit to the box no problem as indicated by the lights on the front changing from blue to green. However the problem lies with when I use my FT70 h/t, the node box doesn’t “hear” that I’ve transmitted and just sits idle. I’ve tried different power settings on the FT70 and it makes no difference. I am only about 3 ft away from the box.

I have also tried it with a Baofeng 888s and also a Retevis RT3S which can transmit on analogue as well. I’ve checked the obvious things like CTCSS and everything seems fine.

Was wondering if anyone has had a similar issue before or if anyone could point me in the right direction for troubleshooting this issue. I’d prefer to be able to use Allstar on the FT70 as opposed to the larger rig.

Many Thanks,