New install with ver ASL_1.01

Just installed ASL_1.01 as a new node on my LAN.

Do I need to open another port on the router?

Tried running asterisk and got ‘Unable to connect to remote asterisk (does /var/run/asterisk.ctl exist?)’

Can Ping, use PUTTY and WinScp

I assume you get that message after running asterisk -r. That message means asterisk is not running. But it can also mean you are not root. Be sure to sudo su - to run as root.

Peter Paul Fox
Many Thanks. Had forgotten it was not at root. Used sudo and it worked

However I have another RPI Node already running and I was setting this up to be a mobile micro-node.
However when I try it cannot connect. But I can on the other node.
Does it need a USB sound fob? I wouldn’t have thought so.
I am using Asus dsl n55u router but cannot seem to be able to enter any port forwarding ports. mayb that is a problem; but why does one work without any port forwarding.
Still trying.

The Allmon URL might be

No ports need to be forwarded it you and the node are on the same subnet, (192.168.1.x for example).

When I run iax2 show registry I get this Registration Refused

Connected to Asterisk GIT Version adaec47 currently running on RPI-MOB (pid = 54 0)
[Mar 10 12:17:20] NOTICE[595]: chan_iax2.c:9712 socket_process: Registration of ‘43203’ rejected: ‘Registration Refused’ from: ‘’.

When I log onto my Allmon account and check this node and the working node the details are similar.

Also get
Host dnsmgr Username Perceived Refresh State Y 43203 60 Rejected

Is it on the web registration somewhere?

Thanks for your patience.

Hi Update; I noticed that the port number is the one used by the other node.
I thought during set up I had entered a different port number.

Can you guide me to the conf files where I need to amend it.

Tried searching on Bing and Google but not successful so far.

Ports other than 4569 are only needed when you have 2 or more servers behind the same public IP address.

For ASL registration the port must be set it three places and it must match. 1) in your server settings on the web site ( 2) in the [general] section of /etc/asterisk/iax.conf. 3) The [nodes] section of /etc/asterisk/rpt.conf.


Many Thanks,
When I log in to the allmon site I see under Portal Servers and nodes.
Click on servers and it lists four and likewise there are four nodes. I set these up under the old website which had settings.
On the new site when I click on a server I just get the settings I entered. There are no tabs or anything clickable. I have changed the other two files. Under the old system i set up node 42383 which is active.
I can go and connect and disconnect to the system,but the http:// wont work with the other IP.

The new site has fewer server and node settings. There are no tabs as the server and node settings are on one page each. You should see something similar to this for a node:

and this for a server:

The old site could push the node configuration to your server. With the new site you configure your node with the new menus built-in to your node. You may also choose to edit the conf files by hand or using a tool such as WinSCP. There is a topic on Community for how to use WinSCP if you choose to do so.

So you are saying you can’t access Allmon second server or that Allmon won’t function the node?

Thanks for the reply.
With my existing node I can go to http://IP address, but after setting up the second node I cannot use http://other IP address.