MTR2000 not passing RX audio to TX or decoding DTMF

I have a new Allstar 2.0.0 build on a RPi 4.
Primary issues:

  1. RX is not passed when repeated, just a carrier
  2. DTMF is not decoded, gives CLI error HUNGUP 'DAHDI/pseudoxxxx (series of numbers)
  • All telemetry, voice works fine, proper audio out of MTR2K TX, full power 40 watts VHF on 2M rpt freq.
  • when I link to another node/hub the MTR2K RX audio passes fine to the other nodes
  • audio from the other nodes is passed out the MTR2K TX
  • I have rpt.conf duplex = 2
  • using USBRadio and an RA-40 board
  • pulling discrim audio off the 96 pin connector and injecting into the A17 TX audio port on the MTR2K
  • the MTR2K is set up in base station mode, COR lights up with RX carrier
  • when I key up the MTR2K, Allstar holds TX for about 4-5 seconds, then the courtesy tone fires
  • I have the MTR at my house in rack, on 250 watt Bird dummy load and RX to outside antenna

Any thoughts?

tnx, John N4SJW
Parker, CO

I’m not familiar with the MTR2000. Maybe base station mode is half duplex or it mutes Rx audio with PTT. Is there another PTT pin that might not do that? might be helpful.
Motorola MTR2000 Information Index

AllStar mutes DTMF so all you hear on the Tx is a short chirp from each TT.

Thanks Tim. I’m taking audio off discriminator, so doubtful it’s being muted, but I’ll check on the RB site.

What does the CLI error below mean?

CLI error HUNGUP 'DAHDI/pseudoxxxx (series of numbers)


Oh, I saw that in your earlier post but forgot to comment. Uh… that can’t be good. But if it inly happens with DTMF it may not be related to the repeat audio problem. I’m not sure how to fix that. It’s a new one on me.

As you said it seems unlikely that the discriminator is muted. The fact that other nodes can hear you backs up that. However, perhaps there is a PTT priority in the MSR that mutes audio from whatever input pin you’re using.

Some clarification:

  • the RA-40 board processes the incoming discriminator audio
  • detects the correct CTCSS
  • Allstar turns on the PTT and repeats
  • no audio coming out of the TX
  • it does beep after a few seconds and that continues every few seconds
  • it acts like its getting desense
  • I can link to a node/hub and external audio gets routed to the repeater and audio quality is good
  • telemetry works
  • when I key up the test repeater, I still get the hangup error message above
  • no audio is passed down the link from the local rptr RX

So I’m stumped at this point . .

I went to a web I found on the ra40 and did not find what I was looking for.
My advice if you are still pondering this would be to first verify the COR logic and voltages maintain minimum/max thresholds while it is actively running.

Perhaps even re-run usbradiotune.
And verify nothing erroneous exists in usbradiotunexxxxx.conf file.

You might also look for rf on the cor line.

Mike, thanks for follow up. Last week, mostly out of frustration, I flashed a copy of HamVoIP and tried that on the repeater, Well after a little tinkering with audio, everything worked fine, all audio being passed, COR line behaving correctly, audio working well. So . . . . I’m going to flash a new SD card with 2.0.0 and see if there was something that got corrupted in my initial build. At least I know the cable, MTR2000, and RA-40 board are all working as they should. I should be able to get the new build installed next couple of days and I’ll report back my findings.

John, thank you for your follow-up. It may help others.
I can say that we have seen over the years a bunch of strange file corruptions of some sort.
I have never tracked them down to anything specific outside of bad sd cards, but not from the lack of trying.
It may very well be your issue. I should have known to suggest it. Nobody seems to like to try again with new sd. Being in a hurry I guess. Sometimes it is simply a hidden character in a setup/.conf file that comes back on a reload if you re-use your old .conf files…

Mike, just a brief follow up. Spend a few hours this afternoon, and cannot figure out why no RX audio is getting through. TX audio both telemetry/voice and linked audio work fine. On RX, I can see the DSP (RA-40) is detecting the correct CTCSS tone, but no RX audio is passed. I tried SimpleUSB in Allstar 2.0.0 and same issues. I went back to my HamVoIP SD card, and everything works well and no issues passing local RX audio. I’ve run out of options why 2.0.0 is not working. Another local ham has almost the identical MTR2000 using the same cabling and 2.0.0 USBRadio and is working fine. So for now, I’ll stick with the HamVoIP build unless there are any additional suggestions from the forum members.

John N4SJW Parker, CO

Taking a guess…
inside of simpleusb_tune_xxxxx.conf


Match the fist 2 numbers with your actual device id as seen from


You are looking for the sound chip… cmedia or equivalent.

Having re-read your post a few times…
Do you also have ctcss set in asl



Yet one other guess if you are activating ctcss from the ra40, you do not also need it on the asl set-up and you could look also to see if it is a different tone.
Since I know nothing of the ra40… It’s all I got LOL

Mike I found the problem. In USBRadio.conf, you need to set the following to 1 (default = 0):

duplex = 1 ; Duplex 0,1
; 0 - half duplex
; 1 - full duplex
duplex3 = 1 ; duplex 3 gain setting (0 to disable) ???

The default setting = 0 even though the initial setup you can specify full duplex in

duplex = 2 ; 0 = Half duplex with no telemetry tones or hang time.
; Special Case: Full duplex if linktolink is set to yes.
; This mode is preferred when interfacing with an external multiport repeater controller.
; Comment out idrecording and idtalkover to suppress IDs also
; 1 = Half duplex with telemetry tones and hang time. Does not repeat audio.
; This mode is preferred when interfacing a simplex node.
; 2 = Full Duplex with telemetry tones and hang time.
; This mode is preferred when interfacing a repeater.
; 3 = Full Duplex with telemetry tones and hang time, but no repeated audio.
; 4 = Full Duplex with telemetry tones and hang time. Repeated audio only when the autopatch is down.

So you can replicate the problem if you have a full duplex radio, to setting duplex = 2 in rpt.config (this is done in the initial setup routine) and leave duplex and duplex3 = 0 (default) in USBRadio.conf which is not changed during the initial setup.

Lesson learned :slight_smile:

John N4SJW

Glad to hear it. TNX for posting a update for everyone.
It seems to me, now that I think on that, it has appeared before.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.