Missing header/footer in Allmon

Hi all
I have set up Allmon2 and apache2 on my hub node in the cloud. I have followed all the instructions but now I am not so sure.
When I connect to index.php I get the Allmon2 text page but no header or footer. Without the Allstarlink header, none of the menus appear either.
I have tried this with all ports open and no firewalls. I have created entries in manager.conf and edited allmon.ini.php as per the instructions.
What have I done wrong here?
Thanks for your help
Simon VK3GTO

You must be missing some files. How did you install Allmon and on what platform?

I installed ASL from the buster repo onto a Debian (Ubuntu) build. I used these instructions

Perhaps I should build ASL from source instead?

Download the zip file from git and unzip it in the /var/www/html directory. That should create an allmon2 directory with all the files.

Did that, then copied allmon.ini.txt to allmon.ini.php, edited that to reflect the manager.conf settings.
Still the same issue.
For some reason header.inc and footer.inc are not being called but I can ping www.allstarlink.org from the node. In fact if I go to http://hub.node/AllMon2-master/header.inc it does resolve successfully.
Weird - anything else I should try?

Update: interesting if I try to run the index.php from the command line I get these warnings:
PHP Notice: Undefined index: REQUEST_URI in /var/www/html/AllMon2-master/header.inc on line 3
PHP Notice: Undefined index: SERVER_NAME in /var/www/html/AllMon2-master/header.inc on line 7
webserver is apache2
Is this relevant?

Rename the directory and see if that helps. ie:

mv AllMon2-master allmon2

Going to take a quick guess …
check your file permissions for the header and footer and ownership as well.

Did you do the cp allmon.ini.txt to allmon.ini.php
cp controlpanel.ini.txt to controlpanel.ini.php???

If you did one and not the other that may be where your issue is.

Hi guys
I followed the installation instructions and the suggestions in the list here. Thank you for your help, however it still does not display the header/footer. For the time being I have given up on this, might pick it up when time permits.
Simon VK3GTO

Update: I have just created another hub server and it now works!
Difference this time is that I installed DVSwitch package - although that should make no difference.
Anyway, I’m happy now and thanks to everyone.
Simon VK3GTO