Maxtrac and RA-40 interface

I am building another node using a Maxtrac UFH radio and a RA-40 interface and a Raspberry pi 3. The issue I am having is I have a terrible ground loop. If I use a jumper to ground the radio to the RA-40, the loop goes away. However when I do that, my dtmf tones do not decipher. When I remove the ground, I can. I see this using the CLI client. That is how I can tell it works without a ground but not with it. Any Ideas on how to stop this ground loop and still have dtmf. The only other thing I have tried is making sure I have good ground from the pi to the interface. That is good however, does not ground the radio. I am using the 16 pin on the back of the radio

Turn on the CTCSS filter. That’s a very common reason DTMF doesn’t work.