Iaxrpt - Call attempt failed

I am a new user to AllStar Link. I now have my node setup and working using a Shari-Pi system and can also control it through Supermon. I would like to use ‘iaxRpt’ to connect to AllStar Link via my PC instead of using my radio. I’ve carefully followed the iaxrpt setup directions, including watching a few videos. In spite of that, when I hit the “Connect” button in iaxRpt I get a “Call Attempt Failed”
message as well as the following message from the Adterisk Client:

ERROR[2508] chan_iax2.c:4411 handle_call_token: Call rejected, CallToken Support required. If unexpected, resolve by placing address in the calltokenoptional list or setting user iaxrpt requirecalltoken=no

I can’t find a calltokenoptional list and tried setting user iaxrpt requirecalltoken=no but that didn’t make any difference.

If any has a suggestion as to what I am doing wrong or what the problem is, I’d sure appreciate it.

Steve K8ZBE

Steve, can you first verify the password you used in your iaxrpt stanza in iax.cof = what you are using in the program,

and then post that stanza here minus that password.

And post it’s stanza entry in extensions.conf as well.

Not sure if shari handles any of this differently, but I will say some of the instructions posted are for different variants of the program. And there is more than one method to set it up depending on what you desire in operation.
So, let;s see what you have and we will look for error.


Thanks so much for getting back to me. As for the password, I’ve double-checked that and, as far as I can tell, the password doesn’t seem to be the problem.

Here is the stanza from iax.conf … with my password x’d out:

; add a password of your selection for secret
secret=xxxxxxxxx ; PASSWORD

and here is the stanza from extensions.conf


Hopefully there is something I am missing!

Mny Tnx,

This looks OK if I’m not missing anything.

You are using iaxrpt as a user name.
The context is pointed and received correctly.

Lets look at the program set-up…

Perhaps common is describing the iax port used on the same line as the ip for the node is placed…
like this…
IP colon PORT

Give that a check/try


If you are referring to the “account” I set up in iaxRpt I’ve already done that. Here is a screen capture of my account setup.


next logical thing is to say that one,
you can not use off characters in the password. Can’t remember which ones are out.
And two, you can’t have any leading or lagging spaces (happens if you do a copy / paste sometimes)

Perhaps change the password to a simple ‘test’ for a test typed in.
Don’t forget to restart the server after changes for testing.

Also make sure at least one of the allowed codec’s are enabled in the software program.


My original password was just a set of lower-case letters but I tried ‘test’ just to be safe. The same result … Failure to Connect.

Perhaps your comment about allowed codec’s is related to the problem … but, not being ashamed to show my ignorance … I admit to not knowing what a codec is or how to check
them. If you don’t mind elaborating, I certainly would check that.


Certainly, (thanks for just admitting that to resolve, many will not)

Generally, the codec’s are coder/decoders converting audio analog to digital or visa-versa

There are particular formats each having different quality and cpu/stream bandwidth.

If you look in your stanza, you have explicitly allowed two codec’s and rejected anything else.
asterisk has a negotiation procedure in handling this you can read about but,
the codec has to exist. And I am sure it does, but the software (iaxrpt) may be only requesting codec’s you have specifically allowed.

The iaxrpt software has settings for this… check
options > preferences > codecs

And make sure one or both of those two codecs are selected.
By chance, you may have to restart the program, but I don’t think so.
I would deselect anything that is not gsm or ulaw. Those are the common standard if you have no reason to change it. This is a global setting in the software I believe. So you may have a reason to increase the codec’s used or even tried in some future scenario. Keep it to a minimum of what might be needed so there are not so many ‘tries’ and speeds things up.


First of all, thanks for the explanation of codec’s. I certainly would have never even thought of that as an issue.

That being said, in iaxRpt, both ‘GSM’ and ‘u-law’ are selected as Allowed Codecs and ‘GSM’ was chosen as the Preferred Codec. I changed to ‘u-law’ as the Preferred Codec but in both cases, I still get “Failed to Connect”. So far, it seems that everything has been set up properly. Needless to say, if you have any other suggestions I will try them. In the mean time, I am starting to wonder if I should at least try a second computer.

Why not just do what the error tells you to do? Add requirecalltoken=no to the iaxrpt stanza in iax.conf.

Or if you have some concern about security and don’t want to disable tokens altogether, you could lock it down to the one IP address with calltokenoptional=

Thanks for the suggestion. Actually, I tried adding ‘requirecalltoken=no’ to the iaxrpt stanza early on before I started this topic and it didn’t help.


What version of ASL are you running, 1.7 or 2.0? I have iaxRpt Windows running on both versions. Each version required different configuration in rpt.conf.

Hi Sean,

A good question to which I am not sure I can answer directly. I set up my node using the instructions from the following disk image:



Ok, you are running version 1.7. It took me 5 hours of trial and error to get it to work with iaxRpt Windows. To start,I had to run both the USB and Dahdi channel drivers. Under your node section [44227] See below …

Also in RPT.CONF in the MISC Settings section under your node ID [44227] section I had to add these three lines to get the keypad to function.

When you get things working you might like these audio settings:

I see you have made the addition to IAX.CONF of “requirecalltoken=no” under [iaxrpt].

In IAX.CONF verify you have your node ID and password issued to you when you first requested your server and node from Allstar.
Under [radio-proxy-out]

Your previous post changes look correct.
Hope this helps.
Sean - K3XT

Are you still having issues or have you solved this.
I might say a few things here.

You do not need or want multiple channel drivers enabled for the same node unless you have a very specific reason for doing so, which I highly doubt.

iaxrpt connects to a valid ‘iax asterisk system’ no matter the channel driver. It does not know.

I had assumed probably incorrectly that you have been using this node already to connect to/from.
But if this is your first interface
Look in iax.conf at bindaddress=
it should be to allow any ip to connect to your iax.

It may be why you are not able to connect.
Go back to your original settings you had if this was the case with bindaddress as they looked very much correct. But don’t forget to save and restart on changing the config.

Or, let me know how you stand now.