IAX Trunk and getting SIP messages on SPA

I have a IAX trunk between Free PBX and allstar. It seems that allstar is sending all the extensions connected to it a message with all the connected nodes. Is there a setting to turn this off?

It could be but not that I am aware of.

I think you will need to adjust how your freePBX box handles the text telemetry to get what you want.

Perhaps someone knows better than I ?

On the theory side of this, you might try creating your trunk outside of the asterisk ‘RADIO CHANNEL’
so that channels rules do not apply. But it is a function of IAX2 and at the heart of how app_rpt all works.

That does look like the messages i am getting. Something seems to be sending them over and over.

After considering your title, I understand you are seeing this on your sip phone.
I thought it was a issue on the freepbx system.

This is normal and as I said above, a built in function of app_rpt in how it handles what it is doing or has done in exchange with connected systems.

You will have to stop it at the end source where you see it. Guessing your sip phone.
You should be able to stop text within the device itself. On a normal phone system, it would display transfers and other like data, but our system is a radio extension in conference mode.

It displays on my sip phones and can be annoying at times when you use the phone a bunch.
Mine have a one-button clear.
My phones can turn it off. But I have to set that in the firmware/phone setup.
Most default to ‘on’ for text messages. I am sure yours is similar.

The messages are not send repeatedly. If that’s what you are saying then there is something wrong. Please tell us more about exactly what you are seeing.

The SPA gets a message with a list of all the links (global links). Once pressing OK to clear it, 3 seconds later it returns

Something must be requesting the global nodes list. Do you have a radio connected to this node, if so do you hear those messages on the radio?

There are several radios/repeaters connected to it indirectly. Through a hub or 2.
http://lnr.ko4uyj.com might give you an example as to how it is setup. I’m getting a message maybe every 10 seconds? That just keep coming. It would be fine if it just went once and I acknowledge it and it goes away but as often as it does It is annoying

Try setting telemdefault=0 or 2 on that node. This is a rpt.conf setting