IAX connect failure


I’m not able to connect via IAX to my nodes using iaxRpt

I double checked everything, but can’t find a reason why it fails.

The Asterisk error I get is :
NOTICE[789]: chan_iax2.c:9522 socket_process: Rejected connect attempt from, request 'Node@iaxrpt' does not exist

Searching in the previous posts, I’ve found an info saying that connections from the same LAN are not possible. Is this confirmed ?
All of our nodes do you the same IP class.

73 Patrick

iaxRpt has always been simple to set up for me. There is definitely not any limitation in using it within a LAN, and in that case it’s actually easier because you don’t have to forward the port in your router.

To access your node from outside your LAN you need to add a port forwarding rule in your router so the IAX port (typically 4569 unless you have more than one node then you could use 4570, 4571, …) will be forwarded to the node’s LAN IP address. But this is not necessary within the LAN where you are connecting directly to node’s local IP address.

Then in iax.conf on the node you need an entry like the following:

[iaxclient] ; Connect from iax client (Zoiper…)
type = friend ; Notice type here is friend <--------------
context = iax-client ; Context to jump to in extensions.conf
auth = md5
secret = put a password here
host = dynamic
disallow = all
allow = ulaw
allow = adpcm
allow = gsm
transfer = no

And in extensions.conf there should be something like the following:

[iax-client] ; for IAX VIOP clients.
exten => ${NODE},1,Ringing
exten => ${NODE},n,Wait(3)
exten => ${NODE},n,Answer
exten => ${NODE},n,Set(NODENUM=${CALLERID(number)})
exten => ${NODE},n,Playback(rpt/node|noanswer)
exten => ${NODE},n,SayDigits(${EXTEN})
exten => ${NODE},n,Set(CALLERID(num)=0)
exten => ${NODE},n,Rpt,${NODE}|P|${CALLERID(name)}
exten => ${NODE},n,Hangup
exten => ${NODE},n(hangit),Answer
exten => ${NODE},n(hangit),Wait(1)
exten => ${NODE},n(hangit),Hangup

Then set up an account in iaxRpt such as the following:

Make sure to use the same port # as the node is set up for in iax.conf eg. bindport = 4569

iaxRpt defaults to 4569 in which case you don’t have to add the port# to the Host address, but if not 4569 then suffix it to the Host address as shown above.

Thanks David,

I have setup my configuration according to the following page :

It differs a little from your settings that are those I could find in the original configuration files.
The main difference is the type = friend or user

But no way to make it work, I still have the same error reported in the Asterisk CLI.
NOTICE[1213]: chan_iax2.c:9522 socket_process: Rejected connect attempt from, request 'Node@iax-client' does not exist

Nothing special in the logs.
I’m stucked.

Can you post a screenshot of the account settings page in iaxRpt?

iaxRpt :



iaxRpt “Account Name” field must be your ASL Node Number.

“Node 100” will not work and is why you are getting an error saying “request ‘Node@iax-client’ does not exist”.

David, you made my day !!
Stupid I am… :weary:

It works now.

Thanks a lot and 73,

Ha ha,

While the bargraph on the iaxRpt is moving when there is activity, I can’t hear anything in the PCs loudspeaker.
I’ve selected the right device, that works with all other apps.

I’ve no microphone to connect yet, is it mandatory ?

The transmit button works, my node is keying.

73 Patrick.

Switch between the speaker and headset in the app.(button)
Mic is not mandatory to listen.

I tried this, but no success.
I’ve also tried with a headset.

Everything seems to be working, except that iaxRpt never appears in the Windows sound mixer.

73 Patrick

Have you selected the correct audio device within the program ?

And when you change the ‘audio’ settings, sometimes better results come from restarting iaxrpt.

For testing, I would select a new device in the program setting for both the headset and speaker (same), restart and test.

If it is not showing up in win mixer, then you have no attachment to win sound at all.

Yes, at times these can be a bit tricky.

Thanks Jim,

Yes, I’ve noticed that iaxRpt isn’t very stable at some regards.

For testing, I’ve connected an external USB audio adapter and have selected its microphone input as iaxrpt input device.
And very strangely, without changing the output device, the PC internal audio adapter is now working normaly, I can hear the traffic.

Before concluding anything, I’ve to solve a problem with my DELL optiplex 3060 computer audio sound system. I can’t make it detect a microphone (Samsung phone headset) .
Both headphone channels are working, but no microphone detection.

Reinstalling drivers didn’t help.
I must check if there is no problem with the jack connector or if the headset is compatible. I know there are 2 kinds of wiring OMTP and CTIA.

73 Patrick

Your problem lies in your windows sound drivers and the interface in widows to them.
Specifically, often it is what is managing them. Windows or the manufacturer software.

While I can not get real specific with that, I might say that one path to try would be to boot windows in safe mode and remove all the sound drivers. Then install only the one windows will provide on a reboot.
May or may not help. But this is the area you should poke around.

For your test, set speakerphone and normal calls with the same devices.

Also know that often a change in sound settings sometimes requires a program restart.

One last thing…
Sometimes when you can clearly see device manufacturer software in the system… i.e. in the system tray, you may need to uninstall it. That’s part of the driver ‘management’ and often they bypass some of windows interface protocol.


Yes, I clearly have a Windows/hardware problem.
I can’t get my internal sound devices to show up a input device.
All my tests an mods didn’t help.

As soon as I connect an external sound card, a input device appears and iaxRpt works.

That might also confirm that iaxRpt NEEDS an input device.

73 Patrick

iaxRpt has no issues on my Win7 PC, shows MS sound mapper as an option as well as individual devices. Are you running Win 10 or 11? I would suspect that could be the issue since iaxRpt is an older program (mine shows a build date of 2011).


As I mentioned before, if you have manufacture supplied software management for the sound device, they most often bypass windows in doing so for many reasons. Most often these are in big manufactured PC’s like Dell, HP etc.

If you go to your control panel and uninstall that, reboot, go to control panel again and edit/re-point the sound devices, I bet you get better results.

Hi Mike,

I’ve made everything possible, at least in the limits of my knowledge.

I upgraded BIOS, checked in BIOS if the audio device/microphone is enabled.

Upgraded DELLs Realtek driver. Uninstalled it, using Windows native drivers, safe mode, etc, etc…
Reading forums, didn’t help either.
I’m starting to think that I have a hardware issue.

But nothing to do, my PC doesn’t find any input device, only the speakers as output.

Nothing to do with iaxRpt that works as soon as I connect an external sound fob.

I might try a Linux live to be sure it’s not Windows related.

73 Patrick

I’ve made a bootable USB stick with Linux Mint.

Guess what ?

It shows up the microphone input correctly and I could monitor my connected microphone !

So, NOT a hardware issue ! Dawn Windoz…

73 EP

Patrick, you could have done about anything with those drivers and it would not matter if the device management software is still in place.
It causes a bypass of normal windows functionality (published spec). And that is why your iaxrpt attachment can not be made.

Often the big PC box manufactures integrate that OEM.

I see it with sound, video and network devices where they use them.
You will have to go to the control panel and locate it in software and uninstall it.