How to use a URI on QTH to connect to a node on VPS

Good morning, would this be a complicated task? URI is attached to pi which has allstar as well, just a different node, which handles a different region. I want to listen to the VPS’s traffic via RF on my QTH with this unused URI.

Thank you.

Something in what you are saying seems to be incomplete… or just not understood by me.

Can’t you just run a connect command from one node to the other…
Are you saying the Pi node has no Allstar ? If so, as long as it has internet, it is easy.

Hello Mike, happy new year. I do not connect both nodes because, QTH node connects to Central America, with Echolink enabled for these connections(very popular here in central america) , and VPS nodes I use for english language nodes, Alaska morning net, etc. But I just wanted to listen to the VPS node via RF at home instead of via software. So I did read a very nice article on how to connect to the ASL node wherever one may be by using some sort of proxy feature in ASL, I cannot recall exactly the article, but if it is something I can edit on QTH’s ASL as to register the URI to the VPS node, taking advantage of having the software running on this QTH’s pi already. Thanks for your reply.

There are two methods I know of to do this,
But, let’s keep it simple.
As long as you are using app_rpt/Allstar on both systems…
In RPT.conf, where you might describe your local nodes,
Create what looks like a local private node only not.
Add a definition for the node with IP/PORT like the others

49999 = radio@,NONE ;use ip of other node and node#?

In the exp above, the fist 49999 is your local number, the second is the number at the other end to connect to.

This will be the number that is used in the connection string. It would be advisable to use a number in the private area under 2000. But the best easy method would be to match the number of the node at the other end. Could be a problem. You will have to test it that way and if it connects to the wrong network, you will need to make a private node of matching number at the other end to connect to.
If you understand how the connection routing system works, you can do better than I have time to describe here.

I think you should try private nodes at each ends to be safe.

And be sure to add it to the extensions as well.

But, you can also get a registration string from the other network if you examine the criteria they use for conflict and isolate it in routing.

Thanks, Mike. In order to be as clear as possible:
Node 48455 located at QTH. This is where URI resides.
Node 48270 located at VPS

1.- I would need to create a private node stanza on 48455, specifying channel type usbradio in order to use URI, I will number it 1002. I do not know for sure how much data is comprised under a node stanza, I think maybe if I use up to before the eanmode settings should do.

2.- Then, I would need to go down to the nodes section, and put:

3.- in extensions.conf, and using this new node as node number 3:
NODE3 = 1002

exten => ${NODE3},rpt,1,rpt,${NODE3}

This would take care of QTH side of connections. Do I just replicate step 2 and 3 on VPS side? Did I understand correctly? Thanks.

Thanks Mike, it worked. I did reverse the IP Address on step 2 on VPS to reflect QTHs IP. How cool. 73

Sorry about my reply… I was in a hurry and walked away after I sent it.
It looks like it was enough though.

I would say for anyone who has a local emergency communication network, you can do the same for your nodes and specify your connections the same in case of network registration failure.
If all have static ip’s. But you still need to have internet of course.
That is how I figured it out 10 years ago for local ecom network.

When I started running VPS’s, I had made connects similar, but stopped them because I would not realize when my registration system had a issue connecting external till I needed it, which may be a long time sometimes.
I would rather know ASAP so it can be repaired and ready.

Anyway, glad you have it working.

No worries Mike. Is there a Wiki article about this? The only thing I noticed is that I do not get the courtesy tone at the EOT when it comes from the node, as I would hear it when connected via software to the node itself. Also, DTMF tones do not traverse, which for now I do not have an issue since the node is on a 5/8 antenna horizontally mounted on my garage, on purpose, so it does not go out so far, and it has T.SQL enabled to deter RFI, so I have to switch nodes directly, but I would like to be able to do this. Also, as I started adding hangtime, althangtime and totime (these settings are a little bit further down into the node settings that come with the software where I was to paste into the private node) the private node responded accordingly, because it had a tail of about 5 seconds when left alone without the settings I originally added, so maybe the DTMF section may have to be added onto the 1003 node stanza.


No wiki… I am writing some on other complex topics, none finished, but busy now.
Perhaps I’ll put it on the list for how2 direct ecom connections.

I don’t navigate the wiki well and it takes me a while to get the right words in fair understandable order.

Fine Business, Mike, thanks for your guidance. I will say, when switching from RX Only to Transcieve, I did get the EOT tone on my side (RF), still no DTMF traversing to the node (*70,*722, etc.)