How to stop loaded asterisk on startup

Hello to all,
when starting ASL I would like to start the asterisk service manually and not automatically. I tried to disable the service at startup but it doesn’t work. Any ideas about it?

systemctl disable asterisk

Hi Mike,
thanks for your reply.
Your commands not works.
At boot asteriks normal start.

You must have administrator access rights or use sudo (super user)

sudo systemctl disable asterisk

On the 2.0 beta the service file is asl-asterisk. ie sudo systemctl disable asl-asterisk. That should prevent startup on boot.

There are a few scripts you might find useful if you’re a CLI kind of person for starting, stopping and restarting, and

1 Like

Thanks Tim.
I did not know of the change in the ASL beta.

Thanks everyone for the replies
unfortunately, even using your indications the problem is not solved.
Asterisk always starts at boot!
Too bad I just need to get it started on command.

Try this in this order.

sudo systemctl stop asl-asterisk
sudo systemctl disable asl-asterisk

reboot & check.